Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: no bootable device found

  1. #1
    Join Date
    Aug 2011
    Beans
    16

    no bootable device found

    Dear folks

    I know that Ubuntu runs on my laptop because I have already had installed the OS on my Laptop

    A Acer Aspire 3810T. Yesterday I received my new Samsung Spinpoint M8 1TB drive.

    I first wanted to install MAC OS onto it and everything worked fine - the I noticed that my hardware isn t fully supported by MAC OS and I ditched it! Durhin the installation process I changed the hard drive to GUID partition table!

    Now everytime I install ubuntu installation runs fine but after the installation (when ubuntu should start) it shows

    "No bootable device found"

    Do you think that this is the problem and if yes: how can I fix it?

    btw win7 installs just fine but I think that doesnt help.
    There is no needed data on the hdd - everythin can be wiped completely.

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: no bootable device found

    If you are only going to have Ubuntu on the 1TB drive ever, you should leave it as gpt. But you have to create a bios_grub partition if booting from BIOS or an efi partition if using UEFI.

    GPT fdisk Tutorial -srs5694 in forums
    http://ubuntuforums.org/showthread.php?t=1439794
    http://www.rodsbooks.com/gdisk/

    GPT Advantages srs5694:
    http://ubuntuforums.org/showthread.php?t=1457901
    GPT or MBR
    http://ubuntuforums.org/showthread.php?t=1625285

    However, in the GPT setup, there is no space following the 512-byte MBR for embedding the "second stage" core.img. Thus, you must make a separate "BIOS boot partition" to hold core.img. You can set bios_grub flag in gparted or with command line: In GPT fdisk (gdisk), give it a type code of EF02.
    BIOS Boot Partition of about 100 KiB to 1 MiB.

    sudo parted /dev/sda set <partition_number> bios_grub on

    It only needs to be about 32 KiB in size, although in most cases make it 1 MiB because of partition alignment issues
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Aug 2011
    Beans
    16

    Re: no bootable device found

    I want to only install Ubuntu and nothign more and currently I want to keep it as simple to only know if it works.

    Before I read your post I changed the partition table to MBR already. Unfortunately this doesn t change much.. instead of the error message

    "no bootable device found" I now only see a blinking coursor...

    please give me some advices

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: no bootable device found

    No bootable device is often a BIOS error, but I thought it was only with Intel motherboards/BIOS. Some BIOS check to make sure there is a boot flag on a primary partition. Grub does not use nor need a boot flag, windows has to have one on a primary partition. It seems some BIOS check for boot flag and do not let grub work without one or assume windows.

    Try putting a boot flag on any primary partition. (We even have to do that with some gpt systems even though gpt also does not use a boot flag normally.)
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #5
    Join Date
    Mar 2010
    Location
    Woonsocket, RI USA
    Beans
    3,195

    Re: no bootable device found

    If you changed from GPT to MBR in a way that left the OS intact, you'll need to re-install GRUB, since GPT and MBR use different boot loader code.

    At this point, if you can't get it working, it's probably best to do one of two things:


    • Re-install from scratch, either to an MBR disk or to a GPT disk that contains a BIOS Boot Partition, as oldfred suggested; or
    • Boot using an emergency system, run the Boot Info Script, and post the RESULTS.txt file that it produces here. Be sure to post it between [code] and [/code] tags for legibility.
    If I've suggested a solution to a problem and you're not the original poster, do not try my solution! Problems can seem similar but be different, and a good solution to one problem can make another worse. Post a new thread with your problem details.

  6. #6
    Join Date
    Aug 2011
    Beans
    16

    Re: no bootable device found

    I tried boot info script but it gave me an error -.-

    this is what I tiped into the terminal:

    ubuntu@ubuntu:/media/System-reserviert$ sh boot_info_script.sh

    and this is what I got

    Code:
    boot_info_script version: 0.60        [17 May 2011]
    
    
    "gawk" could not be found, using "busybox awk" instead.
    This may lead to unreliable results.
    
    [: 326: busybox awk: unexpected operator
    boot_info_script.sh: 353: Syntax error: "(" unexpected (expecting "fi")
    ubuntu@ubuntu:/media/System-reserviert$ sh boot_info_script.sh
    
    boot_info_script version: 0.60        [17 May 2011]
    
    
    "gawk" could not be found, using "busybox awk" instead.
    This may lead to unreliable results.
    
    [: 326: busybox awk: unexpected operator
    boot_info_script.sh: 353: Syntax error: "(" unexpected (expecting "fi")
    ubuntu@ubuntu:/media/System-reserviert$
    is it because "gawk" is missing?
    I think I have to set the boot partition you two mentioned manually.

    Because I have never done setting up the boot partition before I thought it is a good idea to first install Windows7 (which sets up the boot partition automatically as you told) and then install ubuntu to see if this will lead to success. Afterwards I could then do the whole thing manually and get rid of win7.

    This didn t work for me because the Ubuntu setup doesn t see the installed windows at all and just gives me the option to install Ubuntu or to partition manually - normaly there should be the option "Install Ubuntu besides Windows7"?!

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: no bootable device found

    Had exactly the same error in another thread. You need to use sudo.

    Command posted here:
    http://bootinfoscript.sourceforge.net/

    sudo bash ~/Desktop/boot_info_script.sh

    or if you have cd into folder

    sudo bash boo{tab} #if you hit tab it will complete line automatically.
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #8
    Join Date
    Aug 2011
    Beans
    16

    Re: no bootable device found

    worked like a charm with sudo

    here are the results:

    Code:
    Boot Info Script 0.60    from 17 May 2011
     
     
     ============================= Boot Info Summary: ===============================
     
      => Windows is installed in the MBR of /dev/sda.
      => Syslinux MBR (4.04 and higher) is installed in the MBR of /dev/sdb.
     
     sda1: __________________________________________________  ________________________
     
         File system:       ntfs
         Boot sector type:  Windows Vista/7
         Boot sector info:   No errors found in the Boot Parameter Block.
         Operating System:  
         Boot files:        /bootmgr /Boot/BCD
     
     sda2: __________________________________________________  ________________________
     
         File system:       ntfs
         Boot sector type:  Windows Vista/7
         Boot sector info:   No errors found in the Boot Parameter Block.
         Operating System:  Windows 7
         Boot files:        /Windows/System32/winload.exe
     
     sdb1: __________________________________________________  ________________________
     
         File system:       vfat
         Boot sector type:  SYSLINUX 4.04 2011-04-18
         Boot sector info:   Syslinux looks at sector 2185080 of /dev/sdb1 for its 
                            second stage. SYSLINUX is installed in the  directory. 
                            The integrity check of the ADV area failed. No errors 
                            found in the Boot Parameter Block.
         Operating System:  
         Boot files:        /boot/grub/grub.cfg /syslinux/syslinux.cfg /ldlinux.sys
     
     ============================ Drive/Partition Info: =============================
     
     Drive: sda __________________________________________________  ___________________
     
     Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
     255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
     Units = sectors of 1 * 512 = 512 bytes
     Sector size (logical/physical): 512 bytes / 512 bytes
     
     Partition  Boot  Start Sector    End Sector  # of Sectors  Id System
     
     /dev/sda1    *          2,048       206,847       204,800   7 NTFS / exFAT / HPFS
     /dev/sda2             206,848 1,953,521,663 1,953,314,816   7 NTFS / exFAT / HPFS
     
     
     GUID Partition Table detected, but does not seem to be used.
     
     Partition    Start Sector    End Sector  # of Sectors System
     
     Drive: sdb __________________________________________________  ___________________
     
     Disk /dev/sdb: 3984 MB, 3984588800 bytes
     128 heads, 10 sectors/track, 6080 cylinders, total 7782400 sectors
     Units = sectors of 1 * 512 = 512 bytes
     Sector size (logical/physical): 512 bytes / 512 bytes
     
     Partition  Boot  Start Sector    End Sector  # of Sectors  Id System
     
     /dev/sdb1    *             63     7,782,399     7,782,337   b W95 FAT32
     
     
     "blkid" output: __________________________________________________  ______________
     
     Device           UUID                                   TYPE       LABEL
     
     /dev/loop0                                              squashfs   
     /dev/sda1        5204169D041683DF                       ntfs       System-reserviert
     /dev/sda2        38541BA3541B6344                       ntfs       
     /dev/sdb1        725C-5E17                              vfat       
     
     ================================ Mount points: =================================
     
     Device           Mount_Point              Type       Options
     
     /dev/loop0       /rofs                    squashfs   (ro,noatime)
     /dev/sdb1        /cdrom                   vfat        (ro,noatime,fmask=0022,dmask=0022,codepage=cp437,i   ocharset=iso8859-1,shortname=mixed,errors=remount-ro)
     
     
     =========================== sdb1/boot/grub/grub.cfg: ===========================
     
     --------------------------------------------------------------------------------
     
     if loadfont /boot/grub/font.pf2 ; then
         set gfxmode=auto
         insmod efi_gop
         insmod efi_uga
         insmod gfxterm
         terminal_output gfxterm
     fi
     
     set menu_color_normal=white/black
     set menu_color_highlight=black/light-gray
     
     menuentry "Try Ubuntu without installing" {
         set gfxpayload=keep
         linux    /casper/vmlinuz  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
         initrd    /casper/initrd.lz
     }
     menuentry "Install Ubuntu" {
         set gfxpayload=keep
         linux    /casper/vmlinuz  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash --
         initrd    /casper/initrd.lz
     }
     menuentry "Check disc for defects" {
         set gfxpayload=keep
         linux    /casper/vmlinuz  boot=casper integrity-check quiet splash --
         initrd    /casper/initrd.lz
     }
     --------------------------------------------------------------------------------
     
     ========================= sdb1/syslinux/syslinux.cfg: ==========================
     
     --------------------------------------------------------------------------------
     # D-I config version 2.0
     include menu.cfg
     default vesamenu.c32
     prompt 0
     timeout 50
     
     # If you would like to use the new menu and be presented with the option  to install or run from USB at startup, remove # from the following  line. This line was commented out (by request of many) to allow the old  menu to be presented and to enable booting straight into the Live  Environment! 
     # ui gfxboot bootlogo
     --------------------------------------------------------------------------------
     
     =================== sdb1: Location of files loaded by Grub: ====================
     
                GiB - GB             File                                 Fragment(s)
     
                 ?? = ??             boot/grub/grub.cfg                             1
     
     ================= sdb1: Location of files loaded by Syslinux: ==================
     
                GiB - GB             File                                 Fragment(s)
     
                 ?? = ??             ldlinux.sys                                    1
                 ?? = ??             syslinux/gfxboot.c32                           1
                 ?? = ??             syslinux/syslinux.cfg                          1
                 ?? = ??             syslinux/vesamenu.c32                          1
     
     ============== sdb1: Version of COM32(R) files used by Syslinux: ===============
     
      syslinux/gfxboot.c32               :  COM32R module (v4.xx)
      syslinux/vesamenu.c32              :  COM32R module (v4.xx)
     
     =============================== StdErr Messages: ===============================
     
     /home/ubuntu/Desktop/boot_info_script.sh: line 1579: [: 2.73495e+09: integer expression expected
    as mentioned before I insrtalled win7 in hope that it sets up the boot partition automatically but as final result I only want to have Ubuntu.

    EDIT: The entrys of my USB stick with the Ubuntu setup are also in the RESULTS.txt but I think you already noticed that at first glance xD
    Last edited by HLS69; August 7th, 2011 at 09:39 PM.

  9. #9
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: no bootable device found

    Windows will not work on gpt partitioning ( unless you use UEFI) and it looks like you have some bits of gpt left even though windows has converted to gpt.

    I do not want to steal srs5694 thunder as this is his program, but not sure how soon he may post.

    FixParts is the easiest way to remove the stray GPT data. GPT fdisk (gdisk or sgdisk) can do it, but the procedure's a bit more involved.
    http://www.rodsbooks.com/fixparts/
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  10. #10
    Join Date
    Mar 2010
    Location
    Woonsocket, RI USA
    Beans
    3,195

    Re: no bootable device found

    If you intend to keep Windows, as it's installed in the MBR, your first step should be to get rid of the stray GPT data, as oldfred suggests. From there, you should be able to resize your Windows partitions (which is most safely done within Windows) to make room for Linux, add Linux partitions (which you should not do in Windows!), and install Linux. This should work if you installed Windows after installing Linux and if the Windows filesystems are intact.

    If you installed Linux after you installed Windows, it could be that Linux is installed using GPT but that the MBR data reported by Boot Info Script is hiding the GPT partitions. If this is the case, the GPT and MBR partitions doubtless overlap, and there's no telling which is intact and which has been damaged. In this situation, it's best to delete everything and start from scratch:


    1. In the Ubuntu installer's "try it now" mode, launch a shell and type "sudo apt-get install gdisk".
    2. Type "sudo sgdisk -Z /dev/sda". (This assumes that /dev/sda is the disk you want to wipe clean and re-use. Verify this identity first if you have any doubts about it.) This command erases all the MBR and GPT data on the disk, making it safe to re-use it.
    3. Do one of two things:

      • If you want to dual-boot with Windows, you should reboot and install Windows, giving it as much disk space as you want it to have. The Windows installer will create a fresh MBR partition table.
      • If you don't want to dual-boot with Windows (if you want a Linux-only installation), you must decide whether to use MBR (old and well-understood by many people) or GPT (new and with some improvements over MBR, but less well-understood by most people) for your partitions. Launch GParted and select Device -> Create Partition Table. Click Advanced and select either "msdos" (for MBR) or "gpt" (for GPT). If you choose GPT, create a ~1 MiB partition with no filesystem and set the "bios_grub flag" on it. There's no need to create any special partition for MBR at this point (the Ubuntu installer will do that).

    4. Reboot and install Linux, using its partitioner to create partitions.
    If I've suggested a solution to a problem and you're not the original poster, do not try my solution! Problems can seem similar but be different, and a good solution to one problem can make another worse. Post a new thread with your problem details.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •