Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: <USER> is not in the sudoers file. This incident will be reported.

  1. #11
    Join Date
    Mar 2010
    Beans
    Hidden!

    Re: <USER> is not in the sudoers file. This incident will be reported.

    Quote Originally Posted by mendhak View Post
    I was suggesting it in order to rescue the sudoers file, which he can't get to with a normal sudo.
    To set the root password requires the use of sudo, which in this case has been broken. The best bet for the OP is to look into the link in WorMzy's post or post back the output for bodhi.zazen.

    Use of the root account is not supported here (Canonical have it locked as default). Posting instructions for unlocking it is against forum policy (lucky you didn't do that ). Hence the response to your post suggesting the use of the root account and su (which normally won't work in Ubuntu for root). Hope this helps explain the reaction/response earlier.
    Last edited by CharlesA; August 8th, 2011 at 04:02 PM. Reason: Snipped some bits

  2. #12
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: <USER> is not in the sudoers file. This incident will be reported.

    You can drop to recovery mode to get to a root prompt - that will allow you to fix the sudoers file.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  3. #13
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,479
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: <USER> is not in the sudoers file. This incident will be reported.

    Quote Originally Posted by CharlesA View Post
    You can drop to recovery mode to get to a root prompt - that will allow you to fix the sudoers file.
    To explain: On a dual-boot system, the GRUB menu appears on startup. On a single-boot system, you hold down the Shift key while starting up and it brings up the GRUB menu.

    You'll see a list of installed kernels. Basically, you choose the second one in the list - it'll have "Recovery Mode" in its name. Then you can just run:

    Code:
    visudo
    and change back whatever you changed.

    You've learnt the hard way: It's not a good idea to mess with the security system. You're just setting up your system at the moment which is why you get a fair few authentication dialogs and why they seem annoying at first. Once you've set up your system, you'll rarely get them anyway.

    Making the modification you described doesn't remove all authentication dialogs anyway. It just stops the 'gksudo' ones from appearing. Any related to Policykit, such as Software Center or Gnome authentication dialogs, will continue to appear. Can't be stopped either as far as I know; you really don't want to because things will probably break, or you'll loosen your computer's security to the point where a script kiddie will 0wn your computer. If you're going to make your computer insecure, you might as well do it the quick way and install Windows XP.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  4. #14
    Join Date
    Aug 2011
    Beans
    3
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: <USER> is not in the sudoers file. This incident will be reported.

    Thanks for all of the help guys, problem solved

  5. #15
    Join Date
    Jun 2006
    Beans
    Hidden!

    Re: <USER> is not in the sudoers file. This incident will be reported.

    Hey, I switched my desktop from Ubuntu back to CentOS 6. But it'll be a while before I break the sudo habit. Network Manager complains if I add myself to sudo, refusing to connect to the network for "security reasons". So that was not a simple option.

    I got so annoyed at that whiny "I'm gonna report you!" message, that I went in with a binary editor and changed it to a less annoying "The incident will be concealed." (Yes, it's really hard-coded into the sudo binary.)

    Re-establishing the "su" habit is now much less irritating.

    -Steve
    First they ignore you. Then they laugh at you. Then they fight you and squash you like a bug.

    - Forgotten Militant

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •