Page 4 of 4 FirstFirst ... 234
Results 31 to 31 of 31

Thread: iMac G4 24-bit Color

  1. #31
    Join Date
    Sep 2007
    Location
    Milwaukee, WI
    Beans
    268
    Distro
    Ubuntu Development Release

    Re: iMac G4 24-bit Color

    Well, I couldn't find a VGA cable, but I did notice in kern.log, that it looked like the card was trying to output on the TV-out (an output my card doesn't even have).

    That link to KMS info helped a lot. I already knew how to enable/disable it, but there's a short section on forcing different modes from kernel arguments, and it demonstrates how to force the card to use the DVI connector.

    Booting with
    Code:
    video=DVI-I-1:1440x900@60
    as a kernel argument gets me further than before. Now the screen doesn't go black, instead the Xserver fails to load, and I'm left with a text login. I tried logging in and starting X, but, as expected, I get the same error as when X tries to load itself on boot.

    I attached my Xorg.log file, and the part where it seems to go bad is below:

    Code:
    II) Primary Device is: PCI 00@00:10:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: Searching for BusID pci:0000:00:10.0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: drmOpenMinor returns 7
    drmOpenByBusid: drmGetBusid reports pci:0000:00:10.0
    (EE) [drm] failed to open device
    (EE) No devices detected.
    
    Fatal server error:
    no screens found
    The only thing that I can see, is that it looks like nouveau is looking to PCI address 00@00:10:0, which is not the address specified for the graphics card in Xorg.conf (0:0:16:0). I'm kind of beyond my skills here. Is nouveau looking to the wrong PCI address, or am I misreading the log?

    I think I'm going to make a new thread for the Powermac. Both the Powerbook and iMac all will boot the live-CD and run X from it using nouveau. The Powermac (with a Geforce 6200) is the only one I can't get to run the live-CD. I can now get it to boot the CD to a text login by appending the kernel argument I posted earlier, but as soon as I "startx" it all goes to hell again. Nouveau really doesn't like this card for some reason or another...



    **edit**
    Just realized 00@00:10:0 is the PCI address listed by lspci for my graphics card...
    Attached Files Attached Files
    Last edited by svtguy88; September 8th, 2011 at 11:05 PM.

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •