Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Thunar slow opening fix

  1. #1
    Join Date
    May 2006
    Location
    Lake Placid, Florida, USA
    Beans
    2,005
    Distro
    Xubuntu 14.04 Trusty Tahr

    Thunar slow opening fix

    I think I have fixed the Thunar slow opening issue in Xubuntu , I noticed Thunar opened fast as root, but took almost 30 seconds to open normally, so I figured it was a permissions issue, so I opened Thunar, clicked on File > Properties > Permissions > then set your "group" to have read & write permissions ..... that worked good for me on two systems ...

    please let me know if this works for you ,if your having the same problem on Xubuntu 11.04.

  2. #2
    Join Date
    Mar 2010
    Beans
    Hidden!

    Re: Thunar slow opening fix

    Thanks for posting this mike555, I had barely booted into my xubuntu11.04 install in well over a month because of this (was driving me mad to the point of even installing nautilus, and that's not a real good idea I've found out, but it can be done )

    The change is from 35-40 seconds to open a folder down to 1-2 seconds if that. Near instant opening at the moment (nautilus is about to be kicked out by the looks of this )

    Thanks again, this has renewed my interest in continuing trialing/using Xubuntu. yetiman64 (This is posted from Xubuntu btw )

  3. #3
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: Thunar slow opening fix

    An extra step I got:

    1. "Cannot change permissions to symlinks" dialog, so clicked on "Skip for all"

    No speed up for me, but was only about 5 seconds anyway on first run. because thunar goes into memory after that subsequent runs are much quicker.

    Did you do this as your normal user, and only on your home folder ?
    Last edited by Jose Catre-Vandis; August 3rd, 2011 at 07:02 PM.
    No longer participating......

  4. #4
    Join Date
    Apr 2005
    Beans
    191
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Thunar slow opening fix

    Like Jose Catre-Vandis, I had the extra step as well because I have a mounted partition named "data" that is symlinked in the top level of my home directory (ex. /home/rhtopics/data).

    I rebooted the computer and then brought up Thunar. Definitely noticed an improvement. Took about 1-2 seconds to bring up Thunar while before it would take around 5 seconds to bring it up.

  5. #5
    Join Date
    Mar 2010
    Beans
    Hidden!

    Re: Thunar slow opening fix

    I also skipped the symlinks, but at the time got an immediate drastic speed up.

    However since rebooting and on subsequent reboots I have now noted it is slow for about 3 or 4 minutes after startup (not as bad as before though), then drops down to a second or two for each opening. There may be a memory factor in this as well as Jose Catre-Vandis mentions.

    Considering prior to making the permissions changes it was always painfully slow for me, this is still a very good result.

    Edit: @ Jose Catre-Vandis, yes I did the changes as normal user and only on the Home Folder to get the improved Thunar opening.
    Last edited by yetiman64; August 3rd, 2011 at 10:05 PM. Reason: more info

  6. #6
    Join Date
    Oct 2007
    Beans
    7

    Re: Thunar slow opening fix

    Great tip, worked for me!

    Thanks Mike555

  7. #7
    Join Date
    Feb 2008
    Beans
    1,145
    Distro
    Xubuntu

    Re: Thunar slow opening fix

    Might be related to the gvfs issue.

    https://bugzilla.xfce.org/show_bug.cgi?id=7373
    Help yourself: Ubuntu Docs - Ubuntu Packages

  8. #8
    Join Date
    Dec 2008
    Location
    Northwest Ohio
    Beans
    1,581
    Distro
    Lubuntu 13.10 Saucy Salamander

    Re: Thunar slow opening fix

    Update: I found that gvfs-backends was the only culprit in my case. Also, It appears that gvfs-fuse is a package that is installed by default in Xubuntu 11.10, so I have installed it again and it doesn't slow down thunar for me.

    Hi
    I ended up doing something different:
    When I installed Xubuntu 11.10 (clean install), Thunar had no problems at all launching for the first time after every startup.

    Then I decided to install pcmanfm for a light file manager with a few more features, but pcmanfm installed 'gvfs-fuse' and 'gvfs-backends' (as recommends, not dependencies) too, which made Thunar very slow to start during each first launch (and it would open 2 instances of thunar on first launch too).

    So I removed 'gvfs-fuse' and 'gvfs-backends' and Thunar is very quick again, but doing this removed the networking bookmark from Thunar (that isn't something I need myself though).

    'gvfs' and 'gvfs-bin' are still installed (I found that trash applet and trash bookmark in thunar will not work without them).
    Last edited by ankspo71; November 4th, 2011 at 09:40 AM.

  9. #9
    Join Date
    Sep 2006
    Location
    Milan - ITALY
    Beans
    39
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Thunar slow opening fix

    1) gvfs-backends should be already installed in a fresh installation but it isn't. This is a Oneiric bug https://bugs.launchpad.net/ubuntu/on...ta/+bug/878682
    So if you use Xubuntu 11.10 Oneiric, please install gvfs-backends or Thunar/Gigolo cannot have access to FTP SSH WEDDAV SAMBA etc. etc. network filesystems

    2) As described here https://bugzilla.xfce.org/show_bug.cgi?id=7373 there is a problem in Thunar about "network://" search/browse. "network://" is enabled after you installed gvfs-backends.
    When you open Thunar the first time, it run automatically a "network://" search (it's a samba scan) and you must wait it end before see Thunar in your desktop.
    I'm waiting the new Thunar release (the bug above is fixed) but in meantime I've found a simple solution: as 'root' edit the text file
    /usr/share/gvfs/mounts/smb-browse.mount

    Original code: remove type smb-network
    Code:
    [Mount]
    Type=smb-network;smb-server
    Exec=/usr/lib/gvfs/gvfsd-smb-browse
    DBusName=org.gtk.vfs.mountpoint.smb_browse
    AutoMount=false
    Scheme=smb
    After editing:
    Code:
    [Mount]
    Type=smb-server
    Exec=/usr/lib/gvfs/gvfsd-smb-browse
    DBusName=org.gtk.vfs.mountpoint.smb_browse
    AutoMount=false
    Scheme=smb
    YOU MISS NETWORK:// SCAN but now Thunar open fast the first time also.
    For me is ok: I've no Samba share in my local network (only FTP)
    Last edited by ambrosa; November 9th, 2011 at 08:22 AM.

  10. #10
    Join Date
    Sep 2011
    Location
    Fairfax, Virginia
    Beans
    162
    Distro
    Ubuntu

    Re: Thunar slow opening fix

    Quote Originally Posted by ambrosa View Post
    1) gvfs-backends should be already installed in a fresh installation but it isn't. This is a Oneiric bug https://bugs.launchpad.net/ubuntu/on...ta/+bug/878682
    So if you use Xubuntu 11.10 Oneiric, please install gvfs-backends or Thunar/Gigolo cannot have access to FTP SSH WEDDAV SAMBA etc. etc. network filesystems

    2) As described here https://bugzilla.xfce.org/show_bug.cgi?id=7373 there is a problem in Thunar about "network://" search/browse. "network://" is enabled after you installed gvfs-backends.
    When you open Thunar the first time, it run automatically a "network://" search (it's a samba scan) and you must wait it end before see Thunar in your desktop.
    I'm waiting the new Thunar release (the bug above is fixed) but in meantime I've found a simple solution: as 'root' edit the text file
    /usr/share/gvfs/mounts/smb-browse.mount

    Original code: remove type smb-network
    Code:
    [Mount]
    Type=smb-network;smb-server
    Exec=/usr/lib/gvfs/gvfsd-smb-browse
    DBusName=org.gtk.vfs.mountpoint.smb_browse
    AutoMount=false
    Scheme=smb
    After editing:
    Code:
    [Mount]
    Type=smb-server
    Exec=/usr/lib/gvfs/gvfsd-smb-browse
    DBusName=org.gtk.vfs.mountpoint.smb_browse
    AutoMount=false
    Scheme=smb
    YOU MISS NETWORK:// SCAN but now Thunar open fast the first time also.
    For me is ok: I've no Samba share in my local network (only FTP)


    Hello,
    Do I put the code directly into a terminal? Or are there more steps involved?

    Thanks,
    Ernie

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •