Results 1 to 10 of 10

Thread: Can't mark files as executable

  1. #1
    Join Date
    Jul 2011
    Beans
    33

    Cool Can't mark files as executable

    Whenever I want to run .exe files for Wine, or .java files, I get this error: "The file BLA BLA BLA is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run."

    I right-click the file and go to permissions, but the check-box to mark as executable is not even there. What can I do to fix this? Also it would be nice to automatically make the files marked as executable, if possible. Thanks!

    (Also, I DO have Java installed for the .java files.)

  2. #2
    Join Date
    Nov 2009
    Location
    Madrid, Spain
    Beans
    1,403
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't mark files as executable

    Is your permissions menu different to the image attached to this post?.
    Attached Images Attached Images

  3. #3
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,909
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't mark files as executable

    Code:
    sudo chmod +x /path/of/file.exe
    make the file executable
    and then
    Code:
    wine /path/of/file.exe
    Last edited by fdrake; July 29th, 2011 at 01:02 AM.

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  4. #4
    Join Date
    Jul 2011
    Beans
    33

    Re: Can't mark files as executable

    Quote Originally Posted by lmarmisa View Post
    Is your permissions menu different to the image attached to this post?.
    When I right click on a file, and go to properties, it looks like this:
    Attached Images Attached Images

  5. #5
    Join Date
    Jul 2011
    Beans
    33

    Re: Can't mark files as executable

    Quote Originally Posted by fdrake View Post
    Code:
    sudo chmod +x /path/of/file.exe
    make the file executable
    and then
    Code:
    wine /path/of/file.exe
    I'm so confused. I can not even find the Path of files anymore. I think when I used Ubuntu I could just right click on the file and go to properties and it would show me the path. With Xubuntu I have no idea what I'm doing. -_-

  6. #6
    Join Date
    Nov 2009
    Location
    Madrid, Spain
    Beans
    1,403
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't mark files as executable

    Sorry. My last capture was wrong. I attach here the correct image.

    I think your problem is related to read/write permissions. Try to copy your exe or java file to the desktop and open its properties. If you downloaded a zip file, extract the contents to physical files. Do not try to change permissions to the contents of a zip file. The system will not allow to do that.
    Attached Images Attached Images

  7. #7
    Join Date
    Jul 2011
    Beans
    33

    Re: Can't mark files as executable

    Haha that's alright. I extracted the folder with the file to the desktop and tried it. It's still the same. How would I find the path of the file in XFCE so I can do the command fdrake suggested?

  8. #8
    Join Date
    Nov 2009
    Location
    Madrid, Spain
    Beans
    1,403
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't mark files as executable

    Quote Originally Posted by ProfessorUnicorn View Post
    Haha that's alright. I extracted the folder with the file to the desktop and tried it. It's still the same. How would I find the path of the file in XFCE so I can do the command fdrake suggested?
    Try this command:

    Code:
    cd ~/Desktop
    chmod +x yourfile.exe_or_java

  9. #9
    Join Date
    Nov 2009
    Location
    Toowoomba QLD Australia.
    Beans
    71
    Distro
    Ubuntu

    Re: Can't mark files as executable

    unfortunately the option to mark a file as executable from the properties window is non existent in xfce4, which is the default version of xfce that comes with xubuntu as of 10.04 onwards. so commandline is really the only way to go, its a minor inconvenience considering the raw performance you get out of xfce.

    the path of file is simply the directory the file is in, example /home/yourname/downloads/yourfile.exe

    your in xfce4 doubtlessly so you should have an option in your context (right click menu) marked "open terminal here"
    use that, then use command
    Code:
    chmod +x file.exe
    if you dont have said option, open terminal from your applications menu,
    then use the change directory command to navigate to the file,
    it usually starts you off in your home directory, and for the sake of an example your file is in the downloads folder so an example of the command would be

    Code:
    cd downloads
    chmod +x filename.exe
    hope this helps. throw us another post if it doesnt and include screenshots of exactly what your doing, and of the terminal window output, and we will see what we can do.
    is it a bird? is it a plane? no it's....wait what? it's a nerd?!?

    sudo apt-get install Brain
    package not found.

  10. #10
    Join Date
    Jul 2011
    Beans
    33

    Re: Can't mark files as executable

    Thanks everyone for your support! I finally got it figured out with NERDMAN!'s suggestion to use the "Open terminal Here" option.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •