Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

  1. #1
    Join Date
    Nov 2004
    Location
    Ottawa, Canada
    Beans
    130
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    Edit /etc/X11/XF86Config-4 or /etc/X11/xorg.conf depending on which you have with your favourite text editor.

    In section "Screen"
    Change the DefaultDepth value to 16
    And for the display:
    Code:
    Code:
            SubSection "Display"
                    Depth           16
                    Modes           "1024x768" "832x624" "800x600" "720x400" "640x480"
            EndSubSection
    The LARGEST value for Modes must be 1024x768, and the DefaultDepth must be 16, otherwise no 3D. This is a hardware limitation on the card.

    I tried setting the resolution higher, and then using the Screen Resolution program to lower to 1024x768 to no effect.

    You should probably also install libglide3 from the Ubuntu main repository

  2. #2
    Join Date
    May 2005
    Beans
    4

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    worked for me
    i googled and first installed xlibmesa3. it did not work at that moment but gave no error message e.g. in the /var/log/XFree86.log file.

    to find out if opengl works:

    > glxinfo | grep direct
    you should see: direct rendering: Yes

    and to see it in action: start glxgears and make the window big. you will see the difference

    and to do something useful (well, funny): install chromium!

  3. #3
    Join Date
    Oct 2004
    Location
    Denmark
    Beans
    240
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    I have been trying to get 3d acceleration on a really old box of mine. It has a Voodoo Banshee graphics card so I figured I'd give this thread a go...

    I stripped out my 24 bit color depth, and made 16 default. I also set
    Code:
    Option "UseFBDev" "False"
    in my Device section in xorg.conf (I can't remember where I picked that up... ). I also installed libglide3. But alas.
    Code:
    mikkel@smallpox:~$ glxinfo | grep direct
    libGL warning: 3D driver returned no fbconfigs.
    libGL error: InitDriver failed
    libGL error: reverting to (slow) indirect rendering
    direct rendering: No
    OpenGL renderer string: Mesa GLX Indirect
    Any help would be greatly appreciated. My processor could use the spare clock cycles (266MHz)!

    EDIT: glxgears also gives the libGL warnings/errors and shows < 1 fps...

  4. #4
    Join Date
    Oct 2004
    Location
    Denmark
    Beans
    240
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    Ok poking around on the net I find this useful document:
    http://dri.sourceforge.net/doc/DRIuserguide.html

    It states that Voodoo Banshee is indeed supported by DRI. Working my way through it I discover that I don't have bus mastering enabled (what ever that is...). When I follow the instructions in the doc to enable it, nothing happens. Ie. bus mastering does not get turned on.

    Some more relevant output...
    Code:
    lsmikkel@smallpox:~$ lsmod | grep tdfx
    tdfx                    3840  1 
    drm                    58004  2 tdfx
    Code:
    mikkel@smallpox:~$ xdpyinfo | grep DRI
        XFree86-DRI
    mikkel@smallpox:~$ xdpyinfo | grep GL
        GLX
        SGI-GLX
    Device section of /etc/X11/xorg.conf
    Code:
    Section "Device"
            Identifier      "3Dfx Interactive, Inc. Voodoo Banshee"
            Driver          "tdfx"
            Option          "UseFBDev"      "False"
            BusID           "PCI:0:5:0"
    EndSection
    Code:
    mikkel@smallpox:~$ lspci | grep Banshee
    0000:00:05.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo Banshee (rev 03)

  5. #5
    Join Date
    Oct 2005
    Location
    Ely, UK
    Beans
    8
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    I install libglide3 I get 3D accelaration but a "Illegal instruction" when running glxgears. Any suggestions?

  6. #6
    Join Date
    Oct 2004
    Location
    Denmark
    Beans
    240
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    What more have you done? Please be a bit more specific. Do you have busmastering enabled as explained here?
    Grillbar.org - it's a grill and bar! Go check: #-.org

  7. #7
    Join Date
    Jan 2006
    Beans
    1

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    I'm using a Voodoo3 3000 and am getting the same error "Illegal instruction" when I try to run any glx apps (e.g. glxinfo or glxgears).

    I verified bus mastering was enabled, changed xorg.conf as suggested above, and installed libglide3. I didn't see any errors in Xorg.0.log and it appears DRM loaded. I also ran xdpyinfo and found the extensions GLX, SGI-GLX, and XFree86-DRI as suggested in the DRI users guide.

    Not sure what's wrong.

    Please help!

    Regards,
    Mike

  8. #8
    Join Date
    Apr 2006
    Beans
    1

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    I just recently installed Ubuntu on one of my computers. I had Gentoo Linux installed on it prior, but because it is a slower computer, I spent most of the time compiling and it wasn't being used for anything else, really, hence the switch. I did successfully manage to enable direct rendering, 1024x768 16-bit resolution when running Gentoo Linux, however I am having difficulty configuring everything with Ubuntu. I did not determine if bus mastering was enabled when I had everything configured running Gentoo, but I am having difficulty configuring it using Ubuntu. It seems bus mastering is disabled for my 3Dfx Voodoo 3 card and enabling per instructions does nothing. My bios for the system doesn't seem to show any reference to enable/disable or even display its status. Currently glxinfo shows direct rendering as enabled, but I get invalid instruction error when running glxinfo. I'm stuck at this point. Any suggestions/ideas?

  9. #9
    Join Date
    May 2007
    Location
    USA
    Beans
    11
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    Okay, so I installed the glide/mesa stuff and made sure tdfx gets loaded by adding it to /etc/modules (after doing an sudo modprobe tdfx), and yes DRI is enabled and 3-D glxgears runs as 700+ fps. The system does have to be configured so that you start X at 1024x768 to get hardware acceleration.

    That really sucks, because I use my system at 1600x1200, and DRI/2-D hardware acceleration (even windowed 3-D) worked great under my ancient Mandrake installation with XFree 4.0 thru 4.2. The hardware is capable of acceleration at these higher resolutions, and I don't appreciate someone "fixing" or "changing" it to do otherwise...

    Maybe it is time to download the DRI source code and see if someone limited the features there or if it is in xorg...

  10. #10
    Join Date
    May 2007
    Location
    USA
    Beans
    11
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Get 3D acceleration with Voodoo3 using the tdfx driver

    Okay, so I am now using my Voodoo3 3000 AGP video card (16 MB of memory) at 1600x1200 with DRI (hardware acceleration) as I wanted. I found that some Ubuntu developers decided to try to protect us from not having enough memory to use fancy textures at this resolution and limited the DRI to lower resolutions. I wanted the DRI at this resolution, because the 2-D acceleration makes my old system much more responsive (PII 400 MHz --- don't laugh).

    I'm sure a lot of people don't care, and the people who changed it probably don't want to revert the Ubuntu code. But the power of open source has allowed me to choose what I want for my machine, so that is great. I do think that there must be a more elegant solution to still allow DRI at high resolutions for this card, and I will submit a patch if I come up with something good.

    --------------------

    Here is a summary of how I enabled DRI at 1600x1200 under Ubuntu 7.04.

    The basic problem comes from a change made to the tdfx_dri.c file:
    http://archive.ubuntu.com/ubuntu/poo...g-driver-tdfx/

    (Note: look in /var/logs/Xorg.0.log to see the error report that disables
    DRI. This text is also in the Ubuntu code.)

    The development tools were not all installed, so I used the Add Programs
    option to add Glade and got most of the development tools (like autoconf).
    I searched for the original code and found the Debian sources and a lot of
    other things too. It was a bit overwhelming, and the Debian version did
    not compile yet.

    I found the Sources.gz file for 7.04 and determined the name of the package
    that had the tdfx driver in it.

    Then I found a post on the Ubuntu forums that gave me information about
    how to get source code:
    http://ubuntuforums.org/showthread.php?t=14756

    sudo apt-get build-dep xserver-xorg-video-tdfx
    sudo apt-get source xserver-xorg-video-tdfx

    Then I had all the dependencies and code. The diff file showed the change
    that I did not want, so I went into the original Debian code and did the standard
    ./configure, make, sudo make install.

    The files were installed into here though:
    /usr/local/lib/xorg/modules/drivers/
    tdfx_drv.la
    tdfx_drv.so

    They needed to be elsewhere, so I put them there:
    cd /usr/local/lib/xorg/modules/drivers/
    sudo cp *.* /usr/lib/xorg/modules/drivers/

    X did not like that, so it restarted but with the new tdfx driver.

    DRI is now enabled at the higher resolutions as I desired.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •