Page 53 of 93 FirstFirst ... 343515253545563 ... LastLast
Results 521 to 530 of 922

Thread: MacBookAir4,1 & MacBookAir4,2 (MBA 2011) support

  1. #521
    Join Date
    Oct 2011
    Beans
    3

    Re: MacBookAir4,1 & MacBookAir4,2 (MBA 2011) support

    Quote Originally Posted by jebus_beler View Post
    @dfacto: thanks, as always, for the useful reply. I think jbraun, who posted about the graphics flickering problem also had a maxed out model so I think I've hit my statistical limit. He on the other hand did share my flickering problem but apparently not the others.

    @poliva: Thanks for the response. I think that's the exact same model I have (and maybe jbraun too). Do you notice any problems with the screen seeming to flicker. Its not always easy to reproduce this but if you find the right color its very noticeable. For me its the color of the default ubuntu terminal (just maximize it and turn up the brightness).
    yep, I have the same screen as poliva. As you said, it's not always clearly visible.... for the first few hours I wasn't even aware of the problem and thought everything was fine.

  2. #522
    Join Date
    Dec 2004
    Beans
    297

    Re: MBA 4,2 running hotter under 11.10 than with OS X Lion

    Quote Originally Posted by berryman77 View Post
    @jonny

    The air temp is 21C. Are you running Unity with Compiz? Mine's an 13" i5 also.
    Yes, Unity 3D with Compiz. My temperatures were taken during a little light web browsing, but I never see the temperature rising by more than a couple of degrees during normal usage(Minecraft excepted ).

    Have you tried using the top program to see if you have any runaway processes?

  3. #523
    Join Date
    Apr 2005
    Beans
    20

    Re: MBA 4,2 running hotter under 11.10 than with OS X Lion

    @jonny

    Quote Originally Posted by jonny View Post
    Yes, Unity 3D with Compiz. My temperatures were taken during a little light web browsing, but I never see the temperature rising by more than a couple of degrees during normal usage(Minecraft excepted ).

    Have you tried using the top program to see if you have any runaway processes?
    I've completely shutdown graphics (sudo lightdm stop), run powertop and i7z and shut down some offenders (like the sound modules) and still I've got high temps. Here is the output from powertop:

    Code:
         PowerTOP version 1.13      (C) 2007 Intel Corporation
    
    Cn                Avg residency       P-states (frequencies)
    C0 (cpu running)        ( 3.3%)       Turbo Mode     0.9%
    polling           1.1ms ( 0.0%)         1.71 Ghz     0.0%
    C1 mwait          0.4ms ( 0.6%)         1.60 Ghz     0.0%
    C2 mwait          0.6ms ( 0.4%)         1500 Mhz     0.0%
    C3 mwait          1.0ms ( 0.1%)          800 Mhz    99.1%
    C4 mwait          7.8ms (95.6%)
    Wakeups-from-idle per second : 143.9    interval: 15.0s
    no ACPI power usage estimate available
    
    Top causes for wakeups:
      37.0% (189.3)   [Rescheduling interrupts] <kernel IPI>
      15.0% ( 76.7)   [i915] <interrupt>
       8.8% ( 45.2)   kworker/0:1
       6.0% ( 30.7)   [kernel scheduler] Load balancing tick
       5.8% ( 29.7)   [ehci_hcd:usb2] <interrupt>
       5.4% ( 27.6)   firefox
       3.8% ( 19.2)   USB device 2-1.2.4 : USB Receiver (Logitech)
       3.4% ( 17.6)   kworker/0:0
       2.3% ( 12.0)   USB device 2-1.1 : Card Reader (Apple)
    What kernel are you running? Here is mine from uname -a:

    Linux randall-MacBookAir 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

    and my current readings:

    Code:
    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0:  +64.0°C  (high = +86.0°C, crit = +100.0°C)
    Core 0:         +65.0°C  (high = +86.0°C, crit = +100.0°C)
    Core 1:         +63.0°C  (high = +86.0°C, crit = +100.0°C)
    
    applesmc-isa-0300
    Adapter: ISA adapter
    Exhaust  :   3812 RPM  (min = 3806 RPM)
    When I'm running OSX in the same environment, my core temps are 50C (15C less!).

  4. #524
    Join Date
    Dec 2004
    Beans
    297

    Re: MBA 4,2 running hotter under 11.10 than with OS X Lion

    berryman77, I'm on exactly the same kernel. And my laptop's running a little cooler today at 49C - no warmer than in OS X and the fan's at the minimum 2000RPM.

    I have added 'i915.i915_enable_rc6=1' to my GRUB startup parameters as suggested 10-20 pages back. Could that be making a difference?

  5. #525
    Join Date
    Apr 2005
    Beans
    20

    Re: MBA 4,2 running hotter under 11.10 than with OS X Lion

    Quote Originally Posted by jonny View Post
    berryman77, I'm on exactly the same kernel. And my laptop's running a little cooler today at 49C - no warmer than in OS X and the fan's at the minimum 2000RPM.

    I have added 'i915.i915_enable_rc6=1' to my GRUB startup parameters as suggested 10-20 pages back. Could that be making a difference?
    @jonny

    That worked! Thank you!

    My new readings, a drop of nearly 10C:

    Code:
    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0:  +56.0°C  (high = +86.0°C, crit = +100.0°C)
    Core 0:         +56.0°C  (high = +86.0°C, crit = +100.0°C)
    Core 1:         +57.0°C  (high = +86.0°C, crit = +100.0°C)
    
    applesmc-isa-0300
    Adapter: ISA adapter
    Exhaust  :   1994 RPM  (min = 2000 RPM)

  6. #526
    Join Date
    Dec 2004
    Beans
    297

    Re: MBA 4,2 running hotter under 11.10 than with OS X Lion

    @berryman77, that's a huge difference! I'll add something to the wiki when I get a chance.

  7. #527
    Join Date
    Nov 2005
    Location
    Mountain View, CA, USA
    Beans
    261
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: MacBookAir4,1 & MacBookAir4,2 (MBA 2011) support

    Yes; we found this to be the only flag of significance. Its been in the post-install script for quite some time.

  8. #528
    Join Date
    Nov 2005
    Location
    Mountain View, CA, USA
    Beans
    261
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: MacBookAir4,1 & MacBookAir4,2 (MBA 2011) support

    Quote Originally Posted by jbraun View Post
    yep, I have the same screen as poliva. As you said, it's not always clearly visible.... for the first few hours I wasn't even aware of the problem and thought everything was fine.
    Looks like my guess of 2.25 people was surprisingly accurate!

  9. #529
    Join Date
    Apr 2005
    Beans
    20

    Re: MBA 4,2 running hotter under 11.10 than with OS X Lion

    Quote Originally Posted by jonny View Post
    @berryman77, that's a huge difference! I'll add something to the wiki when I get a chance.
    @jonny
    I edited the wiki here: https://help.ubuntu.com/community/Ma...ir4-2#GPUPower


    Thanks again.

  10. #530
    Join Date
    May 2008
    Beans
    76

    Re: MacBookAir4,1 & MacBookAir4,2 (MBA 2011) support

    Quote Originally Posted by jebus_beler View Post
    @poliva: Thanks for the response. I think that's the exact same model I have (and maybe jbraun too). Do you notice any problems with the screen seeming to flicker. Its not always easy to reproduce this but if you find the right color its very noticeable. For me its the color of the default ubuntu terminal (just maximize it and turn up the brightness).
    Hi, definitely no flickering problem in my screen, been running Ubuntu since September 22nd, and haven't noticed any flickering issue at all.

Page 53 of 93 FirstFirst ... 343515253545563 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •