Results 1 to 5 of 5

Thread: Xsane scanner found, but GUI does not find device

  1. #1
    Join Date
    Sep 2008
    Beans
    540
    Distro
    Kubuntu 12.04 Precise Pangolin

    Question Xsane scanner found, but GUI does not find device

    I can find the HP Office Jet 6500 scanner using sane-find-scanner as you can see below, but sudo xsane finds no devices.

    What am I doing wrong?

    Code:
    / Hello! $su                                                                                                                          
    Password: 
    root@tarahmarie-desktop-home:/# sane-find-scanner
    
      # sane-find-scanner will now attempt to detect your scanner. If the
      # result is different from what you expected, first make sure your
      # scanner is powered up and properly connected to your computer.
    
      # No SCSI scanners found. If you expected something different, make sure that
      # you have loaded a kernel SCSI driver for your SCSI adapter.
    
    found USB scanner (vendor=0x0bb4, product=0x0c97) at libusb:002:007
      # Your USB scanner was (probably) detected. It may or may not be supported by
      # SANE. Try scanimage -L and read the backend's manpage.
    
      # Not checking for parallel port scanners.
    
      # Most Scanners connected to the parallel port or other proprietary ports
      # can't be detected by this program.
    root@tarahmarie-desktop-home:/# xsane
    No protocol specified
    
    (xsane:18206): Gtk-WARNING **: cannot open display: :0
    root@tarahmarie-desktop-home:/# exit
    exit
    / Hello! $sudo xsane
    [sudo] password for tarahmarie:
    Registered Linux User #479009
    Friend-->Linux; 6 and counting...

  2. #2
    Join Date
    Sep 2006
    Location
    South Africa
    Beans
    60
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Red face Re: Xsane scanner found, but GUI does not find device

    I have the exact same problem, will update if I find a fix.
    read my blog

  3. #3
    Join Date
    Sep 2006
    Location
    South Africa
    Beans
    60
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Xsane scanner found, but GUI does not find device

    ok got the scanner working. this is what I did:
    run the following command as root:
    Code:
    /etc/init.d/udev restart
    this will ensure that your ubuntu knows where the scanner is plugged in.

    now xsane still doesn't work, but GIMP that I tried earlier without success is now scanning through it's SANE backend without any problems.

    hope this helps
    read my blog

  4. #4
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,143
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Xsane scanner found, but GUI does not find device

    run sane-find-scanner or scanimage -L without root access and see if it sees it
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  5. #5
    Join Date
    Sep 2006
    Location
    South Africa
    Beans
    60
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Xsane scanner found, but GUI does not find device

    just to add more info, running
    Code:
    sane-find-scanner
    as a normal user finds the scanner, but it appears that
    Code:
    xsane
    has a problem with GTK
    read my blog

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •