Page 13 of 14 FirstFirst ... 311121314 LastLast
Results 121 to 130 of 136

Thread: Linkys AE2500 USB Adapter Not Working

  1. #121
    Join Date
    Jan 2009
    Beans
    19

    Re: Linkys AE2500 USB Adapter Not Working

    Well I did recompile Ndiswrapper to the latest package availible 1.58rc1. But what did you mean by the latest xp .ini? I used the one off the disk and the one off the site I modified the .ini file to reflect the extra lines


    [Linksys_AE1200.files.NTamd64]
    AE1200xp64.sys,,,6

    [Linksys_AE2500.files.NTamd64]
    AE2500xp64.sys,,,6

    I am interested in any help you will throw at me..


    And Happy Holidays

  2. #122
    Join Date
    Jan 2009
    Beans
    19

    Re: Linkys AE2500 USB Adapter Not Working

    dravenm4@Draven-Alpha:~$ ndiswrapper -v
    utils version: '1.9', utils version needed by module: '1.9'
    module details:
    filename: /lib/modules/3.2.0-35-generic/misc/ndiswrapper.ko
    version: 1.58rc1
    vermagic: 3.2.0-35-generic SMP mod_unload modversions
    dravenm4@Draven-Alpha:~$

  3. #123
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,143
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Linkys AE2500 USB Adapter Not Working

    But what did you mean by the latest xp .ini? I used the one off the disk and the one off the site I modified the .ini file to reflect the extra lines
    Were there various versions on the disk? XP, Vista, 7, et al? You need XP. As well, you need the version matching your architecture; i.e. x86 or x86_64.

    64-bit is often a bit tricky.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #124
    Join Date
    Jan 2009
    Beans
    19

    Re: Linkys AE2500 USB Adapter Not Working

    Quote Originally Posted by chili555 View Post
    Were there various versions on the disk? XP, Vista, 7, et al? You need XP. As well, you need the version matching your architecture; i.e. x86 or x86_64.

    64-bit is often a bit tricky.
    Yeah the disk had xp, vista, and win7... I only use XP cause thats what NDISWrapper works with. And I am 64 bit Ubuntu I removed the none 64bit files from the folder when installing.

  5. #125
    Join Date
    Jan 2009
    Beans
    19

    Re: Linkys AE2500 USB Adapter Not Working

    Is there no further info?

  6. #126
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,442
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Linkys AE2500 USB Adapter Not Working

    Please check:

    Code:
    impriv wlan0
    You may need to change the router mode to b+g only instead of n

  7. #127
    Join Date
    Feb 2013
    Beans
    1

    Re: Linkys AE2500 USB Adapter Not Working

    Massive thanks to Wojosama (post #79), I can confirm that following those steps, Ubuntu 12.04, 64bit I was able to get the AE2500 wifi adapter running. Has anyone been able to get it to connect to a N router (post #58)?

  8. #128
    Join Date
    Apr 2013
    Beans
    1

    Talking Re: Linkys AE2500 USB Adapter Not Working

    Quote Originally Posted by Wojosama View Post
    I just want to say thank you to everyone who contributed to this discussion, the xp driver worked with no problems using ndiswrapper on 32bit, but when I switched to 64bit I entered a world of hurt.

    However, thankfully, I can confirm the Linksys AE1200 working on 64bit ubuntu 11.10 on 802.11g. The AE1200 and AE2500 share the same drivers, so both should work fine. I can't speak on 802.11N connectivity as I don't have an N router to test it with, sorry. A lot of this will be similar to Fat-n00b's info in post #40 but with all the stuff I had to do extra to make it work on 64bit.

    Before you start, I have not added/modified/deleted anything relating to networking or any other hardware drivers(modules) since I did the clean install of 11.10 x64.
    These are the steps I took (pretty much all found here and pieced together):

    NOTE: THE FILES YOU DELETE IN STEP 3B ARE THE 32BIT DRIVERS. THESE INSTRUCTIONS ARE FOR 64BIT ONLY FOR THAT REASON.
    NOTE 2: IF YOU HAVEN'T DONE ANY WORK TO INSTALL THESE DRIVERS WITH NDISWRAPPER YOU CAN SKIP STEP 1.

    1. First remove all prior work with this (replace bcmwlhigh5 with bcmwlhigh6 if you tried installing vista or win7 drivers):

    Code:
    sudo ndiswrapper -e bcmwlhigh5
    sudo modprobe -rf ndiswrapper
    sudo rm /etc/modprobe.d/ndiswrapper.conf
    sudo rm -rf /etc/ndiswrapper/*
    sudo depmod -a
    I would restart the computer now just to be safe.

    2. Next, I had to build version 1.57 of ndiswrapper as the one in the ubuntu repositories didnt work, instructions for removing your current version and downloading/building/installing the new version can be found here:
    HTML Code:
    http://ubuntuforums.org/showpost.php?p=11612708&postcount=1113
    3a. After that is done, you must make sure you've got the right files in the folder with the winxp inf file.
    Download the XP driver here if you need it (You MUST use the windows xp drivers):
    HTML Code:
    http://homedownloads.cisco.com/downloads/driver/1224667593495/AE1200xp.zip
    3b. Extract those to an easy place to find them. After you extract them, delete the following files from the folder (probably unnecessary but do it just in case): AE1200xp.sys, AE2500xp.sys, bcmh43xx.cat, bcmwlcoi.dll

    4. Now you need to add the following lines to bcmwlhigh5.inf:
    Open in a text editor and put the cursor at the begining of line 178 and paste these lines:
    Code:
     
    
    [Linksys_AE1200.files.NTamd64] 
        AE1200xp64.sys,,,6 
     
    [Linksys_AE2500.files.NTamd64] 
        AE2500xp64.sys,,,6
    Adding "amd64" after "NT" on lines 76, 83, 87 and 94 is NOT necessary, it would just try to make the inf use the 32bit versions of the .sys files which doesn't work (and I've had you delete those files just in case you did amend those lines).

    5.
    Blacklist other bcm modules to keep them from loading
    Code:
    echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist.conf

    6.
    Time to install! Finally, I know.
    Here's the commands (PLEASE READ THE NOTES BELOW FIRST):
    Code:
    sudo ndiswrapper -i /home/adam/Desktop/XP/bcmwlhigh5.inf   **CHANGE TO YOUR LOCATION**
    sudo ndiswrapper -m -ma -mi
    sudo depmod -a
    sudo modprobe ndiswrapper
    A few notes on the code you'll enter (or did enter if you didn't read ahead first );
    First you can either direct ndiswrapper to your inf file (as i did), or you can cd to the folder it's in and just do 'sudo ndiswrapper -i bcmwlhigh5.inf'
    Second is that I don't know if everything in the second command is necessary but it DOES work, they are exactly what I used.
    Lastly, and this is VERY important, the moment I typed in the 'sudo depmod -a' and hit enter, my computer completely froze and I had to hit the restart button on the tower, however when it rebooted, voila! I could see my wireless adapter for the first time since I installed 64bit, and I could connect to my wireless network!

    Two final things about connecting to your router (which I had to do on 32bit and am guessing would've had to do on 64bit as well had i not already done it):
    1. If your router is set to NOT broadcast SSID you will probably not be able to connect to it. I had to set it to broadcast in the end as nothing i did worked, and i tried a LOT of stuff lol.
    2. If you are using WPA, in my case WPA2 - PSK, I had to change my password as for some reason it just would not connect, I ended up using one generated from here:
    HTML Code:
    http://www.yellowpipe.com/yis/tools/WPA_key/generator.php
    After setting the new wpa password, I was able to connect without any problem. Keep in mind, I had 2 phones, and 3 other computers connected to it all using the old password but it just would not work with the ubuntu+ndiswrapper combo until I used the one I generated, so if using WPA, and you can't connect, try one from the generator before you give up on WPA.
    MAC address filtering enabled on the router was obviously unaffected through all of this, so setting SSID to broadcast was the only layer of security I had to sacrifice.

    Sorry for the MASSIVE post. I just can't thank everyone here enough, and if this keeps even one person from wasting their entire weekend like I just did, then making this post was well worth it. I know the last post is a couple days old but if I googled my here, someone else will as well. If there's somewhere else that it would be helpful for me to post this info I'd appreciate it if anyone would let me know. I've only used Ubuntu for a very, very short time, but I've been helped countless times by posters like you guys, so if i contribute back in any way, then I'd really like to.
    (P.S. Longest first post ever? lol)
    Thank you so much! The only additional thing i had to do was to add ndiswrapper to /etc/modules so it runs on startup.

  9. #129
    Join Date
    Dec 2013
    Beans
    8

    Re: Linkys AE2500 USB Adapter Not Working

    Thank you good sir!(Wojosama (post #79)) I followed those steps and I am currently posting this via wireless connection .

  10. #130
    Join Date
    Jan 2014
    Beans
    2

    Re: Linkys AE2500 USB Adapter Not Working

    What does this line do? "echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist.conf"


    and how would I undo it? I've tried a tutorial that is pretty much like yours, but still couldn't my AE2500 to show up in Network settings. So I bought a new PCI wireless card--still waiting for it to arrive--and I'm afraid that line could give me problems in installing the new wireless card. I don't really know if this helps, but I'm running Elementary OS Luna. I'm super new to Linux.

    Thanks in advance
    Last edited by max30; January 28th, 2014 at 09:55 AM.

Page 13 of 14 FirstFirst ... 311121314 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •