Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 35

Thread: 11.04 - Mouse randomly stops working inside applications

  1. #11
    Join Date
    Sep 2011
    Location
    New York City
    Beans
    212
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Question Re: 11.04 - Mouse randomly stops working inside applications

    Occasionally but not always my mouse responds by my hitting the ESC button. So far in the past 2 days the mouse has behaved itself. On Monday of this week I took a chance because of this bad behavior of restarting the machine and booting to Win7 again. After 2 months of using Ubuntu Win7 must have learned its lesson by its being banished and started working again. 2 days later I booted up again into Ubuntu and so far the mouse has behaved itself. I love that command that you've posted above and tried it. This is the output. If it makes any sense to anyone as a direction to a possible solution can someone let me know?

    Code:
    paulw@ubuntu:~$ xinput list
    ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
    ⎜   ↳ USB Mouse                                   id=8    [slave  pointer  (2)]
    ⎜   ↳ UC-LOGIC Tablet WP8060U                     id=9    [slave  pointer  (2)]
    ⎜   ↳ UC-LOGIC Tablet WP8060U                     id=10    [slave  pointer  (2)]
    ⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
        ↳ Power Button                                id=6    [slave  keyboard (3)]
        ↳ Power Button                                id=7    [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard                id=11    [slave  keyboard (3)]
    paulw@ubuntu:~$
    When in doubt, check it out!

    If all else fails, check the plug!

  2. #12
    Join Date
    Dec 2007
    Location
    Durban
    Beans
    124
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: 11.04 - Mouse randomly stops working inside applications

    This is honestly a complete pain.

    Once the touchpad stops working the only solution is to reboot.

    Code:
    dave@SNECCI:~$ xinput list
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ ETPS/2 Elantech Touchpad                	id=12	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Power Button                            	id=6	[slave  keyboard (3)]
        ↳ Video Bus                               	id=7	[slave  keyboard (3)]
        ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
        ↳ CNF7129                                 	id=9	[slave  keyboard (3)]
        ↳ Asus Laptop extra buttons               	id=10	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]

  3. #13
    Join Date
    Dec 2007
    Location
    Durban
    Beans
    124
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: 11.04 - Mouse randomly stops working inside applications

    Nothing on this?

    It's incredibly annoying to have to reboot continuously because the touchpad stops working.

  4. #14
    Join Date
    Nov 2010
    Location
    Foshan, China
    Beans
    437
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 11.04 - Mouse randomly stops working inside applications

    I had that problem on 11.04 when using FileZilla. App wasn't blocked, but mouse click were totally gone (not responding anymore). After a while, I found that it was related to the new scrollbars, somehow it was stucked around a scrollbar and clicks were not working anymore, and had to close the window with ALT+F4. Chrome and Chromium are not using overlay scrollbars, that could be the key.

    Is anyone of you who have this problem using the new overlay scrollbars or the older ones ?

    If you want to give it a try if they fix the problem (might be related, but I am not sure 100%), these commands remove the scrollbars alltogether and return to normal ones:
    Code:
    sudo apt-get remove overlay-scrollbar
    sudo su
    echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars

  5. #15
    Join Date
    Dec 2007
    Location
    Durban
    Beans
    124
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: 11.04 - Mouse randomly stops working inside applications

    I can Alt+F4 all day long, the mouse remains unresponsive, evem with no apps open.

    I haven't noticed it happening with any particular app; it seems entirely random for me.

    Many of us started using Linux because we were a bit tired of the BSOD with Windows, but I have had to reboot my computer five or six times this morning and it's kind of taking away the fun of using Linux (to put it mildly!)

  6. #16
    Join Date
    Dec 2009
    Beans
    7

    Re: 11.04 - Mouse randomly stops working inside applications

    Quote Originally Posted by typhoon_tip View Post
    I had that problem on 11.04 when using FileZilla. App wasn't blocked, but mouse click were totally gone (not responding anymore). After a while, I found that it was related to the new scrollbars, somehow it was stucked around a scrollbar and clicks were not working anymore, and had to close the window with ALT+F4. Chrome and Chromium are not using overlay scrollbars, that could be the key.

    Is anyone of you who have this problem using the new overlay scrollbars or the older ones ?

    If you want to give it a try if they fix the problem (might be related, but I am not sure 100%), these commands remove the scrollbars alltogether and return to normal ones:
    Code:
    sudo apt-get remove overlay-scrollbar
    sudo su
    echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars
    Well, this might be a solution for some of you, but in my case problems started appearing when I was still on the classic Gnome desktop, without fancy scrollbars. My guess is that some keyboard / mouse breaks the event propagation…

    Just one hint for those who talked about rebooting the system: just check if killing / restarting the X-server doesn't do the job. In order to enable the Ctrl + Alt + Backspace shortcut to kill the X-Server, just do the following (from http://deviceguru.com/enabling-ctrl-alt-backspace-to-kill-the-x-server-in-ubuntu/):

    • Go to Menu > System > Preferences > Keyboard
    • Select the Layouts tab
    • Click the Options button
    • Click the Triangle to the left of the line that says “Key sequence to kill the X server”
    • Check the box to the left of Ctrl + Alt + Backspace

    Take care: When killing the X-Server, all your unsaved data will be lost!

  7. #17
    Join Date
    Dec 2004
    Beans
    96

    Re: 11.04 - Mouse randomly stops working inside applications

    I am having this issue too. I run Awesome WM, but also have gnome-settings-daemon running. So the problem is probably something to do with that.

    When I close the WM (which also restarts X) then the mouse is working again. Really annoying though since it can happen twice a day to once every 2 days.

  8. #18
    Join Date
    Dec 2011
    Beans
    1

    Re: 11.04 - Mouse randomly stops working inside applications

    I've been having this problem for the last few days. Not sure what exactly I installed that caused it, but I have found one trick to get around the problem.

    After you log in, simply log out, via Ctrl + Alt + Del, then log back in. Then I don't have any issues.

    I'll try the scroll bar thing.

  9. #19
    Join Date
    Sep 2009
    Beans
    22

    Re: 11.04 - Mouse randomly stops working inside applications

    Quote Originally Posted by genjix View Post
    I am having this issue too. I run Awesome WM, but also have gnome-settings-daemon running. So the problem is probably something to do with that.

    When I close the WM (which also restarts X) then the mouse is working again. Really annoying though since it can happen twice a day to once every 2 days.

    Exactly same setup, exactly same result. I'm going insane because of this.

  10. #20
    Join Date
    Sep 2009
    Beans
    22

    Re: 11.04 - Mouse randomly stops working inside applications

    It seems that this problem is being triggered by using Nautilus. I mean: if I don't use it at all for some time I don't seem to get the this bug.

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •