Page 1 of 6 123 ... LastLast
Results 1 to 10 of 51

Thread: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

  1. #1
    Join Date
    Jul 2011
    Beans
    8

    Angry Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Hey y'all, linux noob here (so of course I'm using Unity in Natty Narwhal). My wireless download rate is absurdly low (0.3 mbps) compared to a faster upload rate (1.5 mbps). My girlfriend's laptop running windows gets much higher download rate (20+ mbps). Saw some posts with similar problems elsewhere and people ask for the info when you terminal lshw -C network so I'm posting that below. Please keep in mind that while I'm willing to try anything I am still pretty green and could use some hand-holding in walking through a solution. I have decided to swear off windows and macs and have moved over to 100% linux so I really want this to work and I would love to make use of the community support that I hear such great things about. Thank you for your help in advance.

    *-network
    description: Wireless interface
    product: RT2860
    vendor: Ralink corp.
    physical id: 0
    bus info: pci@0000:01:00.0
    logical name: wlan0
    version: 00
    serial: 70:71:bc:df:e4:69
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=rt2800pci driverversion=2.6.38-8-generic firmware=0.11 ip=192.168.1.100 latency=0 multicast=yes wireless=IEEE 802.11bgn
    resources: irq:16 memory:f9ff0000-f9ffffff
    *-network
    description: Ethernet interface
    product: RTL8111/8168B PCI Express Gigabit Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:06:00.0
    logical name: eth0
    version: 02
    serial: 6c:62:6d:c8:b0:d7
    size: 10Mbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 multicast=yes port=MII speed=10Mbit/s
    resources: irq:44 ioport:d800(size=256) memory:fbdff000-fbdfffff memory:f8ff0000-f8ffffff memory:fbdc0000-fbddffff

  2. #2
    Join Date
    Jul 2011
    Beans
    8

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Additional information: I receive a strong wireless signal so I do not think that is the culprit. My wireless router is a Linksys WRT150N with the most recent firmware. I also saw somebody ask about time wget www.google.com and time host www.cisco.com for a similar problem... here are my results:

    amore@Revolution:~$ time wget www.google.com
    --2011-07-01 05:44:14-- http://www.google.com/
    Resolving www.google.com... 74.125.67.104, 74.125.67.105, 74.125.67.106, ...
    Connecting to www.google.com|74.125.67.104|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: `index.html'

    [ <=> ] 9,843 --.-K/s in 0.04s

    2011-07-01 05:44:18 (268 KB/s) - `index.html' saved [9843]


    real 0m4.019s
    user 0m0.008s
    sys 0m0.000s
    amore@Revolution:~$ time host www.cisco.com
    www.cisco.com is an alias for www.cisco.com.akadns.net.
    www.cisco.com.akadns.net is an alias for geoprod.cisco.com.akadns.net.
    geoprod.cisco.com.akadns.net is an alias for www.cisco.com.edgekey.net.
    www.cisco.com.edgekey.net is an alias for www.cisco.com.edgekey.net.globalredir.akadns.net.
    www.cisco.com.edgekey.net.globalredir.akadns.net is an alias for e144.cd.akamaiedge.net.
    e144.cd.akamaiedge.net has address 72.247.200.170

    real 0m5.560s
    user 0m0.000s
    sys 0m0.008s

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,426
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Dr. Handhold is on the case! What I suspect we have here is a driver conflict. I think two or more drivers are loading and fighting for control. Let's check. Please open a terminal and do:
    Code:
    lsmod | grep rt2
    The pipe symbol | is on the right side of my US keyboard on the same key with \.

    If we find a conflict, we'll add what I believe to be the worst of the performers to a blacklist file, preventing them from loading and conflicting.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  4. #4
    Join Date
    Jul 2011
    Beans
    8

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Dude you are the best. When all this is said and done I would love some pointers on where I can go learn more so that I can help others the way you help us... Anyways:

    amore@Revolution:~$ lsmod | grep rt2
    rt2860sta 494649 0
    rt2800pci 18159 0
    rt2800lib 43824 1 rt2800pci
    crc_ccitt 12595 2 rt2860sta,rt2800lib
    rt2x00pci 13986 1 rt2800pci
    rt2x00lib 39075 3 rt2800pci,rt2800lib,rt2x00pci
    mac80211 257001 3 rt2800lib,rt2x00pci,rt2x00lib
    cfg80211 156212 2 rt2x00lib,mac80211
    eeprom_93cx6 12653 1 rt2800pci

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,426
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Indeed a conflict. Let's shortcut it and I'll be back later to explain more. Please do:
    Code:
    sudo su
    echo "blacklist rt2800pci" >> /etc/modprobe.d/blacklist.conf
    exit
    Reboot and tell me how it's working.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  6. #6
    Join Date
    Jul 2011
    Beans
    8

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    It works it works! Running super fast! Could you explain how this fixed the problem? You know, teach a man to fish kind of a thing. Regardless, thank you so much!

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,426
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    There are certain drivers including rt2860sta that are in 'staging,' meaning they are being fine tuned for inclusion in the mainline kernel. That's a good plan, except it means the driver already in the kernel, rt2800pci also grabs your device and tries to drive it and conflicts. So we blacklist one or the other, rt2860sta or rt2800pci, and stop the conflict. I happen to think, based solely on observation, that rt2860sta does the better job. Here is good evidence:
    It works it works! Running super fast!
    So, based on experience, I recommend blacklisting rt2800pci. That's what the echo command does; it puts the blacklist in the correct file. Afterwards, as your computer boots, it knows that we do not like rt2800pci and doesn't load it. That leaves rt2860sta to do its job without interference.

    In some kernel version in the future, I have no idea which, rt2860sta is supposed to be folded in to rt2800pci. If your blacklist file is still in place, since rt2800pci is blacklisted, your wireless won't work at all. Either you will remember this and undo it, you will have a copy of this in your user directory or you will search for RT2860 on the forum and be reminded what to do.

    I'm trying to explain this very clearly so the searchers will find it and understand it in the distant future when I've had the laptop lifted off of my lap by the county coroner.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  8. #8
    Join Date
    Jul 2011
    Beans
    8

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Thanks for the explanation and thanks again for the help. Any advice on where to start learning more of this "under the hood" stuff? Most of the beginner-oriented linux books I see on Amazon are more about how to just run programs in the gui...

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,426
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Quote Originally Posted by utamore View Post
    Thanks for the explanation and thanks again for the help. Any advice on where to start learning more of this "under the hood" stuff? Most of the beginner-oriented linux books I see on Amazon are more about how to just run programs in the gui...
    Please see Private Messages at the top.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  10. #10
    Join Date
    Nov 2007
    Beans
    187

    Re: Wireless DL very slow (Ralink RT2860/Realtek RTL8111)

    Quote Originally Posted by chili555 View Post
    Indeed a conflict. Let's shortcut it and I'll be back later to explain more. Please do:
    Code:
    sudo su
    echo "blacklist rt2800pci" >> /etc/modprobe.d/blacklist.conf
    exit
    Reboot and tell me how it's working.
    Hi chili555,

    I really wish you're still listening cause I tried your suggestion but the problem is still there.
    I'm using Ubuntu 10.10 (Maverick Meerkat)

    (the box is only connected via wifi)
    Code:
    dude@home:~$ lspci -nn | grep -i net
    01:00.0 Network controller [0280]: RaLink RT2860 [1814:0781]
    03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
    Before I blacklisted rt2800pci:

    Code:
    dude@home:~$ lsmod | grep rt2
    rt2860sta             504703  0
    rt2800pci               8852  0
    rt2800lib              28961  1 rt2800pci
    rt2x00usb               9779  1 rt2800lib
    rt2x00pci               6029  1 rt2800pci
    crc_ccitt               1351  2 rt2860sta,rt2800pci
    rt2x00lib              27339  4 rt2800pci,rt2800lib,rt2x00usb,rt2x00pci
    led_class               2633  1 rt2x00lib
    mac80211              231927  3 rt2x00usb,rt2x00pci,rt2x00lib
    cfg80211              144790  2 rt2x00lib,mac80211
    eeprom_93cx6            1345  1 rt2800pci
    After I blacklisted rt2800pci:

    Code:
    dude@home:~$ lsmod | grep rt2
    rt2860sta             504703  1
    crc_ccitt               1351  1 rt2860sta
    I realized there were issues when I finish to configure my server and enabled samba. So I started to blame samba for the slow transfer rate. So reading a bit about it, I tried to compare it with scp, but I had similar (or even worse) performances.
    The hard disks are fine since I can copy at around 80 MB/sec inside the server (maybe not stellar, but more than enough for me) and I tried to copy on both the big disks and the SSD OS disk.
    I tried different solutions (and I always rolled back to the original situation if nothing changed):
    editing /etc/nsswitch.conf
    http://ubuntuforums.org/showpost.php...4&postcount=14

    editing sysctl.conf
    http://ubuntuforums.org/showpost.php...3&postcount=20

    I wanted to try this but I wasn't capable:
    http://ubuntuforums.org/showpost.php...8&postcount=27

    I got the following error:

    Code:
    dude@home:~$ uname -a
    Linux NAS 2.6.35-30-generic-pae #60-Ubuntu SMP Mon Sep 19 22:29:36 UTC 2011 i686 GNU/Linux
    dude@home:~$ sudo apt-get install linux-backports-modules-compat-wireless-2.6.38-lucid-generic meta-package
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-backports-modules-compat-wireless-2.6.38-lucid-generic
    E: Couldn't find any package by regex 'linux-backports-modules-compat-wireless-2.6.38-lucid-generic'
    E: Unable to locate package meta-package
    But it doesn't matter what I tried, my typical scp performance is between 80 and 120 kB/sec

    Sometimes the scp copy goes up to 300 kB/sec, but I don't seem to find a pattern. Sometimes it does, sometimes it stays around 100 kB/sec.

    Your patch is the only one I left, since a driver conflict doesn't seem a good plan anyway.

    Samba now is about 500 kB/sec, but this is still very slow (or is it?)

    I also tried to rule out the wireless router (I have two) but I'm getting similar results for both.

    the only thing I can't rule out is that it's my laptop rather then the server to be slow, since I have only a server and a laptop...

    Any suggestion (even ideas for further tests) is really appreciated!

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •