I thought I would find this everywhere but I haven't. I upgraded to Firefox 5 when it came into Mozilla's stable PPA but about 60% of my plugins are not working. I've tried forcing compatibility using the Nightly Tester tools but still have tons non-functional. Is there a safe procedure to downgrade to v4.x? Is there a PPA with 4 still available (Mozilla simply removed it entirely). I'm using Lucid 10.4.2 32bit.

I'm normally pretty careful on upgrades but this one got past me. This new release schedule is going to kill Firefox if they don't solve the plugin issue.

Thanks for any advice.