Results 1 to 10 of 147

Thread: How To: ubuntu natty (11.04) on asus a53s (k53sv family)

Threaded View

  1. #1
    Join Date
    Jun 2006
    Vienna, Austria

    How To: ubuntu natty (11.04) on asus a53s (k53sv family)


    i just got my asus 2 days ago and wanted to share my findings with you how to get nearly everthing working:

    its an asus a53s which is nearly the same as a k53sv:
    core i5, 4gb, 500gb wd scorpio blue, gt 540m 2gb vram, cardreader, NO bluetooth

    just for the record:
    it originally came with BIOS version 208, i updated it to 210 and then to version 300 (i thought it would fix fan issues, but it didn't)

    still not working:

    * camera is upside-down (you can find solutions using google easily or here on the forums / NOT every asus laptop has this problem!)
    * stability issue #2 (heavy lags resulting in freeze)
    * harddisk clicking with WD scorpio blue -> try post #33 and report back please -this works for me!

    what will work after doing these steps:

    * stable WLAN (ath9k driver in 2.6.38 natty is buggy)
    * Touchpad (2 Finger Scrolling/disable on typing) (will actually get detected as touchpad, not as mouse on default natty install)
    * Nvidia offloading through bumblebee WITHOUT the fan going mad (uploaded scripts to bumblebee to fix fan issues)
    * fn keys like volume up/down - play/pause/next/prev (see post #9)
    * stability issue #1 (related to intel sandybridge drivers - update to patched kernel to fix GUI hangs, try post #25 - works for me | fixed in 2.6.38-11)
    * cardreader fix (follow _byrons_ post)
    * BLUETOOTH (follow _byrons_ post again )

    not confirmed by anyone expect me
    * hdd performance issues (repartition whole drive cause its a 4k advanced format hdd, aligning partition table will fix those small lags - if you don't have 'em, nevermind #5)

    my hardware:
    03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    slow wlan connection, copying files over LAN normally will work for 5-10 minutes then it will drop completely.. you had to disconnect and connect again to get it working for another 5-10 minutes

    one of many bugreports to this problem:

    speed before: 120-170kb/s max.

    as 2.6.39 seems to bring new bugs, lets just update (dirty way) the ath9k driver (based on this guide

    tar xfvj compat-wireless-2.6.39-1.tar.bz2
    cd compat-wireless-2.6.39-1
    ./scripts/driver-select ath9k
    sudo make install
    sudo make unload
    sudo modprobe ath9k
    or just reboot insteat of the last 2 steps

    after driver update: 2500-3000kb/s on g-wlan... same situation


    gets detected as mouse so no scrolling etc..

    to get it detected and working (can be configured in the "mouse" preferences):

    after following these steps
    reboot or unload old module and load new one:

    sudo rmmod psmouse && sudo modprobe psmouse
    Nvidia offloading/disabling NVIDIA card to get over 4hrs of battery life:

    you will need git:
    sudo aptitude install git
    after its finished do these steps:
    git clone
    cd bumblebee/
    sudo ./
    if you get asked which config you want to use, choose the one from "Thomas Krutz" - this will fix any fan issues

    be aware, this will add another xorg ppa to install a newer nvidia driver.
    but it should work


    you can now try if it worked:

    optirun glxgears
    to use the nvidia card
    to use intel card

    any change to the GL libraries (like bumblebee PPA or xorg-edgers PPA will break intel DRI after installing/setting up bumblebee, so be aware! i think the bumblebee moves around some files)

    hope this helps someone

    obsolete as of 4.7.2011

    i submitted my enable/disable scripts
    when you get asked which config you want to use, just choose the one from "Thomas Krutz"

    to disable the nvidia card you can use the following commands:

    bumblebee-enablecard, bumblebee-disablecard, ...
    if you get caught by the same bug as me that after installing bumbleebee and the fan starts spinning at full speed
    i did this to fix it

    in /usr/src/acpi_call-1.0 i modified

    # Power control for Asus 1215N Optimus
    # by Pete Eberlein
    if ! lsmod | grep -q acpi_call; then
        echo "Error: acpi_call module not loaded"
    acpi_call () {
        echo "$*" > /proc/acpi/call
        cat /proc/acpi/call
    case "$1" in
        echo _DSM $(acpi_call "\_SB.PCI0.PEGR.GFX0._DSM" \
    	"{0xF8,0xD8,0x86,0xA4,0xDA,0x0B,0x1B,0x47," \
    	 "0xA7,0x2B,0x60,0x42,0xA6,0xB5,0xBE,0xE0}" \
    	 "0x100 0x1A {0x1,0x0,0x0,0x3}")
    	# ok to turn off: Buffer {0x59 0x0 0x0 0x11}
    	# is already off: Buffer {0x41 0x0 0x0 0x11}
        echo _PS3 $(acpi_call "\_SB.PCI0.PEGR.GFX0._PS3")
        echo _PS0 $(acpi_call "\_SB.PCI0.PEGR.GFX0._PS0")
        echo "Usage: $0 [on|off]"
    #echo P3MO $(acpi_call "\_SB.PCI0.PEGR.GFX0.P3MO")
    echo DGPS $(acpi_call "\_SB.PCI0.PEGR.GFX0.DGPS")
    PSC=$(acpi_call "\_SB.PCI0.PEGR.GFX0._PSC")
    echo _PSC ${PSC}
    case "$PSC" in
    echo "Asus 1215N Optimus appears to be ${PSC}"

    now you have to edit bumblebee-enablecard and bumblebee-disablecard to use this file:
    in enablecard: find the last lines
    #echo _PS0 $(acpi_call "\_SB.PCI0.PEG1.GFX0.DON")
    #echo _PS0 $(acpi_call "\_SB.PCI0.PEGR.GFX0.DON")
    modprobe nvidia-current
    and put a # before the echos

    write this right after the commented echo lines in the enablecard script:
    /full/path/to/ on
    in the disablecard script do the same, put a # on the last line and add
    /full/path/to/ off
    et voila, turn the pc off to get rid of the full speed fan (reboot wont help) and then boot your ubuntu again.. everything should work now .. at least it does work for me.
    Last edited by cucisan; August 18th, 2011 at 12:47 PM. Reason: cardreader/bluetooth fixes from _byron_


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts