Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37

Thread: Relsolution problem

  1. #21
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    How bizarre..
    It is like the file is ignored..

    Can you check that the xorg.conf is named exactly.
    "/etc/X11/xorg.conf"
    Linux is case sensitive & very pedantic.

    File ownership & permissions gotten messed up ?

    Maybe running nvidia-xconfig as sudo is a problem ?

    Don't have a
    /etc/X11/XF86Config
    file do you ?
    Last edited by BicyclerBoy; June 26th, 2011 at 12:46 AM.

  2. #22
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Re: Relsolution problem

    Hello

    Yep its named as below , i don't have "XF86Config"

    Any Ideas
    ???
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  3. #23
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    Need to find the actual error/warning messages.

    If you startup gdm X server with logverbose >=6 then nvidia driver prints out detailed info on the mode validation process.

    startx -- -verbose 5 -logverbose 6
    You may be able to run this after stopping the gdm, I have never tried doing this.

    Otherwise, I guess you have to edit the script that launches X server somehow.
    Then switch to console ..
    [sudo] service gdm stop
    [sudo] service gdm start

    The /var/log/Xorg.0.log will probably be significantly longer..
    cat /var/log/Xorg.0.log | grep (WW)

    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    Last edited by BicyclerBoy; June 27th, 2011 at 09:34 PM.

  4. #24
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Talking Re: Relsolution problem

    hello


    sorry for slowness in getting back ! Cool i will try it and report back !!!
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  5. #25
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    As an alternative to the startx verbose ...

    Could add this to /etc/X11/xorg.conf
    Option "ModeDebug" "TRUE"
    to get more info into the /var/log/Xorg.0.log

    But I guess it may not work with the old driver & will not work if the file is ignored..

  6. #26
    Join Date
    Jun 2010
    Beans
    244

    Re: Relsolution problem

    Quote Originally Posted by BicyclerBoy View Post
    How bizarre..
    It is like the file is ignored..

    Can you check that the xorg.conf is named exactly.
    "/etc/X11/xorg.conf"
    Linux is case sensitive & very pedantic.

    File ownership & permissions gotten messed up ?

    Maybe running nvidia-xconfig as sudo is a problem ?

    Don't have a
    /etc/X11/XF86Config
    file do you ?
    That is really odd.

    From the user's Xorg.0.log

    Code:
    [    25.000] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun 20 22:14:12 2011
    [    25.001] (==) Using config file: "/etc/X11/xorg.conf"
    [    25.001] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    Try using the /usr/share/X11/xorg.conf.d/ partial xorg.conf directory as well with the single section containing the modeline? eg. /usr/share/X11/xorg.conf.d/modeline.conf

    Maybe kms is on? I know when kms is enabled the system typically ignores /etc/X11/xorg.conf and it will still check /usr/share/X11/xorg.conf.d/ for partial *.confs. (only /usr/share/X11/xorg.conf.d/ will be declared in the log)

    However, since /etc/X11/xorg.conf is declared in the log it is suggesting everything is setup properly to work with nvidia.ko.

  7. #27
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Red face Re: Relsolution problem

    Hello ,


    BicyclerBoy
    : I tried running [sudo] service gdm stop but it came up with an error. I will try the other steps and report.


    I think its any issue with the NVIDIA driver am going to try find way to speak to NVIDIA !
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  8. #28
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Red face Re: Relsolution problem

    Hello ,

    I've made a post on the NVIDIA Linux forums asking help: http://www.nvnews.net/vbulletin/show...69#post2451369


    Where would i add Option "ModeDebug" "TRUE" in the config file ?

    Thank you !
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  9. #29
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    (Unfortunately) A lot of the xorg.conf options can go into any section..

    I would use a "ServerFlags" section..because this seems logical & tidy.

    The only criticism of nVidia drivers readme/docs is that they are very vague about sections in xorg.conf.

    There has been some suggestion (inc. prev. post) that Xorg is now using a slightly different configuration file or folders.
    /etc/X11/xorg.conf.d/*.conf

    Haven't found anything that states the xorg.conf file is ignored..

    You are still using Xorg 1.09. Don't let that upgrade to 1.10...else you'll have even more problems.
    Did you see this thread about Xorg 1.10 breaking the old drivers.
    http://www.nvnews.net/vbulletin/showthread.php?t=162140
    Last edited by BicyclerBoy; July 1st, 2011 at 10:32 PM. Reason: Xorg 1.10 trouble

  10. #30
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Lightbulb Re: Relsolution problem

    Hello ,

    I've been doing some diging and a found this : http://us.download.nvidia.com/XFree8...ppendix-d.html

    I can turn off mode validation using one of these arguments with option mode validation ?


    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •