Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: Relsolution problem

  1. #11
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Red face Re: Relsolution problem

    Hello

    ok will try that FYI the error has changed now :

    Code:
    [    26.540] (--) NVIDIA(0):     option
    [    26.540] (--) Depth 24 pixmap format is 32 bpp
    [    26.543] (II) NVIDIA(0): Initialized GART.
    [    26.563] (EE) NVIDIA(0): Failed to allocate/map the primary surface!
    [    26.565] 
    Fatal server error:
    [    26.565] AddScreen/ScreenInit failed for driver 0

    I will make the changes and report back !
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  2. #12
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    Not making any progress are we..
    My problem is that I have never used a video driver version or card so old.
    So we could be missing some subtle differences to the current driver.

    That error can mean the virtual desktop is to big for the amount of ram.
    My guess is there an error in your xorg.conf file...

    Try adding this to the "Device" section
    Code:
    Option       "NvAGP" "2"
    BusID        "1:0:0"
    But why this would be necessary now when the driver has been working is a question ...

    Found this...
    NVIDIA Legacy driver 96.43.19 may require nopat option

    If X-server fails to start or can't set some resolution on legacy cards and you see the following message:
    NVIDIA(0): Failed to allocate/map the primary surface!
    try adding nopat kernel option (in boot options or in grub menu)

    After all that...
    Can you post the xorg.conf & the Xorg.0.log file as attachments.
    Please post as attachment, don't let the forum mangle the file.

    The log file needs to be from the failed boot if you can..

    Maybe the problem is the color depth at the higher resolution...
    Maybe you could try Depth 16
    Last edited by BicyclerBoy; June 22nd, 2011 at 11:28 AM. Reason: color depth 16

  3. #13
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Re: Relsolution problem

    Hello ,

    No fixed one issue and made a second ! right I've made changes to the Xconfig and the Grub config. I've done some googling :

    http://forums.nvidia.com/index.php?showtopic=169294

    It raised on that link ! ill reboot and update this post with everything !

    Once again Thanks for your help !
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  4. #14
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Cool Re: Relsolution problem

    Hello ,

    The changes i made fixed the back log-in screen but once i log in its still the wrong size with no Gnome panel from the X.org log :

    Code:
    [    86.553] (WW) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    [    86.553] (WW) NVIDIA(0):     will be used as the requested mode.
    [    86.553] (WW) NVIDIA(0): 
    [    86.553] (II) NVIDIA(0): Validated modes:
    [    86.553] (II) NVIDIA(0):     "nvidia-auto-select"
    [    86.554] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
    [    86.554] (--) NVIDIA(0): DPI set to (63, 84); computed from "UseEdidDpi"
    I how i stop the driver from Checking which modes to use ??? I've attached the log and the config
    Attached Files Attached Files
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  5. #15
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    The driver seems to be ignoring the screen section completely..
    The xorg.conf layout is as per the Xorg defining docs X11R6 & is as I have used with nvidia 173 to 260.
    Maybe the earlier nvidia driver did not follow the standard or I have not understood.

    There is a shortcut syntax for sticking the modeline directly into "Monitor" section.
    Maybe that will work...just copy the modeline (one line) into the monitor section.

    From re-reading this thread...
    You can not use the Gnome Display preferences with the nvidia X server..
    You must only use the nvidia-settings programs, the Gnome tools do not correctly recognize the video modes/refresh rates.
    Last edited by BicyclerBoy; June 22nd, 2011 at 09:53 PM.

  6. #16
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Re: Relsolution problem

    Hello ,

    I re-ran Nvidia-xconfig and added
    Code:
    Modeline     "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
    EndSection
    in to the Monitor part. Then added
    Code:
    Option       "NvAGP" "2"
    BusID        "1:0:0"
    Back aswell in the xconfig but rebooted and am back to the black log in screen


    any ideas ??
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  7. #17
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    I think the problem is in the monitor EDID reported..

    I think we should try to disable the EDID mode validation bit by bit..
    You already have the horiz & vert freq entries for the monitor.

    You can create a new section:
    Section "ServerFlags"
    EndSection
    Code:
    
          Option "ModeValidation" "NoEdidModes"
        Option "UseEDIDFreqs" "FALSE"
          Option "UseEDIDDpi" "FALSE"

    You could try adding these above entries one at a time starting from the top one

    The last king hit is this...
    Code:
        Option "UseEDID" "FALSE"
    Failing this buy a PC monitor with DVI & VGA.
    Last edited by BicyclerBoy; June 23rd, 2011 at 08:49 PM.

  8. #18
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Re: Relsolution problem

    Hello

    Sorry to the time to post back ! I had to clean my pc and fix the internet !


    Right I will try that , I've attach a newer log with more errors ): it say it can not find the screen ! GRRR Thanks for all your help !!
    Attached Files Attached Files
    Last edited by coolcaseley67; June 24th, 2011 at 04:50 PM. Reason: error
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

  9. #19
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Relsolution problem

    The shortcut modeline entry has to go into the "Monitor" section not the Screen section.

    The "Monitor" section can have the modeline (all the list pixel count numbers)
    ModeLine "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

    The "Screen" section must have the modeline "Name"
    ( in SubSection "Display")
    Modes "1368x768_60.00"
    Last edited by BicyclerBoy; June 24th, 2011 at 10:41 PM.

  10. #20
    Join Date
    Aug 2009
    Location
    uk
    Beans
    170
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Cool Re: Relsolution problem

    Hello

    The driver appears to carry on use EDID ,i've been through the sever flags options

    from the x org log

    Code:
    [    25.545] (II) NVIDIA(0): Assigned Display Device: CRT-0
    [    25.545] (WW) NVIDIA(0): 
    [    25.545] (WW) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    [    25.545] (WW) NVIDIA(0):     will be used as the requested mode.
    [    25.545] (WW) NVIDIA(0): 
    [    25.545] (II) NVIDIA(0): Validated modes:
    [    25.545] (II) NVIDIA(0):     "nvidia-auto-select"
    [    25.545] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
    [    25.545] (--) NVIDIA(0): DPI set to (63, 84); computed from "UseEdidDpi" X config
    [    25.545] (--) NVIDIA(0):     option
    [    25.546] (--) Depth 24 pixmap format is 32 bpp
    [    25.548] (II) NVIDIA(0): Initialized GART.
    [    25.764] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
    [    25.907] (II) Loading extension NV-GLX
    Linux may be small but it is powerful ....
    My online blog http://joeslifewithubuntu.blogspot.com/
    (One man's Journey in Ubuntu and Linux: with Daily news,Daily Comment & helpful stuff for users of Ubuntu.)

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •