Page 1 of 6 123 ... LastLast
Results 1 to 10 of 56

Thread: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

  1. #1
    Join Date
    Aug 2009
    Location
    Brisbane, Australia
    Beans
    16
    Distro
    Ubuntu 9.10 Karmic Koala

    Question Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    Hi everyone,

    I turned my server computer on after a few weeks of not having time to get back to it (after freshly installing 9.04 and getting some great help on these forums!), and it told me that 9.10 was out, so I upgraded in through the update manager.

    It restarted a few times, and then on what was to be the last restart, it came up with the following error message:

    Code:
    Mount of filesystem failed. a8d932-6c28-4c09-8b0e-23a20e8c5a9d
    A maintenance shell will now be started.
    CONTROL-D will terminate this shell and retry.
    root@server-desktop:"#
    So I did CONTROL-D and this is what came up on the screen aftewards:

    Code:
    root@server-desktop:"# exit
    fsck from util-linux-ng 2.16
    /dev/sda1: superblock last mount time (sat oct 31 20:09:47 2009,
    now=fri oct 30 12:10:06 2009) is in the future
    
    /dev/sda1:UNEXPECTED INCONSISTENCY; RUN FSCK MANUALLY.
    (i.e., without -a or -p options) 
    swapon: /dev/disk/by-uuid/d5c266b2-fdc9-4417-b537-b4f388cc15c3: swapon failed: Device or resource busy
    mountall: swapon/dev/disk/by-uuid/d5c266b2-fdc9-4417-b537-b4f388cc15c3 [910] terminated with status 255
    mountall: problem activating swap: /dev/disk/by-uuid/d5c266b2-fdc9-4417-b537-b4f388cc15c3
    mountall start/running, process 904
    mountall: fsck / [908] terminated with status 4
    mountall: Filesystem has errors: /
    init: mountall main process (904) teminated with status 3
    Mount of filesystem failed.
    A maintenance shell will now be started
    CONTROL-D will terminate this shell and retry.
    root@server-desktop:"#
    Restarting doesn't help, and I really don't know where to go from here, and didn't see anything helpful in my searches of the forums before posting here.

    Any advice would be great.

    Thanks again,
    Nicole

  2. #2
    Join Date
    Aug 2007
    Location
    From the land down under
    Beans
    1,245
    Distro
    Ubuntu Development Release

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    /dev/sda1:UNEXPECTED INCONSISTENCY; RUN FSCK MANUALLY.
    in the terminal space below type

    Code:
    fsck
    after it runs, ctrl+d, and you may have to do it again.

    It should generally 'fix itself' after running fsck, as many people had this issue.
    // Blog

  3. #3
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    I have not seen that bug myself but there was quite a bit of it a couple weeks ago. I would;
    Code:
    ubuntu-bug mountall
    and follow the directions as they come up.

    This will end up with you on the launchpad page with the bug and there should be directions for fixing it.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  4. #4
    Join Date
    Apr 2009
    Beans
    1

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    [userergel:] schrieb:
    > falls es jemand interessiert.
    >
    > Ich hab am Ende meiner fstab folgende Zeile gefunden:
    > /home /home dazukofs
    >
    > Keine Ahnung wie die dahin kam, hab sie gelöscht und nun gehts.

  5. #5
    Join Date
    Aug 2009
    Location
    Brisbane, Australia
    Beans
    16
    Distro
    Ubuntu 9.10 Karmic Koala

    Talking Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    Hi guys,

    Thanks for the help.

    To ikt - I only know a tiny bit about cmd prompt style things, so even though I saw that and it made sense I didn't want to touch it just in case it made a bigger mess!

    And in regards to the suggestions, I haven't had to do any of them as today (about 24 hours since the problem) I switched the computer back on, and it just worked - gotta love computers!

    Thanks again,
    Nicole

  6. #6
    Join Date
    Nov 2009
    Beans
    1

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    I have same problem, and now it's solved.
    Thanks a lot you guys

  7. #7
    Join Date
    Nov 2009
    Beans
    1

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    thanks, it works. You are asked several times to fix and finally the control-d keys restart the computer properly.

  8. #8
    Join Date
    Dec 2008
    Beans
    2

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    thanks
    even i had the same problem and din't know what to do

  9. #9
    Join Date
    Apr 2008
    Beans
    6

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    i got this error but after a fresh install. fsck worked.

  10. #10
    Join Date
    Oct 2008
    Beans
    1

    Re: Error After Upgrade To 9.10 - "Mount of filesystem failed..."

    Quote Originally Posted by freezerburn666 View Post
    i got this error but after a fresh install. fsck worked.
    +1

    useful writeup

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •