Results 1 to 4 of 4

Thread: synaptics tomahawk: depends: libqt4-sql-sqlite but it is not going to be installed

  1. #1
    Join Date
    Jun 2011
    Beans
    34

    synaptics tomahawk: depends: libqt4-sql-sqlite but it is not going to be installed

    I get the error when trying to mark tomahawk for installation using synaptics. I googled the error but couldn't find anything on it. could some one help me figure out what's going on?

  2. #2
    Join Date
    Mar 2006
    Location
    Sevierville, Tennessee
    Beans
    1,279
    Distro
    Ubuntu Development Release

    Re: synaptics tomahawk: depends: libqt4-sql-sqlite but it is not going to be installe

    Here is the link to what you want to know:

    http://www.linuxquestions.org/questi...talled-749121/
    Gary
    Linux since 1995, Ubuntu since 2006

  3. #3
    Join Date
    Jun 2011
    Beans
    34

    Re: synaptics tomahawk: depends: libqt4-sql-sqlite but it is not going to be installe

    Unfortunately this doesn't quite answer my question or solve my problem. It would appear that I either don't have the correct repositories or simply don't have all the ones I need. I've got the paulo-miguel-dias/tomahawk repo, but I know the libqt4-sql-sqlite is in the libqt4-dev package.
    when I $sudo apt-get install libqt4-dev I get the following:

    The following packages have unmet dependencies:
    libqt4-dev : Depends: libqt4-dbus (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-qt3support (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-xml (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqtgui4 (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-network (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-svg (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-sql (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-script (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-scripttools (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-xmlpatterns (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-designer (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-help (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-test (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Depends: libqt4-declarative (= 4:4.7.2-0ubuntu6) but 4:4.7.2-0ubuntu6.1 is to be installed
    Recommends: libqt4-opengl-dev (= 4:4.7.2-0ubuntu6) but it is not going to be installed
    E: Broken packages

  4. #4
    Join Date
    Jul 2011
    Beans
    1

    Re: synaptics tomahawk: depends: libqt4-sql-sqlite but it is not going to be installe

    Do you have any version of virtualbox installed? If yes try to upgrade it. I had the same problem and after upgrade, even if the libqt4-core would not install, libqt4-dev did install without problems.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •