Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: error de paquets a l'actualitzar

  1. #1
    Join Date
    Jun 2010
    Location
    Barcelona
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    error de paquets a l'actualitzar

    Bona tarda, des de que vaig instal·lar la versió 11.04 (Ubuntu Borges Jam) que tinc força problemes per les actualitzacions (encara que hi ha alguns dies que s'actualitza tot sense cap problema; deu dependre dels paquets x actualitzar). El tema està en que després de "llegir" el release, em surt el missatge següent: i llavors s'atura tot el procés.


    Captura-3.png

    Captura-1.png
    Per a més informació, puc dir que algun dia he provat de fer un terminal amb l'ordre següent. sudo apt-get update (i tampoc no ha acabat de fer bé la feina). Fa més temps, ja em vaig trobar amb el problema similar però era per un tema de connexió a internet -vegeu el threat-. De moment, tampoc no he fet res més pq no sé trobar on és el problema. Moltes gràcies i salut per tots!
    Last edited by ladisse; June 8th, 2011 at 06:25 PM.
    Moltes gràcies a tots!
    Salut i força

  2. #2
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    1,577
    Distro
    Ubuntu Development Release

    Re: error de paquets a l'actualitzar

    Respecte al primer missatge, Ubuntu sempre ho mostra quan es tracta de paquets proveïts externament, com ara els d'Adobe. Si el paquet s'ha baixat del Centre de Programari o del Gestor Synaptics tot i que surti aquest missatge no és perillós instal·lar-lo.

    En quant al segon missatge, sembla que tens habilitat un dipòsit de programari que està oferint un paquet que ja tens instal·lat, o està duplicat. Accedeix a la gestió de dipòsits a Paràmetres de sistema (Al menú de tancar) -> Sistema - Gestor de Paquets Synaptic, i aquí busca la pestanya "Paràmetres" i l'opció Dipòsits. A la pestanya "Altre programari" mira què tens marcat, i si pots desmarcar "Canonical Partners". Tanca el Synaptic, fes a una terminal "sudo apt-get update" i "sudo apt-get upgrade". Això ho hauria d'arreglar.

    Posteriorment pots tornar a habilitar "Canonical Partners" perquè continuï actualitzant els paquets d'aquest dipòsit.

  3. #3
    Join Date
    Jun 2010
    Location
    Barcelona
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: error de paquets a l'actualitzar

    Gràcies. Després d'aplicar els canvis del Synaptic, al refrescar no em deixa (veure captura 7)Captura-7.jpg

    Captura-8.jpg

    Poso la seqüència de pantalles despŕes d'haver tret Canonical i refrescar paquets.
    He obert un terminal amb les ordres update i aquests són els fallos que m'han sortit:
    Captura-9.jpg

    Captura-10.jpg

    Captura-11.jpg
    Moltes gràcies a tots!
    Salut i força

  4. #4
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    1,577
    Distro
    Ubuntu Development Release

    Re: error de paquets a l'actualitzar

    Pots adjuntar a un missatge el fitxer:

    /etc/apt/sources.list

    ?

  5. #5
    Join Date
    Jun 2010
    Location
    Barcelona
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: error de paquets a l'actualitzar

    Això és el que em respon la terminal:
    Captura-13.png
    Moltes gràcies a tots!
    Salut i força

  6. #6
    Join Date
    Apr 2007
    Beans
    39
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: error de paquets a l'actualitzar

    Quote Originally Posted by ladisse View Post
    Això és el que em respon la terminal:
    Amb el que has escrit al terminal no obtindràs cap resposta satisfactòria:
    l'hi estas passant una ruta sense dir-li que ha de fer.
    Per obtenir el contingut del fitxer que et demanen hauries d'escriure:
    Code:
    sudo cat /etc/apt/sources.list
    i enganxar la sortida a un fitxer "txt". Per fer-ho més fàcil escriu al terminal:
    Code:
    sudo gedit /etc/apt/sources.list &
    i s'obrirà en un editor de text gràfic. Ara resta copiar i enganxar.
    Compta amb "apt", ho has escrit malament!
    Salut

  7. #7
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    1,577
    Distro
    Ubuntu Development Release

    Re: error de paquets a l'actualitzar

    Jo el que deia era simplement clicar "Manage attachements" a dalt del tot, navegar fins a la carpeta /etc/apt i adjuntar el fitxer "list", però ara que veig kette té raó, no et deixaria perquè no és una de les extensions de fitxers permeses.

    Per tant és millor el que diu kette, obrir una terminal i entrar:

    cat /etc/apt/sources.list > sources.txt

    i adjuntar (amb el "Manage attachments") aquest últim fitxer.

  8. #8
    Join Date
    Jun 2010
    Location
    Barcelona
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: error de paquets a l'actualitzar

    Volíeu dir això? És que últimament tinc la sensació que no entenc res de res.... Gràcies!

    terminal.pdf
    Moltes gràcies a tots!
    Salut i força

  9. #9
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    1,577
    Distro
    Ubuntu Development Release

    Re: error de paquets a l'actualitzar

    Sí, és això, es tracta del fitxer on s'estipulen els dipòsits de programari que va actualitzant el sistema, i a través del "Gestor de Paquets Synaptic" o del "Centre de Programari Ubuntu" es va canviant aquest fitxer si afegeixes o elimines un dipòsit.

    Sembla que et falten les actualitzacions de seguretat. Jo faria el següent: obrir el "Centre de programari Ubuntu" i al menú "Edita" -> "Fonts de programari", a la pestanya "Programari Ubuntu" (la primera) ho marcaria tot menys "Codi font", l'última opció (si no coincideix algun d'aquest noms perdoneu però estic a un sistema amb els menús en anglès), i a la pestanya "Altre programari" ho desmarcaria tot, si encara tens alguna cosa marcada cosa que no sembla pel teu fitxer sources.list. A la pestanya "Actualitzacions" marcaria "Actualitzacions importants de seguretat" i "Actualitzacions recomanades" (també es convenient marcar el "backports", la quarta opció). També marcar "mirar actualitzacions" i aquí la tercera opció "Sols notifica sobre actualitzacions disponibles". Per tant en aquesta pestanya marcar les opcions 1, 2, 4 i 5 i dins de la 5 la tercera opció.

  10. #10
    Join Date
    Jun 2010
    Location
    Barcelona
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: error de paquets a l'actualitzar

    ho he fet, i per una estona m'he cregut que funcionava.... després, al instal·lar els paquets baixats -que, sigui dit els ha baixat sense problemes, algo hem avançat-, doncs ha resultat que m'ha sortit un missatge dient que fallava la connexió a internet. Jo, innocent, he provat amb el "truco" del ping i resulta que internet i la connexió estan bé (100% dels paquets correctes). Algú em dóna una pista més? Moltes gràcies a tots, altra vegada.
    Moltes gràcies a tots!
    Salut i força

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •