Page 1 of 11 123 ... LastLast
Results 1 to 10 of 108

Thread: headphone jack not working

  1. #1
    Join Date
    Dec 2008
    Beans
    137
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Angry headphone jack not working

    running 64bit ubuntu 11.04 on my new toshiba satellite l-655-s5150

    the headphone jack does not work, but the internal speakers work fine. i mostly use my computer for audio production, so ubuntu is pretty useless if i can't hook up a decent pair of headphones to it. and for that reason i'm forced to use windows until then. i really hate using windows so PLEASE HELP!
    Last edited by silverhaze06; June 3rd, 2011 at 09:05 PM. Reason: more info

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: headphone jack not working

    Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]

  3. #3
    Join Date
    Dec 2008
    Beans
    137
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: headphone jack not working

    it gives me

    Code:
    --2011-06-03 23:47:33--  http://www.alsa-project.org/alsa-info.sh
    Resolving www.alsa-project.org... 77.48.224.243
    Connecting to www.alsa-project.org|77.48.224.243|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh [following]
    --2011-06-03 23:47:37--  http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh
    Resolving git.alsa-project.org... 77.48.224.243
    Reusing existing connection to www.alsa-project.org:80.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/plain]
    Saving to: `alsa-info.sh'
    
        [  <=>                                  ] 27,247      85.4K/s   in 0.3s    
    
    2011-06-03 23:47:41 (85.4 KB/s) - `alsa-info.sh' saved [27247]
    
    ALSA Information Script v 0.4.60
    --------------------------------
    
    This script visits the following commands/files to collect diagnostic
    information about your ALSA installation and sound related hardware.
    
      dmesg
      lspci
      lsmod
      aplay
      amixer
      alsactl
      /proc/asound/
      /sys/class/sound/
      ~/.asoundrc (etc.)
    
    See 'alsa-info.sh --help' for command line options.
    Last edited by silverhaze06; June 4th, 2011 at 05:51 AM.

  4. #4
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: headphone jack not working

    Quote Originally Posted by silverhaze06 View Post
    it gives me

    Code:
    --2011-06-03 23:47:33--  http://www.alsa-project.org/alsa-info.sh
    Resolving www.alsa-project.org... 77.48.224.243
    Connecting to www.alsa-project.org|77.48.224.243|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh [following]
    --2011-06-03 23:47:37--  http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh
    Resolving git.alsa-project.org... 77.48.224.243
    Reusing existing connection to www.alsa-project.org:80.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/plain]
    Saving to: `alsa-info.sh'
    
        [  <=>                                  ] 27,247      85.4K/s   in 0.3s    
    
    2011-06-03 23:47:41 (85.4 KB/s) - `alsa-info.sh' saved [27247]
    
    ALSA Information Script v 0.4.60
    --------------------------------
    
    This script visits the following commands/files to collect diagnostic
    information about your ALSA installation and sound related hardware.
    
      dmesg
      lspci
      lsmod
      aplay
      amixer
      alsactl
      /proc/asound/
      /sys/class/sound/
      ~/.asoundrc (etc.)
    
    See 'alsa-info.sh --help' for command line options.
    Run the command again and when it prompts to upload key in Y and hit enter. You will then be provided with the url of your alsa-info. Post that link here.

  5. #5
    Join Date
    Dec 2008
    Beans
    137
    Distro
    Ubuntu 12.10 Quantal Quetzal

  6. #6
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: headphone jack not working

    You have two entries in alsa-base.conf that need to go. Open for editing:
    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf
    Remove this line:
    Code:
    options snd-hda-intel model=eapd probe_mask=1 position_fix=1
    Edit this line:
    Code:
    options snd-hda-intel model=laptop position_fix=1 enable=yes
    to look like this:
    Code:
    options snd-hda-intel model=thinkpad
    Save. Close. Reboot.

  7. #7
    Join Date
    Dec 2008
    Beans
    137
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: headphone jack not working

    IT WORKS! thank you very, very much!

  8. #8
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: headphone jack not working

    You're welcome! Please mark the thread solved using 'Thread Tools' up top.

  9. #9
    Join Date
    Jul 2011
    Beans
    1

    Re: headphone jack not working

    G'day lidex

    I wonder if you could coach me through mine the same way. Have a Asus A6000 laptop here with no headphone jack audio, Here's the link you were asking for:

    http://www.alsa-project.org/db/?f=0d...9dabaa07c8e9f9

    Cheers
    Fubar

  10. #10
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: headphone jack not working

    Quote Originally Posted by fubar990 View Post
    G'day lidex

    I wonder if you could coach me through mine the same way. Have a Asus A6000 laptop here with no headphone jack audio, Here's the link you were asking for:

    http://www.alsa-project.org/db/?f=0d...9dabaa07c8e9f9

    Cheers
    Fubar
    You don't have a mixer element for headphone, but you do have one for line playback currently muted and turned down as well. First try that control.
    Alsamixer
    Using a Terminal="Applications->Accessories->Terminal"
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.

    Also look in 'sound preferences' ,on the output tab, and toggle the 'connector' option.

    No joy? Try this using a Terminal.
    Code:
    echo "options snd-hda-intel model=asus" | sudo tee -a /etc/modprobe.d/alsa-base.conf
    Reboot

Page 1 of 11 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •