Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: UPDATED FOR CATA: Install World of Warcraft

  1. #11
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: UPDATED FOR CATA: Install World of Warcraft

    UPDATE:

    Do to many reasons, I only finished the download last night, and will start updating post #1 again later today.

    Actually, it worked out pretty good, with patch 4.2 coming out yesterday. One download, 9GB, and done. I think the client IS the way to go.
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  2. #12
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: UPDATED FOR CATA: Install World of Warcraft

    Spoke too soon, had an additional 5.5GB patch...

    But post #1 is updated.

    Sorry for the delay.
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  3. #13
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: UPDATED FOR CATA: Install World of Warcraft

    Now has examples of additions like the Curse Client
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  4. #14
    Join Date
    Feb 2008
    Location
    Los Angeles
    Beans
    339
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: UPDATED FOR CATA: Install World of Warcraft

    Quote Originally Posted by cwwilson721 View Post
    Now has examples of additions like the Curse Client
    FYI: something borked the v3 curse client around 6/28.
    • It's recognizing out-of-date addon need updates
    • But is failing to download addons updated after 6/28.
    • Old addons seem to download, but not the ones updated after 4.2 patch.

    If you are using the v3 client please file a detailed ticket to show your support so hopefully curse notices us and fixes it. Make sure you mention you are using the v3 curse client or you will more than likely get a canned windows answer for the v4 client that we cannot use.
    Dell Latitude D630 - 4GB RAM - 128GB SSD - Nvidia Quadro NVS 135M - Intel 4965 wireless - DVD/CDRW - bluetooth - fingerprint reader

  5. #15
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: UPDATED FOR CATA: Install World of Warcraft

    Quote Originally Posted by Tweak42 View Post
    FYI: something borked the v3 curse client around 6/28.
    • It's recognizing out-of-date addon need updates
    • But is failing to download addons updated after 6/28.
    • Old addons seem to download, but not the ones updated after 4.2 patch.

    If you are using the v3 client please file a detailed ticket to show your support so hopefully curse notices us and fixes it. Make sure you mention you are using the v3 curse client or you will more than likely get a canned windows answer for the v4 client that we cannot use.
    I've noticed that, and have added Ver 4 to the HOWTO
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  6. #16
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: UPDATED FOR CATA: Install World of Warcraft

    wine 1.3.26 and above work fine now, with no mouse issues anymore
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  7. #17
    Join Date
    Feb 2008
    Location
    Los Angeles
    Beans
    339
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: UPDATED FOR CATA: Install World of Warcraft

    Quote Originally Posted by cwwilson721 View Post
    I've noticed that, and have added Ver 4 to the HOWTO
    I forgot follow up: Curse Client v4 requires .NET to run and thus will not work on linux. I've tried getting it working using various winetricks install, and using mono, but no luck so far.

    Good news is that there was some sort of update in the curse server backend that pushed the fail date back around mid July so the v3 client can now download some addons updated post 4.2 patch. The bad news however is addons updated after that point are still fail. The v3 client can still tell which addons are out of date even if it can't download them.

    My work around was to install curse client v4 in winXP virtual machine and share my wow folder for it to update.
    Last edited by Tweak42; August 18th, 2011 at 01:38 AM.
    Dell Latitude D630 - 4GB RAM - 128GB SSD - Nvidia Quadro NVS 135M - Intel 4965 wireless - DVD/CDRW - bluetooth - fingerprint reader

  8. #18
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: UPDATED FOR CATA: Install World of Warcraft

    Quote Originally Posted by Tweak42 View Post
    I forgot follow up: Curse Client v4 requires .NET to run and thus will not work on linux. I've tried getting it working using various winetricks install, and using mono, but no luck so far.

    Good news is that there was some sort of update in the curse server backend that pushed the fail date back around mid July so the v3 client can now download some addons updated post 4.2 patch. The bad news however is addons updated after that point are still fail. The v3 client can still tell which addons are out of date even if it can't download them.

    My work around was to install curse client v4 in winXP virtual machine and share my wow folder for it to update.
    While that works, both 'workarounds' are ridiculous. (I use the VM route myself)

    Imagine this: You need gas in your car (Addons need to be updated on you Linux machine). You go to the gas station, but they decided that the old nozzles needed 'updating'(Curse v4), and they won't fit into your filler neck. And it's the ONLY place to buy gas in 329 miles. But, you can take your old 360 V8 Ford pickup truck (Windows) to the station instead, and because it has a tank mounted in the bed, the 'new nozzle' fits, and you can fill it up. Now you take the pickup to your car, and have to transfer the gas 8oz at a time, because all you have is a old paper Dixie cup (Reboot/reboot/reboot...).

    I forget the name offhand, but there IS another Addon site that actuall has a Linux Client...
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  9. #19
    Join Date
    Feb 2008
    Location
    Los Angeles
    Beans
    339
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: UPDATED FOR CATA: Install World of Warcraft

    Quote Originally Posted by cwwilson721 View Post

    I forget the name offhand, but there IS another Addon site that actuall has a Linux Client...
    http://www.wowmatrix.com/ has a linux client and http://minion.mmoui.com/ has a java client that can run under linux

    I got turned off from wowmatrix from the dust up they had with curse and wowinterface few years ago.
    http://wow.joystiq.com/2009/05/06/wo...ace/#continued

    I tried mmo minion and it was a pain to install was buggy and kept getting old versions. Development moves at snail pace since its been in beta since 2009.
    Dell Latitude D630 - 4GB RAM - 128GB SSD - Nvidia Quadro NVS 135M - Intel 4965 wireless - DVD/CDRW - bluetooth - fingerprint reader

  10. #20
    Join Date
    May 2007
    Location
    Denmark
    Beans
    84
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: UPDATED FOR CATA: Install World of Warcraft

    I read this thread and I saw there was a problem with Curse Client but that was ½ year ago.

    I have not been running WoW on linux since early WotLK and before I start installing I wonder if the situation has changed for Curse Client and if it works now?

    Only use Windows for WoW so really hope it will work since Curse Client syncs about 50 addons on my install and it would be hell to update them manually.

    If it doesn't work are there any alternatives? (I remember there used to be a python addon update script, but I suppose it doesn't work on Curse nowadays)

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •