Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Keyboard Input Methods not showing up

  1. #11
    Join Date
    Jul 2006
    Location
    Here
    Beans
    9,689

    Re: Keyboard Input Methods not showing up

    Quote Originally Posted by thameera View Post
    Any idea how to add a language to that Keyboard Layout Switcher applet? Mine has only the US layout.
    type-> gksudo leafpad /etc/default/keyboard
    add your languages to:
    XKBLAYOUT="us"


    i think theres also a command that does the same thing, but i forget, hit google.

  2. #12
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Keyboard Input Methods not showing up

    To add a language: Go to Preferences > Language Support This will open the Language and Text window Click on "Install/Remove Languages" and select the language you want to add. It will automatically install the language files and should enable the Keyboard Input Methods window. Go to Preferences > Keyboard Input Methods When you do this, a window will pop up asking if you want to start iBus. Click yes. Then you will see the iBus Preferences window where you can select the input method that you want and do things like assign a hotkey. The iBus icon should appear down by the clock now. After a reboot, you should be able to go to Preferences > Desktop Session Settings and make iBus start automatically on boot.

  3. #13
    Join Date
    Sep 2009
    Beans
    93
    Distro
    Ubuntu

    Re: Keyboard Input Methods not showing up

    Quote Originally Posted by whatthefunk View Post
    Go to Preferences > Keyboard Input Methods
    The problem I'm having is that when I click on Keyboard Input Methods nothing happens. No window shows up. :/

  4. #14
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Keyboard Input Methods not showing up

    Quote Originally Posted by thameera View Post
    The problem I'm having is that when I click on Keyboard Input Methods nothing happens. No window shows up. :/
    What language are you trying to install? Do you see the small box with an i in it near the clock?

  5. #15
    Join Date
    May 2007
    Beans
    147

    Re: Keyboard Input Methods not showing up

    How I would like to see this fixed!

  6. #16
    Join Date
    Apr 2009
    Beans
    50
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Keyboard Input Methods not showing up

    the problem is some missing dependencies in the ibus package for lubuntu, as described here: https://bugs.launchpad.net/ubuntu/+s...933/comments/4
    without them, you do not get the "i" icon in the panel. you DO NOT get this icon via the Keyboard Layout Handler applet, that is for switching the ACTUAL keyboard type, not for input methods.

    use synaptic or whatever, and make sure you have all these installed, then, log out and back in:

    libappindicator1
    python-appindicator
    python-gconf
    python-glade2
    python-pexpect

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •