Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Keyboard Input Methods not showing up

  1. #1
    Join Date
    Sep 2009
    Beans
    93
    Distro
    Ubuntu

    Unhappy Keyboard Input Methods not showing up

    I switched to pure LXDE desktop in my Ubuntu and now my Keyboard Input Methods dialog doesn't show up. When I click on the menu item nothing happens. The Preferences menu item in the keyboard icon in the panel doesn't work either.
    Please help, coz I badly need to switch languages while typing.

  2. #2
    Join Date
    Feb 2010
    Location
    Pittsburgh, PA, USA
    Beans
    219
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Keyboard Input Methods not showing up

    try running
    Code:
    ibus-daemon
    in the terminal. This should manually start the process. Then try opening the preferences.
    When people ask me what my most valuable trait is, I tell them that it is the ability to do a Google search.
    CMU ECE Class of 2015

  3. #3
    Join Date
    Sep 2009
    Beans
    93
    Distro
    Ubuntu

    Re: Keyboard Input Methods not showing up

    Quote Originally Posted by johngreth View Post
    try running
    Code:
    ibus-daemon
    in the terminal. This should manually start the process. Then try opening the preferences.
    I tried that, but it says 'current session already have an ibus-daemon' :S

  4. #4
    Join Date
    Jul 2006
    Location
    Here
    Beans
    9,689

    Re: Keyboard Input Methods not showing up

    so what does it say when you type "lxkeymap" in terminal?
    Attached Images Attached Images
    • File Type: png 1.png (184.3 KB, 13 views)

  5. #5
    Join Date
    Feb 2010
    Location
    Pittsburgh, PA, USA
    Beans
    219
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Keyboard Input Methods not showing up

    Try running Administration -> Language Support, and applying System-Wide Support. iBus gave me a message that it needed to be configured when I ran the command.
    When people ask me what my most valuable trait is, I tell them that it is the ability to do a Google search.
    CMU ECE Class of 2015

  6. #6
    Join Date
    Jul 2006
    Location
    Here
    Beans
    9,689

    Re: Keyboard Input Methods not showing up

    Quote Originally Posted by johngreth View Post
    Try running Administration -> Language Support, and applying System-Wide Support. iBus gave me a message that it needed to be configured when I ran the command.
    have you ever used lxde?
    @thameera, "system tools" instead of "Administration" under lxde menu

    @thameera, if you intend to use gnome stuff in lxde, you'll need to have the proper gnome startup apps in lxde startup. check preferences-> desktop session settings.

    are menu looks like this.
    Attached Images Attached Images

  7. #7
    Join Date
    Sep 2009
    Beans
    93
    Distro
    Ubuntu

    Re: Keyboard Input Methods not showing up

    When I type lxkeymap, the lxkeymap window shows up.
    I've already added iBus-daemon to the startup applications. It loads at startup, the problem is I can't access its Preferences. Do I need to start any other service at startup for this?

  8. #8
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,054
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Keyboard Input Methods not showing up

    I run Lubuntu and had similar problems. Im not on my home machine now, but I think that I added the Keyboard Input Methods icon to the tool bar on the bottom near the clock and then could access everything from there. i cant remember though. When I get home tonight I can take a look at it.

  9. #9
    Join Date
    Jul 2006
    Location
    Here
    Beans
    9,689

    Re: Keyboard Input Methods not showing up

    yeah, like he said theres a panel applet you add to switch.

    ps: i don't have no ibus-daemon, so doubt it's even needed. you might be having problems because you added lxde on top of ubuntu gnome, you may want to consider a straight lubuntu install, much faster & cleaner app wise.
    http://lubuntu.net/
    Attached Images Attached Images
    Last edited by kerry_s; June 3rd, 2011 at 09:22 AM.

  10. #10
    Join Date
    Sep 2009
    Beans
    93
    Distro
    Ubuntu

    Re: Keyboard Input Methods not showing up

    Any idea how to add a language to that Keyboard Layout Switcher applet? Mine has only the US layout.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •