Results 1 to 6 of 6

Thread: problem connecting via Realtek RTL 8139

  1. #1
    Join Date
    Jun 2011
    Beans
    2

    problem connecting via Realtek RTL 8139

    hi
    i am using ubuntu 10.04 along with windows xp, dual booting. recently i could not connected to my ADSL via Realtek RTL 8139 which was working fine in Windows XP. I have tried powering off/unplugging my machine but to not avail. please help.

  2. #2
    Join Date
    Oct 2007
    Location
    Europe
    Beans
    3,564
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: problem connecting via Realtek RTL 8139

    Quote Originally Posted by hg75 View Post
    hi
    i am using ubuntu 10.04 along with windows xp, dual booting. recently i could not connected to my ADSL via Realtek RTL 8139 which was working fine in Windows XP. I have tried powering off/unplugging my machine but to not avail. please help.
    the Realtek RTL 8139 chip works fine with linux so its not the problem.
    how do you connect in windows to adsl? via a always-on ethernet (or usb?) router or does the computer use a pppoe setup connection.
    Last edited by gandaran; June 2nd, 2011 at 08:07 AM.
    Intel Atom Dual Core D525 @ 1.80GHz, 1,0GB RAM, Intel Graphics Media Accelator 3150
    Linux User # 478860 Ubuntu User # 24004

  3. #3
    Join Date
    Sep 2009
    Location
    Hampshire, UK
    Beans
    375
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: problem connecting via Realtek RTL 8139

    Is it possible windows is putting its default state to OFF on shutdown and its not waking when Ubuntu boots?

    you could try this;

    - Boot up Windows
    - Right click on My Computer
    - Click on Properties -> Hardware -> Device Manager
    - Expand your network card section and double click on your Realtek network card
    - Set "Wake-on-lan after shutdown" to enabled

    But more likely is that as this chipset has several drivers under linux you may have two trying to run so try:
    Code:
    lsmod | grep 8139
    and see what is loaded for your card. If you get more than one return do;
    Code:
    gksudo gedit /etc/modprobe.d/blacklist.conf
    and blacklist one of the driver modules by adding a line at the end of the file like this-
    blacklist 8139cp (or whichever one you are trying to block...may be 8139too)
    Save and close gedit and reboot.

    Finally there is this post to look at.


    #an ex-8139 owner
    Last edited by Matt__; June 2nd, 2011 at 06:53 PM.
    Toshiba AMD64 2Ghz, 4Gb RAM: dual Natty/win7. Dell Mini10v: 10.04. SamsungN140:win7/11.04. NB200:10.10.
    ++ desktops P4 3Ghz ++ servers
    Full Circle Magazine | Ubuntu Pocket Guide | HantsLUG

  4. #4
    Join Date
    Jun 2011
    Beans
    2

    Re: problem connecting via Realtek RTL 8139

    i am using ethernet and pppoe on my adsl
    thanks for response

  5. #5
    Join Date
    Mar 2007
    Location
    INDIA-Kerala
    Beans
    1,604
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: problem connecting via Realtek RTL 8139

    What do you get for
    Code:
    sudo lshw -C network
    and
    Code:
    cat /etc/network/interfaces
    ?
    Registered linux user #518022

  6. #6
    Join Date
    Dec 2008
    Location
    43° 7' 41" 131° 54' 3"
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: problem connecting via Realtek RTL 8139

    Also post the results of "lspci" and "lsmod".
    EasyBCD.
    PrintersDatabase
    Boot Info Script: How to
    The post above and the post below suffer from the Rashomon effect!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •