Results 1 to 4 of 4

Thread: Compiz Annotate tool lags badly during screencast

  1. #1
    Join Date
    May 2011
    Beans
    18

    Compiz Annotate tool lags badly during screencast

    Hello,

    I use an online screencasting java applet called screencast-o-matic to record my screen. While recording, I use Compiz's annotation tool. Normally this tool works great, but for some reason while I'm recording, it gets very laggy (drawing is way behind the mouse movements) and less smooth. For example, drawing a circle at a quicker pace not only causes lag, but also makes the circle look more like a polygon with straight lines. While this is happening, my CPU also spikes, with large strains showing up on the java process.

    I'm running Ubuntu 11.04 with an intel i7 processor. Any ideas as to why annotation lags badly while screencasting, and any ways to fix it, would be appreciated.

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,757
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz Annotate tool lags badly during screencast

    Quote Originally Posted by meridionaljet View Post
    Hello,

    I use an online screencasting java applet called screencast-o-matic to record my screen. While recording, I use Compiz's annotation tool. Normally this tool works great, but for some reason while I'm recording, it gets very laggy (drawing is way behind the mouse movements) and less smooth. For example, drawing a circle at a quicker pace not only causes lag, but also makes the circle look more like a polygon with straight lines. While this is happening, my CPU also spikes, with large strains showing up on the java process.

    I'm running Ubuntu 11.04 with an intel i7 processor. Any ideas as to why annotation lags badly while screencasting, and any ways to fix it, would be appreciated.
    Hi, go into ccsm and change your refresh rate to 60 and make sure in openGL the the sync to vblank is not checked, if using nvidia go into nvidia x server settings and make sure sync to vblank is not checked there either.

  3. #3
    Join Date
    May 2011
    Beans
    18

    Re: Compiz Annotate tool lags badly during screencast

    Quote Originally Posted by wildmanne39 View Post
    Hi, go into ccsm and change your refresh rate to 60 and make sure in openGL the the sync to vblank is not checked, if using nvidia go into nvidia x server settings and make sure sync to vblank is not checked there either.
    Disabling Sync to VBlank did the trick. Thanks a lot.

  4. #4
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,757
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz Annotate tool lags badly during screencast

    Quote Originally Posted by meridionaljet View Post
    Disabling Sync to VBlank did the trick. Thanks a lot.
    Hi, your welcome, glad it fixed your problem.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •