Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: problems editing /etc/sudoers

  1. #11
    Join Date
    May 2011
    Beans
    167

    Re: problems editing /etc/sudoers

    to Dave: I'm using slackware and not ubuntu so adm

    to Teo: Here you go:

    # sudoers file.
    ##
    ## This file MUST be edited with the 'visudo' command as root.
    ## Failure to use 'visudo' may result in syntax or file permission errors
    ## that prevent sudo from running.
    ##
    ## See the sudoers man page for the details on how to write a sudoers file.
    ##

    ##
    ## Host alias specification
    ##
    ## Groups of machines. These may include host names (optionally with wildcards),
    ## IP addresses, network numbers or netgroups.
    # Host_Alias WEBSERVERS = www1, www2, www3

    ##
    ## User alias specification
    ##
    ## Groups of users. These may consist of user names, uids, Unix groups,
    ## or netgroups.
    # User_Alias ADMINS = millert, dowdy, mikef

    ##
    ## Cmnd alias specification
    ##
    ## Groups of commands. Often used to group related commands together.
    # Cmnd_Alias PROCESSES = /usr/bin/nice, /bin/kill, /usr/bin/renice, \
    # /usr/bin/pkill, /usr/bin/top

    ##
    ## Defaults specification
    ##
    ## You may wish to keep some of the following environment variables
    ## when running commands via sudo.
    ##
    ## Locale settings
    # Defaults env_keep += "LANG LANGUAGE LINGUAS LC_* _XKB_CHARSET"
    ##
    ## Run X applications through sudo; HOME is used to find the
    ## .Xauthority file. Note that other programs use HOME to find
    ## configuration files and this may lead to privilege escalation!
    # Defaults env_keep += "HOME"
    ##
    ## X11 resource path settings
    # Defaults env_keep += "XAPPLRESDIR XFILESEARCHPATH XUSERFILESEARCHPATH"
    ##
    ## Desktop path settings
    # Defaults env_keep += "QTDIR KDEDIR"
    ##
    ## Allow sudo-run commands to inherit the callers' ConsoleKit session
    # Defaults env_keep += "XDG_SESSION_COOKIE"
    ##
    ## Uncomment to enable special input methods. Care should be taken as
    ## this may allow users to subvert the command being run via sudo.
    # Defaults env_keep += "XMODIFIERS GTK_IM_MODULE QT_IM_MODULE QT_IM_SWITCHER"
    ##
    ## Uncomment to enable logging of a command's output, except for
    ## sudoreplay and reboot. Use sudoreplay to play back logged sessions.
    # Defaults log_output
    # Defaults!/usr/bin/sudoreplay !log_output
    # Defaults!/usr/local/bin/sudoreplay !log_output
    # Defaults!/sbin/reboot !log_output

    ##
    ## Runas alias specification
    ####

    ##
    ## User privilege specification
    ##
    root ALL=(ALL) ALL

    ## Uncomment to allow members of group wheel to execute any command
    # %wheel ALL=(ALL) ALL

    ## Same thing without a password
    # %wheel ALL=(ALL) NOPASSWD: ALL

    ## Uncomment to allow members of group sudo to execute any command
    # %sudo ALL=(ALL) ALL

    ## Uncomment to allow any user to run sudo if they know the password
    ## of the user they are running the command as (root by default).
    # Defaults targetpw # Ask for the password of the target user
    # ALL ALL=(ALL) ALL # WARNING: only use this together with 'Defaults targetpw'

    ## Read drop-in files from /etc/sudoers.d
    ## (the '#' here does not indicate a comment)
    #includedir /etc/sudoers.d

    that's all

    do you need my /etc/group as well?
    “No great discovery was ever made without a bold guess”

  2. #12
    Join Date
    May 2011
    Beans
    167

    Re: problems editing /etc/sudoers

    Well, as nobody has come up with a solution I will just leave this issue, because logging in as su (root) works fine.
    It is only sudo which is still giving me troubles. - I guess I will have to use su instead. (might actually be an advantage, bacause you don't have to type sudo everytime, you perform a root command)

    However, thanks for your support
    “No great discovery was ever made without a bold guess”

  3. #13
    Join Date
    Sep 2010
    Beans
    898

    Re: problems editing /etc/sudoers

    If you uncomment the line in /etc/sudoers for the group "sudo", and then add your user to that group, the user should be able to use sudo.

    Edit /etc/sudoers and change:
    Code:
    ## Uncomment to allow members of group sudo to execute any command
    # %sudo ALL=(ALL) ALL
    To:
    Code:
    ## Uncomment to allow members of group sudo to execute any command
    %sudo ALL=(ALL) ALL

  4. #14
    Join Date
    May 2011
    Beans
    167

    Re: problems editing /etc/sudoers

    it is already set to just % without any restrictions, that just root is able to perform that command. (wouldn't make any sense if just the root user would be able to access the root user )

    however, I am able to type sudo and it even asks me for the password. The only problem is that it is not accepting the root password.

    But thanks, I didn't check that one XD

    this error is really weird, isn't it?
    “No great discovery was ever made without a bold guess”

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •