Results 1 to 9 of 9

Thread: Asus Eee PC 1015pn internal microphone

  1. #1
    Join Date
    Apr 2010
    Beans
    6

    Asus Eee PC 1015pn internal microphone

    Ok, so I've searched, and it just doesn't make sense. Initially I had an issue with the sound from the internal speakers, but PulseAudio and Alsa fixed this problem right up for me, but now I cant get Ubuntu 11.04 to recognise the internal microphone that comes with my internal webcam. The camera works, but when I look at the settings for input it doesn't recognise any input devices. I'm kinda stuck at this point, and I have to believe that there is a fix for this, but I can't figure it out.

  2. #2

    Re: Asus Eee PC 1015pn internal microphone

    I have the same netbook, and had the same problem at some point. May be from a different cause, though.

    Two things to check; first, that the Sound Preferences aren't stuck on the HDMI audio hardware, and second, that in the drop down menu on the Hardware tab Settings for the Selected Device, the Duplex option is selected.

  3. #3
    Join Date
    Feb 2011
    Location
    Toulouse ( France )
    Beans
    11
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Asus Eee PC 1015pn internal microphone

    Same here, with another model but in the same serie ; my wife laptop ( 1005HA eeepc ) internal microphone doesn't work anymore (it worked good weeks ago). Something dealing with last updates for sure ( Maverick Meerkat ).

    I suscribe to this thread if a power user can answer and help to repare. The workaround is a mini-jack microphone for the moment, and it works fine.

  4. #4
    Join Date
    Jun 2011
    Location
    Occupied Palestine
    Beans
    23
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Asus Eee PC 1015pn internal microphone

    I am stuck with a similar problem. I have an ASUS Eee PC and run Ubuntu, for some reason when I try to make phone calls inside of Gmail I can hear people but they can not hear me speaking. I know that my microphone works because I have loaded the sound recorder and successfully used it. I checked the options under hardware and made sure it was set to the "Duplex" option; I am really at a loss as to why this will not work.

    Super users, please help!

  5. #5
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Asus Eee PC 1015pn internal microphone

    Quote Originally Posted by antoiner_roquentin View Post
    I am stuck with a similar problem. I have an ASUS Eee PC and run Ubuntu, for some reason when I try to make phone calls inside of Gmail I can hear people but they can not hear me speaking. I know that my microphone works because I have loaded the sound recorder and successfully used it. I checked the options under hardware and made sure it was set to the "Duplex" option; I am really at a loss as to why this will not work.

    Super users, please help!
    If your mic works, then its something else. Do you have google talk plugin installed?
    http://www.ubuntuupdates.org/ppas/47
    Last edited by lidex; June 19th, 2011 at 01:39 AM.

  6. #6
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,754
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Asus Eee PC 1015pn internal microphone

    I found a solution to the microphone problem with Skype on a 1201n. I'd suspect the problem is the same across many EeePC's.

    1) Run "sudo apt-get install pavucontrol" which is the volume control applet for PulseAudio.

    2) Make sure that your PulseAudio settings are correct. I'm using Kubuntu 10.10 where they are controlled via System Settings > Multimedia > Phonon. Make the NVIDIA microphone device the default.

    3) Now start Skype and choose Options > Audio. Uncheck the box that tells Skype to manage your microphone.

    4) Open the pavucontrol applet; I did this by running it in a terminal. Now choose the Input Devices tab, and click the icon to unlock the two volume sliders. Put one slider at 100% and the other at 0%.

    5) Try making a test call to the Echo123 service at Skype. Your microphone should function correctly.

  7. #7
    Join Date
    Feb 2011
    Location
    Toulouse ( France )
    Beans
    11
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Asus Eee PC 1015pn internal microphone

    @SeijiSensei : Many thanks ! It worked here for a 1005Ha ( even if I don't have Nvidia ). Only this steps was suffisent to me :

    1) Open pavucontrol from a terminal ( was installed on the default edition )
    2) Now choose the Input Devices tab, and click the icon to unlock the two volume sliders. Put one slider at 100% and the other at 0%.

    I still get a noisy sound, maybe worst than it was before from the echo123 test. I guess this bad recognition as stereo microphone is the root of the problem, and this trick help to use it but is not well optimised to take part of the full quality of the microphone. Too bad I don't know to who repport the problem ; if someone have an idea, go for it !
    Many thanks again.

  8. #8
    Join Date
    Jul 2006
    Location
    Golden, CO, USA
    Beans
    95
    Distro
    Ubuntu Gnome 13.10 Saucy Salamander

    Re: Asus Eee PC 1015pn internal microphone

    I opened a bug report at https://bugs.launchpad.net/ubuntu/+s...er/+bug/898081, please follow that and "affects me" if it's the case...
    Have a nice day,
    Romano --- Linux user since 1989: first kernel 0.99pl8, Slackware distro (on 40 floppies! )

  9. #9
    Join Date
    Jul 2006
    Location
    Golden, CO, USA
    Beans
    95
    Distro
    Ubuntu Gnome 13.10 Saucy Salamander

    Re: Asus Eee PC 1015pn internal microphone

    I tried the solution posted in the bug, following instructions from https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

    It works!
    Have a nice day,
    Romano --- Linux user since 1989: first kernel 0.99pl8, Slackware distro (on 40 floppies! )

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •