Hi Yannbuntu, thank you for replying. I've tried it like you said (first with the SecureBoot option ticked in boot-repair and then enabled in bios)

When I click Windows 8 in the menu i get this screen:



When I try again i get this one: