Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

  1. #1
    Join Date
    Mar 2007
    Beans
    283
    Distro
    Ubuntu 11.04 Natty Narwhal

    Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    I am starting a new thread for this as it evoked no responses on the Dell XPS 15 L501x thread.

    I just noticed that my webcam isn't working on my Dell XPS 15 L501x (running Ubuntu 11.04 64-bit and GNOME3). When I start Cheese, Camorama (or Skype video test), the webcam's power light turns on, but I see no video feed. Any ideas what could be wrong? It used to work a few weeks ago..

    Code:
     cat /proc/bus/input/devices |grep Name
    N: Name="Power Button"
    N: Name="Sleep Button"
    N: Name="Lid Switch"
    N: Name="Power Button"
    N: Name="AT Translated Set 2 keyboard"
    N: Name=" USB OPTICAL MOUSE"
    N: Name="Video Bus"
    N: Name="Laptop_Integrated_Webcam_2HDM"
    N: Name="Dell WMI hotkeys"
    N: Name="HDA Intel Mic"
    N: Name="HDA Intel Headphone"
    N: Name="SynPS/2 Synaptics TouchPad"
    http://xkcd.com/903/
    Registered Linux User #280857
    Registered Ubuntu User #33646

  2. #2
    Join Date
    Mar 2007
    Beans
    283
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    Any ideas, anyone?
    http://xkcd.com/903/
    Registered Linux User #280857
    Registered Ubuntu User #33646

  3. #3
    Join Date
    Mar 2007
    Beans
    283
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    Reinstalling Dell Webcam Central on the Windows 7 64-bit partition seems to have fixed the issue. I am going to wait for a few days before marking the thread as solved.
    http://xkcd.com/903/
    Registered Linux User #280857
    Registered Ubuntu User #33646

  4. #4
    Join Date
    Sep 2008
    Beans
    3

    Thumbs down Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    sudo apt-get install cheese

    all de best

  5. #5
    Join Date
    Nov 2008
    Beans
    10

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    I have seen this problem intermittently. It seems that the camera sometimes just won't start. The white LED comes on, but nothing comes from the camera. The problem sometimes clears itself up if I power off the computer for a while. Sometimes booting into windows and starting the camera up in windows helps.

    I've had other problems too though - when your camera works in linux, do you ever see corrupted frames - especially at high resolution?

  6. #6
    Join Date
    Mar 2007
    Beans
    283
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    No, I have not seen corrupted frames.

    I reinstalled Natty, and I am still facing this problem. In one session, the camera works just fine, and in another it doesn't (until a reboot). Dell asked me if I want to get the webcam replaced.

    Are you facing this problem in Windows 7 as well? I am.

    EDIT: This is still unsolved.
    Last edited by maverick280857; July 1st, 2011 at 09:02 AM.
    http://xkcd.com/903/
    Registered Linux User #280857
    Registered Ubuntu User #33646

  7. #7
    Join Date
    Sep 2010
    Beans
    11

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    i have got the same problem both on natty and win 7, must e something linked to the bios, what do you think ?
    i updated the bios recently ,maybe this update of the bios was wrongm but definitely something is worng with a software update somewhere.
    as it neither works on ubuntu and win 7 I would rather think of a bios problem.

    i am happy to get your solution if any, and I will share mine. I would say changing the camera is not a solution.
    Last edited by phguisset; July 5th, 2011 at 12:27 PM.

  8. #8
    Join Date
    Mar 2007
    Beans
    283
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    Dell wants to replace my webcam now. They say the webcam and/or its interface cable may be faulty, leading to an erroneous IRQ allocation.

    For the time being, I am researching solutions just like you. Will post anything useful that I come across.
    http://xkcd.com/903/
    Registered Linux User #280857
    Registered Ubuntu User #33646

  9. #9
    Join Date
    Nov 2008
    Beans
    10

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    That sounds odd - the camera is a USB device so the IRQ allocation side of that sounds fishy to me, but there is a thread in Dell's forums
    where a number of people seem to be having similar problems.
    It does sound like there might be some common issue with the cable to the camera.

    The thread is here:
    http://en.community.dell.com/support.../19864532.aspx

    Do they want to ship you a new camera to have you change it? Or sent the computer back to them? or onsite service?

    Getting to the camera actually looks fairly involved...

    My problem with the camera not starting is very intermittent. Sometimes just closing the lid (to suspend) and reopening "fixes" it for a while...

  10. #10
    Join Date
    Mar 2007
    Beans
    283
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS 15 L501X Webcam NOT working in Ubuntu 11.04 Natty Narwhal 64-bit

    My problem has been solved for now, after Dell decided to replace the webcam and its interface cable.

    The culprit in all likelihood was the interface cable. Sometimes, the camera started to work after I closed and re-opened the lid. If the camera were bad, it wouldn't work at all.

    By the way, the interface cable is VERY flimsy. Makes me wonder how much of the 'build quality' we end up paying for these days .

    If your webcam works permanently in Windows and not in Linux, it is most likely a driver issue in Linux. If it works intermittently in Windows, then check the lid (close the lid, and restart Dell Webcam Central). Dell only offers support for Windows, so ask Dell to replace your webcam AND the interface cable.
    http://xkcd.com/903/
    Registered Linux User #280857
    Registered Ubuntu User #33646

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •