Results 1 to 10 of 10

Thread: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

  1. #1
    Join Date
    Jul 2011
    Beans
    139

    Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    Hi, I can't get my Ubuntu server to run.

    I end up getting this message at boot:
    WAIT....

    CMOS settings Wrong


    Press F1 to Run Setup

    Press F2 to load default values and continue

    error: fd0 error
    It's Ubuntu 11.10 running on an old Celeron from early 2001.

    I believe it must have something to do with the new year. I haven't booted up since December, but today I went to boot it up for the first time this year and it didn't run.

    http://ubuntuforums.org/showthread.php?t=2004472&page=2

    In the link above you can see that I modified a few things in BIOS and in Grub in order to get it to boot and shutdown, starting with post #18.

    Should I change date in BIOS?

    Thanks.

  2. #2
    Join Date
    Jul 2007
    Location
    Mississauga, ON
    Beans
    123
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    Most likely CMOS values got corrupted (dead battery?).

    Try reloading factory values (F2). If it works, try setting the correct date and see if it boots up again. If it doesn't work try disabling the floppy drive in the BIOS.

    If it's a dead battery, you can get it in the dollar store.
    Windows by necessity, Linux by choice
    Lubuntu and loving it!

  3. #3
    Join Date
    Jul 2011
    Beans
    139

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    When I press F2 (default values) I get the fd0 error.

    Like I said in my initial post I edited some values in grub that affected boot.

  4. #4
    Join Date
    Jan 2010
    Location
    Germany
    Beans
    165
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    Hey there and welcome.

    Have a look at this launchpad bug and see if it helps:

    https://bugs.launchpad.net/ubuntu/+s...b2/+bug/568720
    Try not to be a man of success but be a man of value
    USE FUL LINKS
    Ubuntu Server setup guide
    setting up a DNS Server on Ubuntu

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,187
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    /dev/fd0 is a floppy drive. Do you have one of those? If so, either disable it in the BIOS or simply unplug the cables from the back of the drive. Then try booting again.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    Hi

    What you are describing is before grub gets a chance to start.

    Agree sort off
    /dev/fd0 is a floppy drive. Do you have one of those? If so, either disable it in the BIOS or simply unplug the cables from the back of the drive. Then try booting again.
    By setting the BIOS to defaults you have told it there is an installed floppy drive and to halt on all errors.

    Go into BIOS and if you don't have a floppy change BIOS to not installed, don't just remove cable because the BIOS boot sequence will still require it. IF you do have one still set as uninstalled it may be your floppy drive has failed.

    For Errors you can reduce what it is going to halt on ie all but keyboard.

  7. #7
    Join Date
    Jul 2011
    Beans
    139

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    I was able to get the server booting after disabling the floppy drive. That's fixed.

    However I now have another problem that I can't seem to connect the server to my network. Everything in /etc/network/interfaces is correct, I don't see any errors.

    I even did a ping test and no packets were dropped.

    It doesn't even show up on my router.

    Whenever I try connecting with Putty, I just get message: Network error: Connection timed out

  8. #8
    Join Date
    Jan 2010
    Location
    Germany
    Beans
    165
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    Ok without knowing the topology of your network it can be difficult to diagnose your problem. You say that you are connected. So the first things I would check are this :

    Check the router config to make sure it has allocated you an IP Address statically if not then just manually allocate one, you may need to read your router docs for this.


    Make sure the ports are open in your firewall by issuing the following commands:


    Sudo ufw allow 80 (the same for 443, 22 and 53 if you want DNS)


    80 is the web and 443 is https. 22 is for SSH but most experienced users or admins change this number for Security. You don't need to worry about that at the moment because until you have mastered the basics you can then start making complicated tweaks.


    Btw I assume that when you issue ifconfig it displays your IP and MAC address correctly?


    If you get any errors then just post them here.
    Try not to be a man of success but be a man of value
    USE FUL LINKS
    Ubuntu Server setup guide
    setting up a DNS Server on Ubuntu

  9. #9
    Join Date
    Jul 2011
    Beans
    139

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    fixed
    Last edited by Wiking; January 31st, 2013 at 01:08 AM.

  10. #10
    Join Date
    Jul 2011
    Beans
    139

    Re: Can't start Ubuntu Server - CMOS settings wrong - fd0 error

    Ok got it fixed. in ufw status port 22/tcp was Denied. Changed that and now can connect.

    thanks all.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •