Results 1 to 7 of 7

Thread: Run (Register) Mathematica 8

  1. #1
    Join Date
    May 2011
    Beans
    1

    Angry Run (Register) Mathematica 8

    I'd install and activate programm Mathematica 8 on my ubuntu (10.04, Gnome 2.30.2).
    But when i treid to run it, i get message about registration like this:

    The bug is, that I CAN'T press any button. And then i close the window programm cloasd too.
    I treid press enter, space, double click... it does not work at all!
    What is it? What can i do? Does any body know something about this trange thing?

  2. #2
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: Run (Register) Mathematica 8

    With a working installation, I produced the following configuration file. Try placing the following in ~/.Mathematica/FrontEnd/init.m - that should prevent the registration dialog from appearing at all.

    Code:
    SetOptions[$FrontEnd, 
    Current2DTool->"Select",
    Default2DTool->"Select",
    Current3DTool->"RotateView",
    Default3DTool->"RotateView",
    PrivateFrontEndOptions->{"LicensesAgreed"->{"8."}},
    VersionsLaunched->{"8.0.1"},
    PrivateFrontEndOptions->{"DialogSettings"->{
     "DialogSettings" -> "None", 
      "WelcomeScreen" -> {
       "ShowRecentFilesContextMenu" -> False, "DefaultSlideNumber" -> 5, 
        "CurrentSlideNumber" -> 5}},
    "LastRegistrationReminderDate"->None,
    "ShowAtStartup"->"NewDocument"}
    ]
    --Technical Stuff--

    I had the same problem described above. For no apparent reason, the registration dialog just started working. Possibly a reinstall helped, possibly not.

    Also, Mathematica's tech support is *awesome*, and amazingly competent with linux tools including strace and gdb. They were extremely helpful, and gave me permission to post this. However, they did warn the workaround may not work on future versions of Mathematica.

  3. #3
    Join Date
    Apr 2010
    Beans
    8

    Re: Run (Register) Mathematica 8

    Hi,

    I tried this solution and it overwrites the registration panel, but when mathematica starts , I am having the same problem, I cannot click, double-click, keyboard...nothing.The startup screen freezes like the registration panel Is there any solution to this?

    Thanks

  4. #4
    Join Date
    Jul 2009
    Location
    Austin, Texas, USA
    Beans
    407

    Re: Run (Register) Mathematica 8

    Quote Originally Posted by NSim View Post
    Hi,

    I tried this solution and it overwrites the registration panel, but when mathematica starts , I am having the same problem, I cannot click, double-click, keyboard...nothing.The startup screen freezes like the registration panel Is there any solution to this?

    Thanks
    I recommend that you contact Mathematica's Tech Support people. Explain the problem to them, and ask for their suggestions. As already mentioned in this thread, they are very helpful and knowledgeable.

  5. #5
    Join Date
    Sep 2011
    Beans
    3

    Re: Run (Register) Mathematica 8

    I found the problem...is the license

    If the license end with :10 the Registration Page will not respond any click

  6. #6
    Join Date
    Aug 2009
    Location
    USA
    Beans
    2
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Run (Register) Mathematica 8

    Quote Originally Posted by NSim View Post
    Hi,

    I tried this solution and it overwrites the registration panel, but when mathematica starts , I am having the same problem, I cannot click, double-click, keyboard...nothing.The startup screen freezes like the registration panel Is there any solution to this?

    Thanks
    This is rather late, but I had the same problem. The configuration file provided above got me past the registration screen, but then I was stuck again. Substituting 8.0.1 -> 8.0.0 in VersionsLaunched got everything working.

  7. #7
    Join Date
    Nov 2009
    Location
    /dev/random
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Run (Register) Mathematica 8

    None of what I found online worked even this thread.

    What did work though is installing Mathematica 7 (of course if you have the this version) then installing Mathematica 8.

    This solved the problem & now it's working normally.

    Hope this helps someone.
    [Dell Studio XPS 1640] [Core2Duo P8700 2.53GHz] [500/4GB][ATI Radeon HD 4670] [12.04/Win7]
    [Dell Inspiron 8600] [? 1.73GHz] [80/1 GB] [-] [10.04/XP]
    [No Brand] [PIII (Coppermine) 1GHz] [80GB/248 MB] [-] [#!/lubuntu 11.10/XP]

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •