Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

  1. #11
    Join Date
    May 2011
    Location
    USA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    @ukf you have different Dell than mine.
    I tried Unity. I tried GNOME 3. I did not like neither of them. Now running Ubuntu 12.04 in Fallback mode.

  2. #12
    Join Date
    Sep 2009
    Location
    UK
    Beans
    434
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    sorry for late reply, type;

    Code:
    xinput list
    in a terminal and paste your output here...

  3. #13
    Join Date
    May 2011
    Location
    USA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    Here we go:


    Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Logitech USB Receiver id=12 [slave pointer (2)]
    ⎜ ↳ ImPS/2 ALPS GlidePoint id=14 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_3M id=10 [slave keyboard (3)]
    ↳ Logitech USB Receiver id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=15 [slave keyboard (3)]
    I tried Unity. I tried GNOME 3. I did not like neither of them. Now running Ubuntu 12.04 in Fallback mode.

  4. #14
    Join Date
    Sep 2009
    Location
    UK
    Beans
    434
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    so the device you want to toggle has id 14 i believe, you can get more details by typing;

    xinput --list-props 14

    which will tell you all the props for that device, there should be one like enabled which can be toggled 0/1

    with;

    xinput set-prop [device id (14)] [enabled propery id (usualy 125)] [on/off (0/1)]

    if you still can't work it post the feedback of the props;

    or if you want to get it done try the pointed id eg;

    xinput set-prop 2 125 0

    and

    xinput set-prop 2 125 1

    that would disable the maser device pointer, ie disable all of these;
    Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Logitech USB Receiver id=12 [slave pointer (2)]
    ⎜ ↳ ImPS/2 ALPS GlidePoint id=14 [slave pointer (2)]

    neways hope that sorts it for you...

  5. #15
    Join Date
    May 2011
    Location
    USA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    YAY!! It worked!! Thanks a lot!!

    It was: Device Enabled (122): 1

    I posted this almost two months ago, I thought I'd have to wait till next Ubuntu.

    No more annoying touchpad getting in the way!

    Thanks again!!!!
    Last edited by vincegata; July 2nd, 2011 at 01:42 AM.
    I tried Unity. I tried GNOME 3. I did not like neither of them. Now running Ubuntu 12.04 in Fallback mode.

  6. #16
    Join Date
    Oct 2010
    Beans
    9

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    Quote Originally Posted by mikejonesey View Post
    so the device you want to toggle has id 14 i believe, you can get more details by typing;

    xinput --list-props 14

    which will tell you all the props for that device, there should be one like enabled which can be toggled 0/1

    with;

    xinput set-prop [device id (14)] [enabled propery id (usualy 125)] [on/off (0/1)]

    if you still can't work it post the feedback of the props;

    or if you want to get it done try the pointed id eg;

    xinput set-prop 2 125 0

    and

    xinput set-prop 2 125 1

    that would disable the maser device pointer, ie disable all of these;
    Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Logitech USB Receiver id=12 [slave pointer (2)]
    ⎜ ↳ ImPS/2 ALPS GlidePoint id=14 [slave pointer (2)]

    neways hope that sorts it for you...
    Ubuntu God may bless you... I don't understand much of code but
    xinput set-prop 11 127 0
    worked for me. I was going insane with this issue...
    Muchas gracias

  7. #17
    Join Date
    Jul 2011
    Beans
    2

    Talking Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    Excelent!

    I tried 'xinput set-prop 13 126 0' and works perfectly!

    To turn on 'xinput set-prop 13 126 1'

    In may case:

    xinput --list so the results:

    ⎡ Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Microsoft Microsoft Notebook Receiver v2.0 id=11 [slave pointer (2)]
    ⎜ ↳ ImPS/2 ALPS GlidePoint id=13 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_0.3M id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=14 [slave keyboard (3)]

    Then a typed 'xinput --list-props 13' and the result was:
    Device 'ImPS/2 ALPS GlidePoint':
    Device Enabled (126): 1
    Coordinate Transformation Matrix (128): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (248): 0
    Device Accel Constant Deceleration (249): 1.000000
    Device Accel Adaptive Deceleration (250): 1.000000
    Device Accel Velocity Scaling (251): 10.000000
    Evdev Axis Inversion (252): 0, 0
    Evdev Axes Swap (254): 0
    Axis Labels (255): "Rel X" (136), "Rel Y" (137)
    Button Labels (256): "Button Left" (129), "Button Middle" (130), "Button Right" (131), "Button Wheel Up" (132), "Button Wheel Down" (133), "Button Horiz Wheel Left" (134), "Button Horiz Wheel Right" (135)
    Evdev Middle Button Emulation (257): 0
    Evdev Middle Button Timeout (258): 50
    Evdev Wheel Emulation (259): 0
    Evdev Wheel Emulation Axes (260): 0, 0, 4, 5
    Evdev Wheel Emulation Inertia (261): 10
    Evdev Wheel Emulation Timeout (262): 200
    Evdev Wheel Emulation Button (263): 4
    Evdev Drag Lock Buttons (264): 0

    Then i checked the prop important in this case was the 'Device Enable(126)'

    So taking the command suggested by @mikejonesey

    'xinput set-prop [device id (14)] [enabled propery id (usualy 125)] [on/off (0/1)]'

    I typed 'xinput set-prop 13 126 0' and so far so good.

    Is there any way to set a shortcut or hot key with this command, because i have a inspiron 14 in my keyboard after the key F12 i have a hot key that should enable and disable as a typed, but dont work,this is why i using the command suggested. But i could forget this command, you know.... for me as a newbie looks like a cake recipe if u know what i mean....

    Anyone suggest a tech guide or book to becames a pro on Ubuntu?

    Thanks, all the best.

  8. #18
    Join Date
    Sep 2009
    Location
    UK
    Beans
    434
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    this should work for all (my scipt from earlyer but tweeked to find ps2 pointers and find the enabled id)

    Code:
    #!/bin/bash
    cd $HOME
    
    function messageUser()
    {
        if [ "$(which notify-send)" == "" ]; then
            echo "requires... libnotify-bin for messages..."
        elif [ "$1" == "on" ]; then
            notify-send -t 800 -i /home/mike/myicon.png "Touchpad enabled..." "mike reprogramed the calculator button :)"
        elif [ "$1" == "off" ]; then
            notify-send -t 800 -i /home/mike/myicon.png "Touchpad disabled..." "mike reprogramed the calculator button :)"
        fi
    }
    
    touchPadId=$(xinput list | grep -i Point | grep "PS/2" | cut -d "=" -f 2 | cut -b 1-2)
    if [ "$touchPadId" == "" ]; then
        echo "Unable to identify device id..."
    else
        enabledId=$(xinput --list-props 11 | grep -i enabled | sed 's/.*(//' | sed 's/).*//')
        if [ -a ".mike-touchPadOnOff" ]; then
            rm -rfv ".mike-touchPadOnOff"
            xinput set-prop $touchPadId $enabledId 1
            messageUser "on"
        else
            touch ".mike-touchPadOnOff"
            xinput set-prop $touchPadId $enabledId 0
            messageUser "off"
        fi
    fi
    just edit for your own logo/image in libnotify, n change the lockfile name to remove "mike" ...

    should have a trap to catch interupts n a couple more ifs but it does the job fine...

    re: resoureces to become a pro on ubuntu, dunno about specific to ubuntu but i recommend books on linux from wiley

  9. #19
    Join Date
    Oct 2010
    Beans
    9

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    Well, I was happy too fast. Now when I execute xinput set-prop 11 127 0 from a console the computer goes crazy like I if I was holding the Enter down. I had to turn it off each time. I've tried 3 times and it's happened again.
    I see now that my ALPS touchpad has moved to id=12 ¡?¡? How could that happen?
    ~$ xinput --list
    ⎡ Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Genius Optical Mouse id=10 [slave pointer (2)]
    ⎜ ↳ ImPS/2 ALPS GlidePoint id=12 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Video Bus id=6 [slave keyboard (3)]
    ↳ Power Button id=7 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_0.3M id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=13 [slave keyboard (3)]

    So now I've just tried xinput set-prop 12 127 0 and the touchpad is dead again... uffff

    Mikejonesey: sorry for being so ignorant , but what should I do with the script? How do I turn that into a executable file? It looks like it'll find the touchpad wherever it is, right?
    Just in case: I have an Inspiron 14.
    Thanks

  10. #20
    Join Date
    Sep 2009
    Location
    UK
    Beans
    434
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    you can paste it into gedit then save as mouse-on-off.sh (or whatever you prefer), these sort of scripts usually reside in ~/bin (home directory->bin directory), to use nautilus to change the permissions so you can run it, right click and check to box under the permissions tab, via command line chmod +x scriptname.sh.

    also run
    Code:
    sudo apt-get install libnotify-bin
    to get system popup messages when you disable or enable the touchpad

    then you can add a keyboard shortcut via the system->pref menu and select that script...

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •