Results 1 to 5 of 5

Thread: Xfce Empty Desktop (LDAP/autofs)

  1. #1
    Join Date
    Oct 2012
    Beans
    3

    Xfce Empty Desktop (LDAP/autofs)

    Hi! I have something similar:
    Code:
    openConnection: connect: No such file or directory
    cannot connect to brltty at :0
    
    (polkit-gnome-authentication-agent-1:1567): GLib-CRITICAL **: g_variant_new_string: assertion `string != NULL' failed
    
    (polkit-gnome-authentication-agent-1:1567): polkit-gnome-1-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
    WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-rVrgat/pkcs11: Нет такого файла или каталога
    ** Message: applet now removed from the notification area
    ** Message: using fallback from indicator to GtkStatusIcon
    ** Message: applet now embedded in the notification area
    
    (xfce4-indicator-plugin:1629): libindicator-WARNING **: IndicatorObject class does not have an accessible description.
    
    (xfce4-indicator-plugin:1629): libindicator-WARNING **: IndicatorObject class does not have an accessible description.
    
    (xfce4-indicator-plugin:1629): Gtk-CRITICAL **: IA__gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed
    ** Message: moving back from GtkStatusIcon to indicator
    ** Message: applet now removed from the notification area
    
    (xfce4-indicator-plugin:1629): Indicator-Application-WARNING **: Unable to get application list
    I can see only mouse and clear desktop after login screen. I've tried to find what is wrong(ctrl+alt+F1) and I found(sudo lsof /home/$user) gsettings process, that was working with .xsession-errors. I've killed it and get back to tty7. Everithing looks fine, but I need to do it every time I want to login=(
    Last edited by Toz; October 23rd, 2012 at 05:02 PM.

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Xfce Empty Desktop

    Moderator Note: Since this issue is slightly different from the thread you posted in, I have moved it to it's own thread.

    Hello and welcome to the forums.

    There doesn't appear to be anything wrong in your log file.
    1. Is this a Xubuntu or an Xfce on Ubuntu install?
    2. What version?
    3. Has the desktop ever showed up?
    4. How long do you wait for the desktop to show up? Perhaps there is a delay.

  3. #3
    Join Date
    Oct 2012
    Beans
    3

    Re: Xfce Empty Desktop

    This is xubuntu 12.04.
    I'm trying to mount /home directory with autofs and ldap authorization. Everything is ok except gui. Desktop showed up when I've been using local /home, also it works good at first start after shutdown.
    I wait about few minutes, nothing changes kill-9 gsettings helps only
    Last edited by Alboroto; October 23rd, 2012 at 04:28 PM.

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Xfce Empty Desktop

    It looks like this is a known bug. See: https://bugs.launchpad.net/ubuntu/+s...re/+bug/870874. There are a couple of potential solutions noted there.

    EDIT: Also updated title of this thread to more accurately reflect the issue.
    Last edited by Toz; October 23rd, 2012 at 05:03 PM.

  5. #5
    Join Date
    Oct 2012
    Beans
    3

    Re: Xfce Empty Desktop

    Quote Originally Posted by Toz View Post
    It looks like this is a known bug. See: https://bugs.launchpad.net/ubuntu/+s...re/+bug/870874. There are a couple of potential solutions noted there.

    EDIT: Also updated title of this thread to more accurately reflect the issue.
    Thank you very much for help!=)
    I've installed nscd and this solved the bug!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •