Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: turning off the dm1 Bluetooth

  1. #1
    Join Date
    May 2011
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Exclamation turning off the dm1 Bluetooth

    Hello from a newbie!

    I have the dm1 3020 (the version found in most stores) with the ralink rt5390 wifi/BT card that so many people have been posting about, and would like to know how to make sure the bluetooth is disabled. Since I don't have any BT stuff to connect and really want to get all the battery life I can out of this thing I am using Ubuntu 11.04 with KDE, so any idea if there is a plasma widget I could use to make sure its disabled? There is no BT icon in the notifications area on the bar.

    Any help would be appreciated. Thanks.

  2. #2
    Join Date
    Feb 2011
    Location
    new york state
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: turning off the dm1 Bluetooth

    Code:
    rfkill block bluetooth
    that should block it. but lets see if it did please post
    Code:
    rfkill list all
    thanks
    Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men, even when they exercise influence and not authority

  3. #3
    Join Date
    May 2011
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: turning off the dm1 Bluetooth

    thanks for replying so fast! I typed in what you suggested and got this:

    rfkill list all
    0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

    But I also did more searching in synaptic and found more BT stuff that had not been installed, that after install and restart gave me the BT icon in the notifications area. Of course there's always a chance I now have a bunch of redundant stuff installed, but I am happy for now.

    Now, should I get a BT device in the future, how do I undo the rfkill command? thanks!

  4. #4
    Join Date
    Feb 2011
    Location
    new york state
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: turning off the dm1 Bluetooth

    to unblock
    Code:
    rfkill unblock bluetooth
    Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men, even when they exercise influence and not authority

  5. #5
    Join Date
    May 2011
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: turning off the dm1 Bluetooth

    great thanks!

  6. #6
    Join Date
    May 2011
    Beans
    2
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: turning off the dm1 Bluetooth

    Could you please describe which BT stuff had not been installed? I cannot get the BT icon in notification area. When I go to menu System > Preferences > Bluetooth appears "Bluetooth is disabled". If you select "Turn On Bluetooth" nothing happened.
    Thanks in advance.

  7. #7
    Join Date
    May 2011
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: turning off the dm1 Bluetooth

    Well what I have installed for bluetooth currently is:

    bluedevil
    blueman
    bluetooth
    bluez
    bluez-alsa
    bluez-cups
    bluez-gstreamer
    gnome-bluetooth
    libbluedevil1
    libbluetooth3
    libgnome-bluetooth8
    obex-data-server
    pulseaudio-module-bluetooth
    rfkill

    This is what came up when I searched in synaptic for "bluetooth" without quotes. I am running KDE currently, which is where the issue of it not showing up in the notifications bar was a problem. And most likely I have redundant ones installed, but so far not an issue.

    Hope this helps.

  8. #8
    Join Date
    May 2011
    Beans
    13

    Re: turning off the dm1 Bluetooth

    Are you able to connect to bluetooth devices? I have the bluetooth icon and the device shows up with 'hcitool dev'. But if I try searching for bluetooth devices to connected to none shows up. This happens both with the bluetooth gui manager and 'hcitool scan'

  9. #9
    Join Date
    May 2011
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: turning off the dm1 Bluetooth

    Sorry but I don't own any BT devices to test it with. I know other people were having issues connecting to their devices, but I don't know if they ever solved the issues. sorry.

  10. #10
    Join Date
    May 2011
    Beans
    13

    Re: turning off the dm1 Bluetooth

    A workaround is described here: http://ubuntuforums.org/showthread.php?t=1584388. Boot in Windows, turn on bluetooth, turn off bluetooth/wifi in hardware with fn-12, and boot in Linux. See also https://bugs.launchpad.net/ubuntu/+s...ez/+bug/781556

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •