Results 1 to 3 of 3

Thread: Wacom settings not working in 11.04

  1. #1
    Join Date
    Oct 2005
    Location
    Tokyo, Japan
    Beans
    102
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wacom settings not working in 11.04

    Because of Nvidia driver problems my upgrade failed and I had to do a clean install of Ubuntu 11.04.

    Now I have my system restored, but my Wacom tablet is no longer set to the preferences I had before.

    The real problem is that the method I used to set it last time under 10.10 does not seem to apply. (Which is par for the course because Wacom settings are never the same twice.)

    Before, I created this file:

    Code:
    /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi
    ... and then I added the following details:

    Code:
    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
    
    <deviceinfo version="0.2">
      <device>
        <match key="input.originating_device" contains="if0">
          <match key="info.product" contains="Wacom">
            <merge key="input.x11_driver" type="string">wacom</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
            <merge key="info.product" type="string">stylus</merge>
        <merge key="input.x11_options.Mode" type="string">Relative</merge>
            <merge key="input.x11_options.Button2" type="string">3</merge>
            <merge key="input.x11_options.Button3" type="string">2</merge>
            <merge key="input.x11_options.Speed" type="string">1.2</merge>
              <append key="info.callouts.add" type="strlist">hal-setup-wacom</append>
              <append key="wacom.types" type="strlist">eraser</append>
              <append key="wacom.types" type="strlist">cursor</append>
              <append key="wacom.types" type="strlist">pad</append>
          </match>
        </match>
      </device>
      <device>
        <match key="input.x11_options.Type" contains="eraser">
          <merge key="info.product" type="string">eraser</merge>
        </match>
      </device>
      <device>
        <match key="input.x11_options.Type" contains="cursor">
          <merge key="info.product" type="string">cursor</merge>
        </match>
      </device>
      <device>
        <match key="input.x11_options.Type" contains="pad">
          <merge key="info.product" type="string">pad</merge>
        </match>
      </device>
    </deviceinfo>
    ... but this isn't working.

    So what unholy rituals do I need to perform this time to get Wacom running again?
    Desktop: Ubuntu 12.04 Gnome Classic, Intel i5, 4GB RAM, Nvidia GeForce 9600, dual monitor
    Laptop: Ubuntu 12.04 Gnome Classic (no effects), Panasonic Let's Note CF-Y2 laptop, 1GB RAM
    Media Server: Mythbuntu 12.04, Intel Q4, 4GB RAM

  2. #2
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom settings not working in 11.04

    Hi again Dave M G,

    I think you mean Karmic (9.10) because with Lucid (10.04) they ditched HAL/.fdi files in favor of xorg.conf.d/.conf files. RIP HAL. So in Natty you now get to configure a wacom.conf file. But since you now have X server 1.10 with Natty you can actually configure dependent devices again! Hurrah!

    This time I've got some fancy mediawiki pages for you to look at:
    http://sourceforge.net/apps/mediawik..._Configuration
    http://sourceforge.net/apps/mediawik...le=Xorg.conf.d

  3. #3
    Join Date
    Oct 2005
    Location
    Tokyo, Japan
    Beans
    102
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom settings not working in 11.04

    Favux,

    Thanks for responding. Your constant efforts to deal with Wacom issues for all Ubuntu users is much appreciated.

    Turns out I'm an idiot. Or at least very forgetful. I had been down this road before, with your help:
    http://ubuntuforums.org/showthread.php?t=1592422

    The problem was that I saved the wrong notes on my computer... so I was just repeating old mistakes.

    D'oh!

    Anyway, it's solved now. I'm using the right configuration file in the right place.

    Still hoping for the day when we can use a nice GUI for Wacom configuration.

    Anyway, thanks again.
    Desktop: Ubuntu 12.04 Gnome Classic, Intel i5, 4GB RAM, Nvidia GeForce 9600, dual monitor
    Laptop: Ubuntu 12.04 Gnome Classic (no effects), Panasonic Let's Note CF-Y2 laptop, 1GB RAM
    Media Server: Mythbuntu 12.04, Intel Q4, 4GB RAM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •