Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Microphone not working

  1. #11
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Microphone not working

    Since you have gnome-alsamixer, use the 'Edit -> Soundcard Properties' to make sure required elements are enabled. When in alsamixer, hit <F4> to show capture elements. This may help further:
    From ubuntu wiki:
    Changing default subdevice configuration

    Some sound devices have multiple capture subdevices (eg. hda-intel),
    but pulseaudio only seems to detect the parent device, and only listens to subdevice #0.
    ALSA may not be configured to use your preferred device as subdevice #0 by default.

    Open the pulseaudio record meter (pavumeter --record)
    Talk into your chosen device while you carry out the process and watch the meter.
    Some channels are quite noisy even with no input (especially on integrated chipsets),
    so we are watching for movements that correspond to our voice.

    Use alsamixer -c n (where n is your sound card number, probably 0)
    Press F4 to get to the capture console
    Make sure the first capture channel is enabled ("CAPTUR" in red, press space to toggle),
    and the volume turned up.
    Check the first input source is switched to your chosen plug (Mic, in my case)
    At this point, you should see the record meter bouncing in response to your voice.
    I found that I had to repeat this procedure each time I wanted to use the Mic,
    even though the settings "stuck" in the mixer, something in the soundcard wasn't initialized
    until it was repeated. This also works if you use the "Options" tab in the standard mixer app to do the same thing.

  2. #12
    Join Date
    Feb 2011
    Beans
    492
    Distro
    Ubuntu

    Re: Microphone not working

    I've found these settings to work nicely:

    My settings in alsamixer:
    Playback
    Master F: 8%
    PCM: 99%
    Front: 100%
    Front Mic: 0%
    Line: 0%
    (there are other settings too, but these are the important ones.)

    Recording
    Front mic boost: 100%
    Mic boost: 0%
    Capture: 18%
    Capture1: 0%
    Input Source : Front Mic

    However, once you start Skype, Skype changes the mixer settings automatically
    (for the worse). The sound is adjusted so that a humming background noise is noticeable. To change this (in Skype) go to options (click the blue button at the bottom left) click at “sound devices”, untick the box that says: "Allow Skype to automatically adjust my mixer levels".

    So to sum this up for people who might encounter the same problem:
    1. Make sure the microphone is connected, and not muted.
    2. Type
    Code:
    alsamixer
    in the terminal (install it if you haven't got it)
    3. Adjust the settings for the playback to match those above (YMMV)
    4. Press F4 and adjust the settings for the mic to match those above (YMMV)
    5. Prevent Skype from messing with your settings, as described above.


    Thank you so much for helping me out lidex!
    Last edited by Dry Lips; May 9th, 2011 at 03:32 PM.

  3. #13
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Microphone not working

    Nicely done and thanks for posting your fix for others to see.

  4. #14
    Join Date
    Apr 2011
    Beans
    6

    Re: Microphone not working

    lidex,

    Ive searched through more forums than i have wanted to (with your advice showing up on a majority of them btw) and i still cannot fix my microphone. I get no sound when using sound recorder or any audio captured through skype.

    I uploaded my alsa settings: http://www.alsa-project.org/db/?f=12...c901ae0dbf6c08

    If you could help i would be eternally grateful haha thanks

    Also, as I am a noob in a sense, could you make it rather detailed on how to fix it? lol thanks again.

  5. #15
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Microphone not working

    Quote Originally Posted by secretaznman3 View Post
    lidex,

    Ive searched through more forums than i have wanted to (with your advice showing up on a majority of them btw) and i still cannot fix my microphone. I get no sound when using sound recorder or any audio captured through skype.

    I uploaded my alsa settings: http://www.alsa-project.org/db/?f=12...c901ae0dbf6c08

    If you could help i would be eternally grateful haha thanks

    Also, as I am a noob in a sense, could you make it rather detailed on how to fix it? lol thanks again.
    Why don't you try adjusting these levels in alsamixer:
    Code:
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch penum
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 80
      Front Left: Capture 1 [1%] [-73.00dB] [on]
      Front Right: Capture 1 [1%] [-73.00dB] [on]
    Simple mixer control 'Analog Mic Boost',0
      Capabilities: cenum
      Items: '0dB' '10dB' '20dB' '30dB' '40dB'
      Item0: '40dB'
    Turn your capture level up. The range is 0 - 80 and currently set at 1.

    This may help as well. From ubuntu wiki:
    Changing default subdevice configuration

    Some sound devices have multiple capture subdevices (eg. hda-intel),
    but pulseaudio only seems to detect the parent device, and only listens to subdevice #0.
    ALSA may not be configured to use your preferred device as subdevice #0 by default.

    Open the pulseaudio record meter (pavumeter --record)
    Talk into your chosen device while you carry out the process and watch the meter.
    Some channels are quite noisy even with no input (especially on integrated chipsets),
    so we are watching for movements that correspond to our voice.

    Use alsamixer -c n (where n is your sound card number, probably 0)
    Press F4 to get to the capture console
    Make sure the first capture channel is enabled ("CAPTUR" in red, press space to toggle),
    and the volume turned up.
    Check the first input source is switched to your chosen plug (Mic, in my case)
    At this point, you should see the record meter bouncing in response to your voice.
    I found that I had to repeat this procedure each time I wanted to use the Mic,
    even though the settings "stuck" in the mixer, something in the soundcard wasn't initialized
    until it was repeated. This also works if you use the "Options" tab in the standard mixer app to do the same thing.

  6. #16
    Join Date
    Apr 2011
    Beans
    6

    Re: Microphone not working

    Quote Originally Posted by lidex View Post
    Why don't you try adjusting these levels in alsamixer:
    Code:
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch penum
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 80
      Front Left: Capture 1 [1%] [-73.00dB] [on]
      Front Right: Capture 1 [1%] [-73.00dB] [on]
    Simple mixer control 'Analog Mic Boost',0
      Capabilities: cenum
      Items: '0dB' '10dB' '20dB' '30dB' '40dB'
      Item0: '40dB'
    Turn your capture level up. The range is 0 - 80 and currently set at 1.

    This may help as well. From ubuntu wiki:

    I changed my capture settings now to 80 shown here in my new alsa script log thing: http://www.alsa-project.org/db/?f=29...d83a3ed20759ad

    I then went into my sound preferences and didn't see anything in the input tab. Then i opened PulseAudio Volume Control and in the recording tab it said that the GNOME Volume Control Dialog was recording but the green level beneath that was extremely small (maybe 1% of the full bar) and when i yelled it fluttered a tiny bit.
    So in the GNOME Volume Control I set the input volume in the input tab to full, past the unamplified 100% mark, and saw that the green bar in PulseAudio grow to maybe 5% full, but fluttering.

    My recorded voice in 'Sound Record' is audible but only when my ear is right against my speakers when the output volume is set to full.

    I tried to write everything I did so if it's unclear im sorry. Thanks!

  7. #17
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Microphone not working

    On closer inspection, namely your dmesg output, it looks like that hp-laptop model is incorrect. Edit it to look like this:
    Code:
    options snd-hda-intel model=thinkpad
    Open for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf

  8. #18
    Join Date
    Apr 2011
    Beans
    6

    Re: Microphone not working

    Quote Originally Posted by lidex View Post
    On closer inspection, namely your dmesg output, it looks like that hp-laptop model is incorrect. Edit it to look like this:
    Code:
    options snd-hda-intel model=thinkpad
    Open for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Ok i just did that. Do i need to update anything afterwards? ALso, I don't have a thinkpad..does that matter?

  9. #19
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Microphone not working

    Quote Originally Posted by secretaznman3 View Post
    Ok i just did that. Do i need to update anything afterwards? ALso, I don't have a thinkpad..does that matter?
    You'll need to reconfigure your settings - check the previous posts.

  10. #20
    Join Date
    Apr 2011
    Beans
    6

    Re: Microphone not working

    Quote Originally Posted by lidex View Post
    You'll need to reconfigure your settings - check the previous posts.
    When i change "hp-laptop" to "thinkpad" and then i reset my computer and go back to PulseAudio there is no longer any green bar indicating recording in the record tab.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •