Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

  1. #1
    Join Date
    Mar 2007
    Beans
    203

    Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    I've upgraded to Gnome 3 on my Natty install on my MacBook Pro 5,1. I installed gnome-session and got around the .ICEauthority problem.

    Now if I log into "Ubuntu Gnome Shell Desktop" it waits a bit and then it shows a nice graphical screen (with a picture of a sad monitor) saying:
    Code:
    Oh no! Something has gone wrong.
    A problem has occurred and the system can't recover.
    Please log out and try again.
    Log out
    Anyone know the cause of this?
    Onieric - Leaning towards Xubuntu these days.

  2. #2
    Join Date
    Oct 2009
    Location
    Finland
    Beans
    31
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    I got exactly the same.
    It turned you that the only thing you have to do is to add the command "gnome-shell --replace" to autostart at login.
    To do so press CTRL+Alt+F1 to get to your first console, log in using you name and password, then type these commands:

    Code:
    cd ~/.config/autostart
    nano gnome-shell.desktop
    Then, in the editor, type this:

    Code:
    [Desktop Entry]
    Type=Application
    Exec=gnome-shell --replace
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    Name[en_US]=Gnome Shell
    Name=Gnome Shell
    Comment[en_US]=
    Comment=
    Press CTRL+O and then ENTER (to save), after that press CTRL+X (to quit nano).

    This will make so that the command "gnome-shell --replace" will run at login, because of some reason it doesn't.

    Hope this will solve your problem!
    Last edited by Grozzy; May 4th, 2011 at 03:25 PM.

  3. #3
    Join Date
    Mar 2007
    Beans
    203

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    Hey,

    I found the issue by accident and it wasn't something I would have guessed! When changing settings to fix the .ICEauthority problem I had to change my "Auto eth0" NIC to DHCP (it was set in the old NetworkManager to a static IP address). To do this I had to modify the "/etc/NetworkManager/system-connections/Auto eth0" file and set "method=auto" in the "ipv4" section and remove the other lines from that section.

    This is what actually fixed the issue for me. It's repeatable also; if I restore the backup file I took it fails every time. I'll check to see if this bug has been reported and report it if it hasn't.

    Thanks,
    Kevin
    Onieric - Leaning towards Xubuntu these days.

  4. #4
    Join Date
    May 2008
    Beans
    89
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    Quote Originally Posted by Grozzy View Post
    I got exactly the same.
    It turned you that the only thing you have to do is to add the command "gnome-shell --replace" to autostart at login.
    To do so press CTRL+Alt+F1 to get to your first console, log in using you name and password, then type these commands:

    Code:
    cd ~/.config/autostart
    nano gnome-shell.desktop
    Then, in the editor, type this:

    Code:
    [Desktop Entry]
    Type=Application
    Exec=gnome-shell --replace
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    Name[en_US]=Gnome Shell
    Name=Gnome Shell
    Comment[en_US]=
    Comment=
    Press CTRL+O and then ENTER (to save), after that press CTRL+X (to quit nano).

    This will make so that the command "gnome-shell --replace" will run at login, because of some reason it doesn't.

    Hope this will solve your problem!
    This worked for me, thanks!!
    Wife after seeing my Ubuntu coffee cup.
    "What the h&ll is Uuuuu-bunnnn-to?"

  5. #5
    Join Date
    May 2011
    Beans
    1

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    Quote Originally Posted by Grozzy View Post
    I got exactly the same.
    It turned you that the only thing you have to do is to add the command "gnome-shell --replace" to autostart at login.
    To do so press CTRL+Alt+F1 to get to your first console, log in using you name and password, then type these commands:

    Code:
    cd ~/.config/autostart
    nano gnome-shell.desktop
    Then, in the editor, type this:

    Code:
    [Desktop Entry]
    Type=Application
    Exec=gnome-shell --replace
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    Name[en_US]=Gnome Shell
    Name=Gnome Shell
    Comment[en_US]=
    Comment=
    Press CTRL+O and then ENTER (to save), after that press CTRL+X (to quit nano).

    This will make so that the command "gnome-shell --replace" will run at login, because of some reason it doesn't.

    Hope this will solve your problem!
    Had the same problem as OP, Grozzy's solution solved it for me!

    Thanks!

    (Quote spam to bump because it works =D)

  6. #6
    Join Date
    May 2008
    Beans
    3

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    I have this problem on my opensuse 11.4.
    I found that gnome-shell-extension-xrandr-indicator was the culprit.
    Uninstalling it the problem was gone.

  7. #7
    Join Date
    Aug 2007
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    Quote Originally Posted by Grozzy View Post
    I got exactly the same.
    It turned you that the only thing you have to do is to add the command "gnome-shell --replace" to autostart at login.
    To do so press CTRL+Alt+F1 to get to your first console, log in using you name and password, then type these commands:

    Code:
    cd ~/.config/autostart
    nano gnome-shell.desktop
    Then, in the editor, type this:

    Code:
    [Desktop Entry]
    Type=Application
    Exec=gnome-shell --replace
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    Name[en_US]=Gnome Shell
    Name=Gnome Shell
    Comment[en_US]=
    Comment=
    Press CTRL+O and then ENTER (to save), after that press CTRL+X (to quit nano).

    This will make so that the command "gnome-shell --replace" will run at login, because of some reason it doesn't.

    Hope this will solve your problem!
    This helped me , thanks a lot!
    Everyone has beauty but not everyone sees it.
    Artha ~ The Open Thesaurus

  8. #8
    Join Date
    Aug 2009
    Beans
    881
    Distro
    Ubuntu Development Release

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    At least in Fedora when I get the error, sometimes the error was lying and I could just Alt+F2 to access my Gnome Shell which was working just fine behind the error window.

  9. #9
    Join Date
    Oct 2010
    Location
    Norfolk, UK
    Beans
    318
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    Strangely enough I used to have this problem, but it seems to have gone away (updates?). A second login attempt always worked.

    Gnome shell is excellent and 'knocks spots' off Unity in my opinion!

  10. #10
    Join Date
    Sep 2011
    Beans
    5

    Angry Re: Gnome 3 & nVidia (Natty) - Oh no! Something has gone wrong.

    yes it happened same for me pls help me out

    its showing me a message describing:"No such file or directry" when i enter the cmd :"~/.config/autostart"
    pls suggest me another way

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •