Page 8 of 8 FirstFirst ... 678
Results 71 to 76 of 76

Thread: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

  1. #71
    Join Date
    Apr 2012
    Beans
    8

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by donniezazen View Post
    Try this.
    Code:
    sudo thinkfan stop
    
    sudo thinkfan -n
    The second command will give you both temp and fan speed.

    OK, this is what I got:

    Code:
    $ sudo thinkfan stop
    
    LOWER limit doesn't overlap with previous UPPER limit.
    /etc/thinkfan.conf:50:(1,    50,    80)
    
    LOWER limit doesn't overlap with previous UPPER limit.
    Refusing to run without usable config file. Please read AND UNDERSTAND the documentation!
    
    
    $ sudo thinkfan -n
    
    LOWER limit doesn't overlap with previous UPPER limit.
    /etc/thinkfan.conf:50:(1,    50,    80)
    
    LOWER limit doesn't overlap with previous UPPER limit.
    Refusing to run without usable config file. Please read AND UNDERSTAND the documentation!
    "Please read AND UNDERSTAND the documentation!" -- I guess I deserved that

    Any ideas on what to do next? I feel a bit sick of this so I might keep going with the "auto" config, unless you think it is a bad idea...

    Edit: I purged the thinkfan installation, because I was worried it might be the cause of recent system freezes (nothing works, not even mouse, and I have had to hard restart). Now I am worried that I've been configuring this the wrong way all along. Apparently the T420 can overheat and the "auto" setting is not sufficient from stopping it to overheat (it does not run at the fan's maximum possible speed: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/751689). This is my work PC so I have to make some time in the future to set up thinkfan properly. Until then, I will monitor this thread.
    Last edited by cenaar; May 7th, 2012 at 03:02 PM.

  2. #72
    Join Date
    Jan 2008
    Location
    USA
    Beans
    750
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Find your sensors using the command.

    Code:
    find /sys/devices -type f -name "temp*_input"
    Add sensor in front of them like

    Code:
    sensor /sys/devices/platform/coretemp.0/temp1_input
    sensor /sys/devices/platform/coretemp.2/temp1_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input
    This is the default configuration.

    Code:
    ######################################################################
    # thinkfan 0.7 example config file
    # ================================
    #
    # ATTENTION: There is only very basic sanity checking on the configuration.
    # That means you can set your temperature limits as insane as you like. You
    # can do anything stupid, e.g. turn off your fan when your CPU reaches 70C.
    #
    # That's why this program is called THINKfan: You gotta think for yourself.
    #
    ######################################################################
    #
    # IBM/Lenovo Thinkpads (thinkpad_acpi, /proc/acpi/ibm)
    # ====================================================
    #
    # IMPORTANT:
    #
    # To keep your HD from overheating, you have to specify a correction value for
    # the sensor that has the HD's temperature. You need to do this because
    # thinkfan uses only the highest temperature it can find in the system, and
    # that'll most likely never be your HD, as most HDs are already out of spec
    # when they reach 55 C.
    # Correction values are applied from left to right in the same order as the
    # temperatures are read from the file.
    #
    # For example:
    # sensor /proc/acpi/ibm/thermal (0, 0, 10)
    # will add a fixed value of 10 C the 3rd value read from that file. Check out
    # http://www.thinkwiki.org/wiki/Thermal_Sensors to find out how much you may
    # want to add to certain temperatures.
    
    #  Syntax:
    #  (LEVEL, LOW, HIGH)
    #  LEVEL is the fan level to use (0-7 with thinkpad_acpi)
    #  LOW is the temperature at which to step down to the previous level
    #  HIGH is the temperature at which to step up to the next level
    #  All numbers are integers.
    #
    
    # I use this on my T61p:
    #sensor /proc/acpi/ibm/thermal (0, 10, 15, 2, 10, 5, 0, 3, 0, 3)
    
    ADD YOUR SENSORS HERE
    
    (0,	0,	55)
    (1,	48,	60)
    (2,	50,	61)
    (3,	52,	63)
    (4,	56,	65)
    (5,	59,	66)
    (7,	63,	32767)
    Amor cuerdo, no es Amor.

  3. #73
    Join Date
    Apr 2008
    Beans
    9

    Angry Deleted

    Deleted message
    Last edited by AllWires; May 9th, 2012 at 03:55 AM.

  4. #74
    Join Date
    Nov 2009
    Location
    Philippines
    Beans
    98
    Distro
    Ubuntu 12.04 Precise Pangolin

    Unhappy Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by mejo View Post
    level 0 means that the fan is not running at all. are you sure that it's the fan that makes the noise?



    Yes, that's correct. It's exactly the same as in my /etc/thinkfan.conf. Which Thinkpad do you use? Is it a T420?
    Hello @mejo, I hope it's all right to ask in this thread despite it nearly being a year old. I have a ThinkPad R61i running on 12.04 64-bit. I carefully followed your steps without any error AFAIK that popped on the terminal, but I have to ask if what I added on
    Code:
    /etc/thinkfan.conf
    is correct?

    Code:
    # I use this on my T61p:
    #sensor /proc/acpi/ibm/thermal (0, 10, 15, 2, 10, 5, 0, 3, 0, 3)
    
    sensor /sys/devices/platform/coretemp.0/temp1_input
    sensor /sys/devices/platform/coretemp.2/temp1_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input
    
    (0,    0,    55)
    (1,    48,    60)
    (2,    50,    61)
    (3,    52,    63)
    (4,    56,    65)
    (5,    59,    66)
    (7,    63,    32767)
    I added the same 3 sensor lines even if I'm using an R61i and not T420. Is that correct? Because if I enter the command
    Code:
    sudo find /sys/devices -type f -name "temp*_input"
    I find more than 3 sensors:

    Code:
    sensor /sys/devices/platform/coretemp.0/temp2_input
    sensor /sys/devices/platform/coretemp.0/temp3_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp9_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp10_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp11_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp12_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp13_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp14_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp15_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp16_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp1_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp2_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp3_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp4_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp5_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp6_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp7_input
    sensor /sys/devices/platform/thinkpad_hwmon/temp8_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp2_input
    I manually inserted 'sensors' before the /sys/...

    Also, I noticed that my fan speed increased to more than 3000 RPM (max is around 3100). Before I installed thinkfan my fan speed was only around 2500 to 2800 RPM despite having temperature ranging from 60 to 80 Celsius. I monitor my temperature via Psensor and Hardware Sensors Indicator.

    When I entered
    Code:
    sudo cat /proc/acpi/ibm/fan
    at an interval of around 3 to 5 minutes, this was the result.

    Code:
    juno@Oogushi:~$ sudo cat /proc/acpi/ibm/fan
    status:        enabled
    speed:        3031
    level:        auto
    commands:    level <level> (<level> is 0-7, auto, disengaged, full-speed)
    commands:    enable, disable
    commands:    watchdog <timeout> (<timeout> is 0 (off), 1-120 (seconds))
    juno@Oogushi:~$ sudo cat /proc/acpi/ibm/fan
    status:        enabled
    speed:        3052
    level:        auto
    commands:    level <level> (<level> is 0-7, auto, disengaged, full-speed)
    commands:    enable, disable
    commands:    watchdog <timeout> (<timeout> is 0 (off), 1-120 (seconds))
    juno@Oogushi:~$
    I rebooted and did the command again but the level is always stuck to 'auto' and never became a number like 1 or 3. Did I do something wrong in installing the thinkfan?

    I hope you can help me. Thank you very much.
    Last edited by Sicadastra; August 22nd, 2012 at 06:59 AM.
    Laptop Specs:

    ThinkPad R61i --- 64-bit --- 3.8GB memory --- Intel Core2Duo CPU T5870 @ 2.00GHz x 2

  5. #75
    Join Date
    Feb 2013
    Beans
    3

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Using Thinkpad W500, ubuntu 12.04. I came to this thread to find solution for my interesting problem.
    Problem:
    My laptop, while watching movie or playing games, shuts down all of sudden. With syslog having this message:
    Code:
    Feb 11 15:02:49 vipin-ThinkPad-W500 kernel: [17020.922112] Critical temperature reached (128 C), shutting down.
    Upon investigating, found out that it's the GPU temp which is shooting up till 128C.
    Started monitoring temp & fan speed since last two days... Generally the GPU sensor (i.e. temp4) remains at around 100C-118C which is abnormal IMO. The fan remains in auto mode doing ~3500 rpm "all the times". This explains temperature soaring so much.
    Read about thinkfan here, gave it a shot. But not helping either. Followed the instructions by mejo (thanks!). And the fan still shows auto and doesn't change speed with temperature change.
    Code:
    vipin@vipin-ThinkPad-W500:~/Downloads$ sudo cat /proc/acpi/ibm/fan
    [sudo] password for vipin: 
    status:        enabled
    speed:        3386
    level:        auto
    commands:    level <level> (<level> is 0-7, auto, disengaged, full-speed)
    commands:    enable, disable
    commands:    watchdog <timeout> (<timeout> is 0 (off), 1-120 (seconds))
    
    vipin@vipin-ThinkPad-W500:~/Downloads$ sensors
    acpitz-virtual-0
    Adapter: Virtual device
    temp1:        +58.0C  (crit = +127.0C)
    temp2:        +56.0C  (crit = +100.0C)
    
    thinkpad-isa-0000
    Adapter: ISA adapter
    fan1:        3375 RPM
    temp1:        +58.0C  
    temp2:        +62.0C  
    temp3:        +42.0C  
    temp4:       +120.0C  
    temp5:        +43.0C  
    temp6:            N/A  
    temp7:        +36.0C  
    temp8:            N/A  
    temp9:        +43.0C  
    temp10:       +62.0C  
    temp11:       +60.0C  
    temp12:           N/A  
    temp13:           N/A  
    temp14:           N/A  
    temp15:           N/A  
    temp16:           N/A  
    
    coretemp-isa-0000
    Adapter: ISA adapter
    Core 0:       +56.0C  (high = +105.0C, crit = +105.0C)
    Core 1:       +55.0C  (high = +105.0C, crit = +105.0C)
    Any thoughts?

  6. #76
    Join Date
    Sep 2010
    Location
    Germany
    Beans
    83
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Hi,

    looking for a software solution is pointless imho.

    Check your hardware: remove dust from air vents, heat exchanger and fan. I would even remove the fan unit and change the thermal grease and pads -> Hardware Maintenance Manual.

Page 8 of 8 FirstFirst ... 678

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •