Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 76

Thread: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

  1. #21
    Join Date
    Jul 2008
    Beans
    18

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    I just opened a bunch of youtube videos, gimp, eclipse, random programs, a movie editor, etc... And the fan speed did not change from 0. I'm going to assume this means things aren't setup properly. So I will go through your steps.

    Also, my thinkfan version is 0.7.1.

  2. #22
    Join Date
    Jul 2008
    Beans
    18

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    I went through the instructions and the fan is now running. I've seen it go from level 3 to level 1. So it seems to be working.

    Anything else?

    Thank you for your help.

  3. #23
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by chonald View Post
    I went through the instructions and the fan is now running. I've seen it go from level 3 to level 1. So it seems to be working.

    Anything else?

    Thank you for your help.
    You're welcome. Thinkfan is working on your system now. I'm curious though, why your fan wasn't working at all before that. Because level 0 is 'no fan'. But whatever the reason was, now it's working as expected.

  4. #24
    Join Date
    Sep 2011
    Beans
    9

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    when i tried the following command....i get the following error. Can any body help me regarding this?

    Code:
    # sudo modprobe thinkpad_acpi
    FATAL: Error inserting thinkpad_acpi (/lib/modules/2.6.38-11-generic/kernel/drivers/platform/x86/thinkpad_acpi.ko): Unknown symbol in module, or unknown parameter (see dmesg)

  5. #25
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by coolleonard View Post
    when i tried the following command....i get the following error. Can any body help me regarding this?

    Code:
    # sudo modprobe thinkpad_acpi
    FATAL: Error inserting thinkpad_acpi (/lib/modules/2.6.38-11-generic/kernel/drivers/platform/x86/thinkpad_acpi.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    What's the output in /var/log/dmesg? I guess that you pass a wrong parameter to the module. Please post the output of 'grep -r thinkpad_acpi /etc/modprobe.d/'.

  6. #26
    Join Date
    Mar 2011
    Beans
    17

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    I'm trying to install this on a T61p. Would that make a difference? After I enter sudo echo "coretemp" >> /etc/modules I get back...bash: /etc/modules: Permission denied

    Admittedly I am new at this, but any help would be appreciated.

  7. #27
    Join Date
    Sep 2011
    Beans
    9

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by mejo View Post
    What's the output in /var/log/dmesg? I guess that you pass a wrong parameter to the module. Please post the output of 'grep -r thinkpad_acpi /etc/modprobe.d/'.


    The output is
    Code:
    $ grep -r thinkpad_acpi /etc/modprobe.d/
    /etc/modprobe.d/thinkfan.conf:options thinkpad_acpi fan_control = 1

  8. #28
    Join Date
    Sep 2011
    Beans
    9

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Also while installing the thinkfan I got the following out put:
    # apt-get install thinkfan
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    thinkfan
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B/33.7 kB of archives.
    After this operation, 164 kB of additional disk space will be used.
    Selecting previously deselected package thinkfan.
    (Reading database ... 161516 files and directories currently installed.)
    Unpacking thinkfan (from .../thinkfan_0.7.1-2_amd64.deb) ...
    Processing triggers for man-db ...
    Processing triggers for ureadahead ...
    ureadahead will be reprofiled on next reboot
    Setting up thinkfan (0.7.1-2) ...
    /proc/acpi/ibm/fan: No such file or directory


    I guess the file in /proc/acpi/ibm/fan is not created while install. i don't know why...

  9. #29
    Join Date
    Aug 2010
    Location
    Seattle, WA, USA
    Beans
    40
    Distro
    Kubuntu Development Release

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Thanks for the tutorial. Working very well on my T410 also.

  10. #30
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by Jeff9 View Post
    I'm trying to install this on a T61p. Would that make a difference? After I enter sudo echo "coretemp" >> /etc/modules I get back...bash: /etc/modules: Permission denied

    Admittedly I am new at this, but any help would be appreciated.
    Sorry, indeed the command was wrong. 'sudo' gives you root privileges for the command. So the command 'echo 'coretemp'' is executed with root privileges. but the redirection of output to /etc/modules doesn't work as this is done as normal user again. The following should work:

    $ sudo sh -c 'echo coretemp >> /etc/modules'

Page 3 of 8 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •