Page 2 of 8 FirstFirst 1234 ... LastLast
Results 11 to 20 of 76

Thread: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

  1. #11
    Join Date
    Feb 2010
    Beans
    7

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by mejo View Post
    i got thinkfan working on my t420:

    1. install thinkfan package
    2. add kernel module 'coretemp' to /etc/modules
    3. load kernel module 'coretemp'
    4. add the following three sensor entries to /etc/thinkfan.conf just before the temperature levels:

    sensor /sys/devices/platform/coretemp.0/temp1_input
    sensor /sys/devices/platform/coretemp.2/temp1_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input

    5. add the following to /etc/modprobe.d/thinkfan.conf:

    options thinkpad_acpi fan_control=1

    6. reload kernel module 'thinkpad_acpi'
    7. set START="yes" in /etc/default/thinkfan
    8. start thinkfan: /etc/init.d/thinkfan start

    9. check whether it works: cat /proc/acpi/ibm/fan

    if level has a value between 0 and 7, and changes by times, your thinkfan daemon works.

    I found the solution in the thinkpad wiki (only german) at http://thinkpad-wiki.org/Thinkfan#Ke..._Kernel_2.6.38

    greetings,
    jonas
    Would you mind explaining how to do step 2: Adding 'coretemp' to /etc/modules?

    Cheers,
    M

  2. #12
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by monkeyking009 View Post
    Would you mind explaining how to do step 2: Adding 'coretemp' to /etc/modules?
    M
    Sure. It's very easy. Just add a line with the content 'coretemp' to the textfile /etc/modules. You can do so by using your favourite texteditor, or by executing the following commandline:

    Code:
    # echo "coretemp" >> /etc/modules

  3. #13
    Join Date
    Jul 2011
    Beans
    1

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    @mejo, works nicely!

    on T400, coretemp.1 may be needed instead of coretemp.2

  4. #14
    Join Date
    May 2011
    Beans
    14

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    I'm looking at laptops to install Ubuntu on and the t420 seems like a good bet. Besides needing a workaround for the fan and HDAPS, is the t420 a good machine to use Ubuntu (and/or Mint) on?

  5. #15
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by raphifix View Post
    I'm looking at laptops to install Ubuntu on and the t420 seems like a good bet. Besides needing a workaround for the fan and HDAPS, is the t420 a good machine to use Ubuntu (and/or Mint) on?
    take a look at http://ubuntuforums.org/showthread.php?t=1816071 for a first overview of issues with ubuntu on t420 and links to workarounds and fixes.

  6. #16
    Join Date
    Jul 2008
    Beans
    18

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by mejo View Post
    i got thinkfan working on my t420:

    1. install thinkfan package
    2. add kernel module 'coretemp' to /etc/modules
    3. load kernel module 'coretemp'
    4. add the following three sensor entries to /etc/thinkfan.conf just before the temperature levels:

    sensor /sys/devices/platform/coretemp.0/temp1_input
    sensor /sys/devices/platform/coretemp.2/temp1_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input

    5. add the following to /etc/modprobe.d/thinkfan.conf:

    options thinkpad_acpi fan_control=1

    6. reload kernel module 'thinkpad_acpi'
    7. set START="yes" in /etc/default/thinkfan
    8. start thinkfan: /etc/init.d/thinkfan start

    9. check whether it works: cat /proc/acpi/ibm/fan

    if level has a value between 0 and 7, and changes by times, your thinkfan daemon works.

    I found the solution in the thinkpad wiki (only german) at http://thinkpad-wiki.org/Thinkfan#Ke..._Kernel_2.6.38

    greetings,
    jonas
    I was trying to go through this, but I'm thinking I don't have enough expertise. How would you recommend installing the thinkfan package? I ran 'sudo apt-get install thinkfan'. Is this what you meant?

    Also, when loading kernel modules (step 3), how do you do this? I restarted my computer to load this module.

    I stopped at number 5 because I didn't have a thinkfan.conf file in /etc/modprobe.d/.

    How should I go about this?

    The fan does seem to be going all the time. But I can't be sure, because most of the time it is really quiet, or it gets drowned out by other audio.

    Thanks.

  7. #17
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by chonald View Post
    I was trying to go through this, but I'm thinking I don't have enough expertise. How would you recommend installing the thinkfan package? I ran 'sudo apt-get install thinkfan'. Is this what you meant?

    Also, when loading kernel modules (step 3), how do you do this? I restarted my computer to load this module.

    I stopped at number 5 because I didn't have a thinkfan.conf file in /etc/modprobe.d/.

    How should I go about this?

    The fan does seem to be going all the time. But I can't be sure, because most of the time it is really quiet, or it gets drowned out by other audio.

    Thanks.
    You need to create the file /etc/modprobe.d/thinkfan.conf.

    I'll describe the steps in detail:

    1. install thinkfan package:

    $ sudo apt-get install thinkfan

    2. add kernel module 'coretemp' to /etc/modules

    $ sudo sh -c 'echo coretemp >> /etc/modules'

    3. load kernel module 'coretemp'

    $ sudo modprobe coretemp

    4. add the following three sensor entries to /etc/thinkfan.conf just before the temperature levels:

    sensor /sys/devices/platform/coretemp.0/temp1_input
    sensor /sys/devices/platform/coretemp.2/temp1_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input

    [ edit the file /etc/thinkfan.conf with your favourite editor, e.g. 'sudo gedit /etc/thinkfan.conf' ]

    5. add the following to /etc/modprobe.d/thinkfan.conf: 'options thinkpad_acpi fan_control=1'

    $ sudo sh -c 'echo "options thinkpad_acpi fan_control=1" >> /etc/modprobe.d/thinkfan.conf'

    6. reload kernel module 'thinkpad_acpi'

    $ sudo modprobe -r thinkpad_acpi
    $ sudo modprobe thinkpad_acpi

    7. set START="yes" in /etc/default/thinkfan

    [ edit the file /etc/default/thinkfan with your favourite editor, e.g. 'sudo gedit /etc/default/thinkfan' ]

    8. start thinkfan:

    $ sudo /etc/init.d/thinkfan start

    9. check whether it works

    $ sudo cat /proc/acpi/ibm/fan

    if level has a value between 0 and 7, and changes by times, your thinkfan daemon works.
    Last edited by mejo; October 8th, 2011 at 12:48 AM. Reason: fix command to write to /etc/modprobe.d/thinkfan.conf

  8. #18
    Join Date
    Jul 2009
    Location
    Austin, Texas, USA
    Beans
    399

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    @mejo:
    Chonald commented: "I stopped at number 5 because I didn't have a thinkfan.conf file in /etc/modprobe.d/."

    I encountered the same problem, but I assumed that the reference to subdirectory "modprobe.d" was an error and made the number 5 change to the "thinkfan.conf" file in directory "/etc".

    This seems to have worked for me.

  9. #19
    Join Date
    Jul 2008
    Beans
    18

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Mejo, thank you very much. I appreciate it.

    One thing before I follow these steps. Right now the fan isn't running constantly. I did install the thinkfan package earlier when I first tried this, but I just didn't get through all of the steps. Is there still need for me to go through the rest of the steps, or has the package somehow set itself up to work?

  10. #20
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by rewyllys View Post
    @mejo:
    Chonald commented: "I stopped at number 5 because I didn't have a thinkfan.conf file in /etc/modprobe.d/."

    I encountered the same problem, but I assumed that the reference to subdirectory "modprobe.d" was an error and made the number 5 change to the "thinkfan.conf" file in directory "/etc".

    This seems to have worked for me.
    I wonder why this has worked for you. The file referenced in step five configures the options for the thinkpad_acpi kernel module. This is _not_ the same file as /etc/thinkfan.conf, which configures the options for the thinkfan daemon. The former is kernel level, the latter is userland level.

    Quote Originally Posted by chonald View Post
    Mejo, thank you very much. I appreciate it.

    One thing before I follow these steps. Right now the fan isn't running constantly. I did install the thinkfan package earlier when I first tried this, but I just didn't get through all of the steps. Is there still need for me to go through the rest of the steps, or has the package somehow set itself up to work?
    Which version of thinkfan do you have installed? Did you try step 9 to check whether thinkfan works as expected? Monitor the content of /proc/acpi/ibm/fan in different load situations, and see whether it changes. You can check this by executing 'sudo cat /proc/acpi/ibm/fan' on the console. In case that the value (it's the fan speed level), then your thinkfan already works as expected.

Page 2 of 8 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •