Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: 11.04 Slow wireless connection using ath9k drivers.

  1. #1
    Join Date
    Mar 2010
    Location
    Coventry
    Beans
    156
    Distro
    Ubuntu 11.04 Natty Narwhal

    11.04 Slow wireless connection using ath9k drivers.

    Hello Everyone!

    Title pretty much says it all. Since upgrading to Ubuntu 11.04 my wireless connection has been extremely slow. The same happened with 10.10. Although that was quite different. Back then everything within my network moved slowly, but now it doesn't affect my web browser.
    It seems to have only slowed the application centre and update manager. I am still waiting for the flash plugin to download and install for testing youtube, but I am torrenting Ubuntu 11.04 right now and have actually hit the limit of my bandwidth (1.1 MB/s) whereas the speed in the software centre and update manager was in the region of 45 kb/s.

    I'm not sure if this is because I have installed extra drivers found here after I did some research.

    Although my web surfing is fast and stable, I would like to get my updates and applications downloading properly. Does anyone know what I can do?

    From my 2-hour googling spree I know you may want the results from the command "lspci"


    Code:
    root@Felicia:/home/silkworm# lspci
    00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
    00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
    00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
    00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
    00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
    00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
    00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
    00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
    00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
    00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
    00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
    00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
    00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
    00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
    00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
    00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
    02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
    Any help would be greatly appreciated ^_^

    And by the way, a little off topic, but is downloading apps through Ubuntu Tweak just another interface for apt-get? Because that has the same speed as the software centre.
    The time you enjoy wasting is not time wasted.
    You are where you are because you wanted to be there.

  2. #2
    Join Date
    Sep 2007
    Beans
    1

    Re: 11.04 Slow wireless connection using ath9k drivers.

    Hi, try this is well explained:
    http://linuxwireless.org/en/users/Do...ng_the_tarball

    I had the same problem with ath9k and it worked for me

  3. #3
    Join Date
    May 2011
    Beans
    11

    Re: 11.04 Slow wireless connection using ath9k drivers.

    hi,

    i have the same problem. 11.04 has turned my high speed wifi into a slow dialup style connection. i conect to my wireless router just fine but when i try to load a page, it just sits there loading and takes a long time or it just stops loading altogether.

    unfortunately i have no clue what to do at the link. i don't know how to compile a tarball thing or where to put those scripts.

    is there an easy way to ugrade my drivers for the ath9k?

    thanks in advance for any help.

  4. #4
    Join Date
    Aug 2006
    Location
    Brighton, England
    Beans
    56
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 11.04 Slow wireless connection using ath9k drivers.

    See this post here: LINK

    Basically all you have to do is:

    Code:
    sudo -s
    
    echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
    and reboot!

    (Thanks to mantaor and Andrea!)

  5. #5
    Join Date
    May 2011
    Beans
    11

    Re: 11.04 Slow wireless connection using ath9k drivers.

    Thank you so much !!

    it worked!! i truly appreciate your help.

    i hope you have a wonderful week.


    thank you again!!

  6. #6
    Join Date
    Feb 2007
    Location
    Prince Edward Island
    Beans
    9
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Slow wireless connection using ath9k drivers.

    Thank you "Yellercat"! This solution worked flawlessly for me also.

    Just a slight addition to your solution - you can type "reboot" as step 3 from terminal to initiate the reboot process. Thank God for Ubuntu Forums.

    Quote Originally Posted by yellerKat View Post
    See this post here: LINK

    Basically all you have to do is:

    Code:
    sudo -s
    
    echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
    and reboot!

    (Thanks to mantaor and Andrea!)

  7. #7
    Join Date
    Mar 2008
    Beans
    8

    Re: 11.04 Slow wireless connection using ath9k drivers.

    Quote Originally Posted by yellerKat View Post
    See this post here: LINK

    Basically all you have to do is:

    Code:
    sudo -s
    
    echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
    and reboot!

    (Thanks to mantaor and Andrea!)
    Thanks!!! It also worked for me!!!!

  8. #8
    Join Date
    May 2011
    Beans
    3
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Slow wireless connection using ath9k drivers.

    Using this nocrypt option actually restores speed, but my machine then crashes completely after a variable duration, from a few seconds to a few minutes. It then needs a hard reboot. This does not happen when nocrypt is not used (and wifi is then slow enough to get timeouts on most transmissions).

  9. #9
    Join Date
    Mar 2010
    Location
    Coventry
    Beans
    156
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Slow wireless connection using ath9k drivers.

    Thanks for that response yellerKat! That fixed it right up this time!
    The time you enjoy wasting is not time wasted.
    You are where you are because you wanted to be there.

  10. #10
    Join Date
    Jan 2009
    Beans
    5

    Re: 11.04 Slow wireless connection using ath9k drivers.

    FYI, I just installed the newest kernel (2.6.38-9.43) that is in the ubuntu-proposed update tree, and it seems to fix the issues with the ath9k driver. My Acer laptop is usable on wireless again!

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •