Results 1 to 5 of 5

Thread: Installing Brother Printer, depends on libc6 (>= 2.2.5) error

  1. #1
    Join Date
    Dec 2008
    Location
    Waterloo / Toronto
    Beans
    4
    Distro
    Ubuntu 11.04 Natty Narwhal

    Exclamation Installing Brother Printer, depends on libc6 (>= 2.2.5) error

    Hi there, I've just installed Ubuntu for the first time with 11.04 onto my new laptop.

    I'm trying to install the LPR driver provided by Brother, (found here:http://welcome.solutions.brother.com...ion_prn1a.html ) followed by the cupswrapper driver. I am following the instructions provided on the Brother website.

    When installing the LPR driver, I run into

    Code:
    Unpacking brhl2040lpr:i386 (from brhl2040lpr-2.0.1-1.i386.deb) ...
    dpkg: dependency problems prevent configuration of brhl2040lpr:i386:
     brhl2040lpr:i386 depends on libc6 (>= 2.2.5).
    dpkg: error processing brhl2040lpr:i386 (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     brhl2040lpr:i386
    Checking on synaptic, I have libc version 2.13-0ubuntu13. Why is this a problem?

    I am running 64 bit Natty and I have both lib32stdc++6 AND ia32-libs installed.

    Thanks!

  2. #2
    Join Date
    Jan 2009
    Beans
    2

    Re: Installing Brother Printer, depends on libc6 (>= 2.2.5) error

    I have exactly the same problem with the BrotherHl2150N lpr and cupswrapper driver.

    Thanks,
    Fazky

    Edit: I found the solution to this problem at:
    https://bugs.launchpad.net/ubuntu/+s...ps/+bug/701856

    Cheers
    Last edited by Fazky; May 2nd, 2011 at 08:10 PM.

  3. #3
    Join Date
    Dec 2008
    Location
    Waterloo / Toronto
    Beans
    4
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Installing Brother Printer, depends on libc6 (>= 2.2.5) error

    I found another quasi solution. I installed the Brother HL-2035 Foomatic/hl1250 driver which was included with CUPS, even though my printer is the HL2040. Seems to work fine so far.

  4. #4
    Join Date
    May 2011
    Beans
    1

    Re: Installing Brother Printer, depends on libc6 (>= 2.2.5) error

    I finally got my Brother HL-2140 working on 64-bit Ubuntu 11.04 Natty.

    My printer was detected fine from a fresh install as an HL-2140. When I attempted to print the printer would continuously print blank pages.

    I had tried Faxky's solution above, building the new debs and installing them. The new printer showed up in the Printing gui but the "Printer State" seemed to be stuck at Processing. So I gave up on that and tried changing the driver which luckily worked.


    1. In the Printing gui, I right-clicked and selected "Properties" on the HL-2140-series printer that had been installed automatically when I installed the system.
    2. Under Settings->Make and Model, click the Change button.
    3. Click Forward on the Choose driver page after the list populates and should have "Brother (recommended)" selected in the list.
    4. The Model on the left should be selected as "HL-2140 (recommended)" or whatever Brother model you're using. The Driver selected to the right for me was "Brother HL-2140 Foomatic/Postscript [en] (recommended)". I changed that to the next option in the list, "Brother HL-2140 Foomatic/hpijs-pcl5e [en]".
    5. Click Forward to select
    6. I chose the "Use the new PPD as is"
    7. Tried printing a test page from the printer page and it worked!

  5. #5
    Join Date
    May 2009
    Beans
    12

    Talking Re: Installing Brother Printer, depends on libc6 (>= 2.2.5) error

    Quote Originally Posted by n0y0x View Post
    I found another quasi solution. I installed the Brother HL-2035 Foomatic/hl1250 driver which was included with CUPS, even though my printer is the HL2040. Seems to work fine so far.
    Thank you! I have installed and uninstalled several different printer drivers (including the official Brother drivers) and so far nothing worked. I installed the Brother HL-2035 Foomatic/hl1250 driver expecting it to fail because I'd mess around with the drivers so much but IT WORKS!

    Thank you! =D>

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •