Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Classic gnome panel suddenly not working

  1. #1
    Join Date
    Nov 2009
    Beans
    199
    Distro
    Ubuntu 12.04 Precise Pangolin

    Classic gnome panel suddenly not working

    After having some trouble with some disk full errors the classic gnome panel that I have been using stopped working. I tried running it from terminal and got some errors about expecting a string and getting a list, I managed to fix those by changing some values in the gconf-editor. Now all I get when I try to run it from terminal is "Segmentation fault (core dumped)". I have uninstalled, purged, and reinstalled several times but no effect. Using Ubuntu 12.04 64-bit.

  2. #2
    Join Date
    Nov 2009
    Beans
    199
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Classic gnome panel suddenly not working

    After purging and reinstalling several times I finally figured out that it was leaving some remnants so I removed those as well. This time it tried to start and then it gave me another error that it stopped working and suggested I send an error report, which I did. I then tried starting it from terminal and got this message

    Code:
    ** (gnome-panel:3228): WARNING **: Error opening directory '/usr/share/gnome-panel/4.0/applets': No such file or directory
    Segmentation fault (core dumped)
    After reinstalling Ubuntu 12.04 still having the same problem. I purged again and autoremoved and am still seeing remnants when I use whereis and locate. Really could use some help here
    Last edited by netopalis45; October 4th, 2012 at 12:59 AM. Reason: Update

  3. #3
    Join Date
    Nov 2009
    Beans
    199
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Classic gnome panel suddenly not working

    Admin: Can you move this thread to General Help, I think I may at least get a reply there.

  4. #4
    Join Date
    Oct 2011
    Location
    West Bengal, India
    Beans
    92
    Distro
    Kubuntu 12.04 Precise Pangolin

    Lightbulb Re: Classic gnome panel suddenly not working

    Maybe it will work again if you reset the gnome to its default.

    This command will delete your configuration files. So be warned!

    First if you want to backup your config file run this:

    Code:
    mkdir ./.old-gnome-config/ && mv ./.gnome* ./.old-gnome-config/ && mv .gconf* ./.old-gnome-config/ && mv ./.metacity ./.old-gnome-config/ && mv ./.cache ./.old-gnome-config/ && mv ./.dbus ./.old-gnome-config/ && mv ./.dmrc ./.old-gnome-config/ && mv ./.mission-control ./.old-gnome-config/ && mv ./.thumbnails ./.old-gnome-config/   && ~/.config/dconf/* ./.old-gnome-config/
    Now delete config files:

    Code:
    rm -rf .gnome .gnome2 .gconf .gconfd .metacity .cache .dbus .dmrc .mission-control .thumbnails ~/.config/dconf/user ~.compiz*
    Log out and log in back.
    Intel Core2Duo 2.20 GHz || 4 GB DDR3 RAM
    nVidia GT 240M 1 GB || 320 GB SATA Hard Disk

  5. #5
    Join Date
    Nov 2009
    Beans
    199
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Classic gnome panel suddenly not working

    Just gave that a try and when it tried to copy the .metacity folder it said "file not found". Could that be what is causing the problem in the first place?

  6. #6
    Join Date
    Oct 2011
    Location
    West Bengal, India
    Beans
    92
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Classic gnome panel suddenly not working

    Metacity is a window manager and is used by gnome-classic session.

    Just gave that a try and when it tried to copy the .metacity folder it said "file not found"
    Its probably mean that something is missing inside the folder. I cannot clearly tell if it is the problem. I suggest you to delete the config files using the second command I posted and see if problem still exists......
    Intel Core2Duo 2.20 GHz || 4 GB DDR3 RAM
    nVidia GT 240M 1 GB || 320 GB SATA Hard Disk

  7. #7
    Join Date
    Nov 2009
    Beans
    199
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Classic gnome panel suddenly not working

    So I checked on metacity and it looked to be installed correctly but I went ahead and purged and reinstalled it but it didn't help any. Strange thing is I have a laptop with 12.04 installed and am running gnome classic perfectly on it so I really don't know what's going on.

  8. #8
    Join Date
    Apr 2008
    Beans
    10,636

    Re: Classic gnome panel suddenly not working

    First be certain that you are logging into the classic (no effects) session and NOT the standard classic session:

    session_select.png

    The standard classic session uses compiz rather than metacity and it's proven to be problematic, more so on some hardware than others.

  9. #9
    Join Date
    Apr 2008
    Beans
    10,636

    Re: Classic gnome panel suddenly not working

    Oh, just thought to add, since you have no panel(s) you might find it difficult to log out and display the login screen. The key combo Alt+SysReq+K should log you out if needed, and SysReq is PrtScn on some keyboards.

  10. #10
    Join Date
    Apr 2008
    Beans
    10,636

    Re: Classic gnome panel suddenly not working

    If you find that some of your configuration files are messed up this may be helpful:

    http://ubuntuforums.org/showpost.php...0&postcount=40

    I made quite a few notes about using classic (no effects) here:

    http://ubuntuforums.org/showthread.php?t=1966370

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •