Page 5 of 9 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 82

Thread: wireless is disabled by hardware switch - natty 11.04

  1. #41
    Join Date
    Feb 2011
    Beans
    11

    Re: wireless is disabled by hardware switch - natty 11.04

    Quote Originally Posted by chili555 View Post
    That suggests a switch or slider is in the Off position. Please check.
    Hey chili555, you are wonderful. Wireless switch was indeed in off position. I slided it and it is working again.

    Thanks a lot,
    Ashish

    P.S. I was not aware of the position of WiFi hardware switch. I am attaching the right hand side snap shot of the XPS1530 which I took from Dell site
    http://support.dell.com/support/edoc....htm#wp1212382
    Attached Images Attached Images
    Last edited by converge2ashish; May 18th, 2011 at 04:33 AM. Reason: spelling correction

  2. #42
    Join Date
    Jan 2010
    Beans
    5

    Question Re: wireless is disabled by hardware switch - natty 11.04

    Quote Originally Posted by chili555 View Post
    ... Now let's see:
    Code:
    lsmod | grep wl
    dmesg | grep wl
    The above code didn't have any visible output. This was the entry in byobu:

    Welcome to Ubuntu 11.04 (GNU/Linux 2.6.38-8-generic x86_64)

    * Documentation: https://help.ubuntu.com/

    ~$ lsmod | grep wl
    ~$ dmesg | grep wl
    ~$

    @Chilli555 Thanks for the explanation of the module.

  3. #43
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,104
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless is disabled by hardware switch - natty 11.04

    Quote Originally Posted by DarrenMayLin View Post
    The above code didn't have any visible output. This was the entry in byobu:

    Welcome to Ubuntu 11.04 (GNU/Linux 2.6.38-8-generic x86_64)

    * Documentation: https://help.ubuntu.com/

    ~$ lsmod | grep wl
    ~$ dmesg | grep wl
    ~$

    @Chilli555 Thanks for the explanation of the module.
    Please connect an ethernet cable and do:
    Code:
    sudo apt-get install bcmwl-kernel-source
    sudo modprobe wl
    Now is your wireless working?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #44
    Join Date
    May 2007
    Beans
    1

    Re: wireless is disabled by hardware switch - natty 11.04

    Quote Originally Posted by chili555 View Post
    With due respect to my colleagues, I think it's due to a poor implemetation of the module dell-laptop. Please do:
    Code:
    lsmod | grep dell
    If dell-laptop is loaded, remove it:
    Code:
    sudo rmmod -f dell-laptop
    sudo rfkill unblock all
    Is your wireless working now? If so, we'll need to blacklist dell-laptop.
    This solution works for the Latitude D520. Thanks.

  5. #45
    Join Date
    May 2009
    Location
    Austin, Tx
    Beans
    41
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: wireless is disabled by hardware switch - natty 11.04

    I have the same laptop as the original poster and had problems when I clean installed natty. (no problems in Lucid)

    At first the Advanced Driver "wizard" (windoze lingo I know... what else could you call them?) wouldn't install the Broadcom driver, but I got over that with help from: http://www.broadcom.com/docs/linux_sta/README.txt

    Then I had the same message: wireless disabled by a hardware switch. I can confirm @chili555 method. Removing dell_laptop did seem to fix the problem (after reboot).
    > < > Brian (University of Texas, Electrical Engineering, '13)

    "We are perishing for want of wonder, not for want of wonders." -G. K. Chesterton, qtd: I, Pencil by Leonard Read

  6. #46
    Join Date
    Apr 2007
    Beans
    Hidden!

    Re: wireless is disabled by hardware switch - natty 11.04

    Quote Originally Posted by MKdx View Post
    I can confirm that wireless settings in Windows influence hard blocked key in [brcmwl]:

    Code:
    brcmwl-0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    I have lenovo laptop, had problem with acer_wmi but worked around that by 'blacklisting' it. However, [brcmwl] issue seems to only get 'fixed by setting software switch in Windows to ON.
    I got around to check this bit more last week, though the wireless state is affected by how it's set in Windows, Windows is not needed to set it back in Linux.

    For some reason [brcmwl] state can't be altered unless [acer_wmi] is still loaded. So to get wireless to work at startup, a sequence similar to this is need:
    Code:
    rfkill unblock all
    sudo rmmod acer_wmi
    This will unblock all devices before removing [acer_wmi], to ensure [brcmwl] is not blocked. Wireless should start regardless of Windows availability/setting. This should work for most lenovo laptops/netbooks, possibly other brands with some variation.

  7. #47
    Join Date
    Feb 2010
    Beans
    5

    Re: wireless is disabled by hardware switch - natty 11.04

    Quote Originally Posted by rl78 View Post
    Try specifying the identifier: rfkill unblock 0.
    This worked for me. Will I need to run it each time I boot, or is there a way to automate it at start-up?

  8. #48
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,104
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless is disabled by hardware switch - natty 11.04

    Quote Originally Posted by pearlzilla View Post
    This worked for me. Will I need to run it each time I boot, or is there a way to automate it at start-up?
    If that is all you need to do, that is, you don't need to rmmod any laptop or wmi drivers, then do:
    Code:
    sudo gedit /etc/rc.local
    Add one line above exit 0
    Code:
    rfkill unblock 0
    Proofread carefully, save and close gedit.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #49
    Join Date
    Jun 2011
    Beans
    31

    Re: wireless is disabled by hardware switch - natty 11.04

    I did every thing i have done so far and this is what i get what next it killed the dell but the hard lock still it there on brcmwl


    Code:
    tanoah@tanoah-Inspiron-1545:~$ rfkill list
    0: dell-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
    1: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
    tanoah@tanoah-Inspiron-1545:~$ sudo rmmod -f dell-laptop
    tanoah@tanoah-Inspiron-1545:~$ sudo rfkill unblock all
    tanoah@tanoah-Inspiron-1545:~$ rfkill list
    1: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
    tanoah@tanoah-Inspiron-1545:~$ sudo rfkill unblock all
    tanoah@tanoah-Inspiron-1545:~$ sudo ifconfig eth1 up
    tanoah@tanoah-Inspiron-1545:~$ sudo rfkill unblock all
    tanoah@tanoah-Inspiron-1545:~$ rfkill list
    1: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
    tanoah@tanoah-Inspiron-1545:~$

  10. #50
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,104
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless is disabled by hardware switch - natty 11.04

    Hard blocked: yes
    Are you quite sure the hardware switch or key combination is in the On position?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 5 of 9 FirstFirst ... 34567 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •