Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: frequency out of range problem in ubuntu natty grub

  1. #11
    Join Date
    Jun 2011
    Beans
    1

    Re: frequency out of range problem in ubuntu natty grub

    Quote Originally Posted by JgsDragon View Post
    I just had this problem too. It happened when I updated from 10.10 to 11.04 so that might be a good place to look for the solution...

    What I did was I opened my Grub config in /etc/default/grub (You may need to open this with sudo with the following command:
    Code:
    sudo gedit /etc/default/grub
    )
    Then find the line with
    Code:
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640*400
    Un-comment the last line and change it to a supported resolution for your monitor.
    (I used 800*600, and pretty much any resolution below 1024*786 should work.)

    Then the last thing you need to do is type
    Code:
    sudo update-grub
    and it will automatically update your Grub configuration files.
    I am having the same issue. The fix above allows me to get to the sign in screen but when I sign in it get the out of range message again. can some one help??

  2. #12
    Join Date
    Feb 2007
    Location
    perdita
    Beans
    1,622
    Distro
    Ubuntu

    Re: frequency out of range problem in ubuntu natty grub

    I am having the same issue. The fix above allows me to get to the sign in screen but when I sign in it get the out of range message again. can some one help??
    And the login screen is ok?
    Do you only get an out-of-range message and the screen is ok or is your screen unusable after login?

    I think your problem is different than the one of the people here.
    Setting the resolution in /etc/default/grub only affects the grub menu.

    To change the resolution in Ubuntu itself, try system->preferences->display first:
    http://www.ubuntugeek.com/how-to-cha...in-ubuntu.html

    Or use xrandr:
    https://wiki.ubuntu.com/X/Config/Resolution

    Your problem might also be driver-related eventually.
    If you can boot into safe graphics / VESA mode from a live CD correctly, it's most likely driver-related.
    You can enable/disable proprietary drivers (if any are available) in "system->administration->restricted drivers manager":
    http://cybernetnews.com/install-and-...ers-in-ubuntu/
    Non-proprietary drivers come with the various xserver-xorg-video* packages. If you had/have no problems with previous versions of Ubuntu, you might be able to fix the problem by downgrading to older versions. But report a bug on launchpad about it in this case.

    Tips to be able to use Ubuntu when having graphics problems:
    • You can choose recovery mode from the grub menu to get command-line access to your system.
    • If you missed the grub menu, you can still hit ctrl+alt+Fn (Fn=F1,F2,etc) to get a terminal.
    • Boot into safe graphics mode from a Live-CD: https://help.ubuntu.com/community/Bo...Boot%20Options
    • And there should be a way to force vesa mode by default, but I couldn't find anything except the xforcevesa option mentioned here:
      http://www.piotrkrzyzek.com/enter-sa...-lynx-live-cd/
      i.e. either edit the GRUB2 line from the menu or edit the grub2 config files to make it permanent.
    Last edited by KIAaze; June 24th, 2011 at 09:58 AM.

  3. #13
    Join Date
    Mar 2008
    Beans
    6

    Re: frequency out of range problem in ubuntu natty grub

    I am having this same problem. I have 10.10 installed do i update and then edit the grub BEFORE i reboot or what?

    Linux newbie here sorry.

  4. #14
    Join Date
    Feb 2007
    Location
    perdita
    Beans
    1,622
    Distro
    Ubuntu

    Re: frequency out of range problem in ubuntu natty grub

    What do you mean by update? Upgrade from 10.10?

    If you mean "sudo update-grub", then no, you first edit /etc/default/grub, then "sudo update-grub" and then when you reboot, the grub resolution should be ok.

    Just follow the instructions here:
    http://ubuntuforums.org/showpost.php...04&postcount=2

    And obviously you have to reboot after that to see if it works.

    As I said previously: This only solves resolution problems with GRUB, the boot menu, not with the login screen or after login.

  5. #15
    Join Date
    Sep 2011
    Beans
    3

    Re: frequency out of range problem in ubuntu natty grub

    How is one supposed to fix this if they can't see anything? I sent my daughter a nice PC with Natty loaded on it. It ran great here during load and test on a 1400x900 resolution. She recievd it and it worked great on a 1280x1024 resolution on a different LCD. Then all the sudden the monitor just displayed the same "monitor out of frequency" problem.

    Before I had read this thread I had her disconnect the monitor and try another monitor between reboots. Then I sent her another monitor that supported a much broader frequencey range and still the same problem.

    The biggest delimea for me is that she lives 2000 miles away and It is not possible to connect through VPN because she is in a rural area that does not support high speed internet with any reliancy.

    So without being able to see the screen, how would she fix the problem?

    All I can think of is reloading....

  6. #16
    Join Date
    Feb 2007
    Location
    perdita
    Beans
    1,622
    Distro
    Ubuntu

    Re: frequency out of range problem in ubuntu natty grub

    If the display problem is just with GRUB (i.e. the boot menu), she should be able to use Ubuntu normally after boot and fix the issue as specified earlier.
    Otherwise, the problem is different and you should create another thread.

    Also, the VGA mode (safe graphics mode) and recovery mode should still work I think.

    Did the problem appear after an upgrade? In that case, downgrading the corresponding package (xserver something probably) might solve it and then you should report a bug at launchpad.

  7. #17
    Join Date
    Nov 2011
    Beans
    1

    Re: frequency out of range problem in ubuntu natty grub

    Quote Originally Posted by m8i9k View Post
    When I try to boot, monitor tells me something like "out of range". The computer does not shutdown or anything like this, but the message stays on the screen. I tried to chroot from live cd and edit grub settings (as written above). I rebooted it and it stays the same (still nothing happens). Does anyone have an idea what could be the problem?

    Edit: Nevermind the above solution seems to have worked after all.
    Im also getting like this plz tel me any one how to fix this problem im waiting for your answer.....

  8. #18
    Join Date
    Jan 2010
    Beans
    20
    Distro
    Xubuntu

    Re: frequency out of range problem in ubuntu natty grub

    I'm having a different but related problem. I have Ubuntu 11.10 installed on an old Fujitsu Lifebook p2110. It was installed originally from an older version Minimal CD and upgraded in place.

    The Lifebook has an 867mhz Transmeta CPU, 256MB RAM (of which the CPU grabs 16MB off the top for code morphing), and a 40GB UDMA 4 HD, multibooting Win2K Pro, Ubuntu, Puppy 4.31, and FreeDOS. Video is handled by an onboard ATI Rage Pro Mobility chipset with 8MB video RAM. Ubuntu properly recognizes the chipset's maximum 1280x768 resolution in 16bit color, and the GUI uses it.

    The problem is character mode screens _not_ using the GUI. I get a screen that is black text on a white background, and the text is garbled and unreadable.

    If I go into the grub menu entry at boot time, and manually specify the boot commands including "set GFXMODE=1280x768", I see the character mode screen I expect, and I can switch to another display using Ctrl-Alt-F1 or the like and have a usable character mode session.

    I followed directions elsewhere to update /etc/default/grub to uncomment the GRUB_GFXMODE line, and set the resolution the 1280x768, then did an update-grub operation to regenerate the grub.cfg file. All appeared to work as expected, but when I rebooted and selected Ubuntu from the grub menu, I saw the same garbled character mode screen display I was trying to fix. It works manually changing the boot options form the grub menu, but fails when it does it automatically.

    Am I missing something, or have I been bitten by an 11.10 bug?
    ______
    Dennis

  9. #19
    Join Date
    Aug 2011
    Beans
    40
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: frequency out of range problem in ubuntu natty grub

    Too Many Bugs with Ubuntu. Sure this fix gets rid of the black screen at login in, but the resolution on my system just goes berserk. everything is magnified, including the bootloader.
    Isa Dsouza
    onionous.wordpress.com

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •