Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: samba4 fails in 10.04 upgrade

  1. #1
    Join Date
    Aug 2007
    Beans
    29

    Exclamation samba4 fails in 11.04 upgrade

    Hi

    When I upgraded to Ubuntu 11.04 the install of the samba4 failed. Now everytime I install/remove packages I get an error about it:

    Code:
    Setting up samba4 (4.0.0~alpha15~git20110124.dfsg1-2ubuntu1) ...
    Unknown parameter encountered: "max log size"
    Ignoring unknown parameter "max log size"
    Unknown parameter encountered: "syslog"
    Ignoring unknown parameter "syslog"
    Unknown parameter encountered: "passdb backend"
    Ignoring unknown parameter "passdb backend"
    Unknown parameter encountered: "unix password sync"
    Ignoring unknown parameter "unix password sync"
    Unknown parameter encountered: "passwd program"
    Ignoring unknown parameter "passwd program"
    Unknown parameter encountered: "pam password change"
    Ignoring unknown parameter "pam password change"
    Unknown parameter encountered: "map to guest"
    Ignoring unknown parameter "map to guest"
    Unknown parameter encountered: "usershare allow guests"
    Ignoring unknown parameter "usershare allow guests"
    Unknown parameter encountered: "guest ok"
    Ignoring unknown parameter "guest ok"
    Unknown parameter encountered: "guest ok"
    Ignoring unknown parameter "guest ok"
    Unknown parameter encountered: "max log size"
    Ignoring unknown parameter "max log size"
    Unknown parameter encountered: "syslog"
    Ignoring unknown parameter "syslog"
    Unknown parameter encountered: "passdb backend"
    Ignoring unknown parameter "passdb backend"
    Unknown parameter encountered: "unix password sync"
    Ignoring unknown parameter "unix password sync"
    Unknown parameter encountered: "passwd program"
    Ignoring unknown parameter "passwd program"
    Unknown parameter encountered: "pam password change"
    Ignoring unknown parameter "pam password change"
    Unknown parameter encountered: "map to guest"
    Ignoring unknown parameter "map to guest"
    Unknown parameter encountered: "usershare allow guests"
    Ignoring unknown parameter "usershare allow guests"
    Unknown parameter encountered: "guest ok"
    Ignoring unknown parameter "guest ok"
    Unknown parameter encountered: "guest ok"
    Ignoring unknown parameter "guest ok"
    ldb: unable to stat module /usr/lib/samba/ldb/modules/samba : No such file or directory
    ldb: failed to initialise module /usr/lib/samba/ldb/modules/samba : Unavailable
    ldb: failed to initialise module /usr/lib/samba/ldb/modules : Unavailable
    WARNING: Module [samba_dsdb] not found - do you need to set LDB_MODULES_PATH?
    Unable to load modules for /var/lib/samba/private/sam.ldb: Failed to load modules from: /usr/lib/samba/ldb
    
    Traceback (most recent call last):
      File "/usr/share/samba/setup/upgradeprovision", line 1597, in <module>
        ldbs = get_ldbs(paths, creds, session, lp)
      File "/usr/lib/python2.7/dist-packages/samba/upgradehelpers.py", line 159, in get_ldbs
        ldbs.sam = SamDB(paths.samdb, session_info=session, credentials=creds, lp=lp, options=["modules:samba_dsdb"])
      File "/usr/lib/python2.7/dist-packages/samba/samdb.py", line 53, in __init__
        options=options)
      File "/usr/lib/python2.7/dist-packages/samba/__init__.py", line 110, in __init__
        self.connect(url, flags, options)
      File "/usr/lib/python2.7/dist-packages/samba/samdb.py", line 66, in connect
        options=options)
    _ldb.LdbError: (80, 'Failed to load modules from: /usr/lib/samba/ldb\n')
    dpkg: error processing samba4 (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     samba4
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    This error is the same one that occurred during the upgrade. Any help to resolve this issue would be appreciated (preferably without removing samba as I regularly access windows shares).

    P.S
    The upgrade to 11.04 seemed to work even though it said it failed due to this error.
    Last edited by Hotel; April 30th, 2011 at 03:46 AM.

  2. #2
    Join Date
    Sep 2007
    Location
    Cape Town
    Beans
    70
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: samba4 fails in 10.04 upgrade

    I had the same problem.
    Linux since 2005
    Ubuntu since 2007
    Windows free since January 14 2011
    back on that Windows crack :'( October 2011. I just love games.

  3. #3
    Join Date
    Dec 2005
    Beans
    59

    Re: samba4 fails in 11.04 upgrade

    Same here after upgrade to 11.04, though the local network still works.
    Cheers, Krister

  4. #4
    Join Date
    Mar 2009
    Beans
    48
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: samba4 fails in 10.04 upgrade

    me too

  5. #5
    Join Date
    May 2011
    Beans
    1

    Re: samba4 fails in 10.04 upgrade

    Dear Ubuntu Support,
    Please post bug fix, same problem to my IBM ThinkPad T61


    Kind Regards,
    David

  6. #6
    Join Date
    Mar 2009
    Beans
    48
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: samba4 fails in 10.04 upgrade

    ive saved my data and done a fresh install, worked for me

  7. #7
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    9,485
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: samba4 fails in 10.04 upgrade

    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  8. #8
    Join Date
    Sep 2010
    Beans
    8

    Re: samba4 fails in 10.04 upgrade

    I have the same problem here too.

  9. #9
    Join Date
    Dec 2005
    Beans
    59

    Re: samba4 fails in 10.04 upgrade

    Made a fresh install instead of an upgrade, and Samba still failed. Maybe I should qualify that. As I mentioned above the Samba shares still work, but what does not work is the configuration program:

    root@DESKTOP:~# system-config-samba
    Traceback (most recent call last):
    File "/usr/sbin/system-config-samba", line 44, in <module>
    import mainWindow
    File "/usr/share/system-config-samba/mainWindow.py", line 30, in <module>
    import gtk.glade
    ImportError: No module named glade

    Could it be so that the system-config-samba is a gnome program, whereas I am using Kubuntu 11.04?

  10. #10
    Join Date
    Sep 2010
    Beans
    8

    Re: samba4 fails in 10.04 upgrade

    I fixed the problem.
    Code:
    sudo rm /usr/lib/samba/ldb/modules/samba
    I don't know if it brokes something else on the system, but I still can access samba shares.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •