Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 11.04 Unity - Can't get rid of Workspace Switcher

  1. #1
    Join Date
    May 2008
    Beans
    13

    11.04 Unity - Can't get rid of Workspace Switcher

    I don't want to use more than one workspace. On previous versions of Ubuntu, I was able to reduce the number of workspaces to 1 and and remove the workspace switcher from the panel. I want to do this in Unity and can't find a way to. Right clicking doesn't let me remove from the launcher and I can find no way to reduce the workspaces.

    It's a little thing but it annoys me.

  2. #2
    Join Date
    May 2009
    Location
    Pensacola, Florida
    Beans
    52
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    I agree with you as well. I was hoping to find a way to get rid of this too.....
    ***********************************************
    I run two sites, if you like horror movies: etcomeback.com, and my personal blog at mailorderdudes.com

  3. #3
    Join Date
    Jun 2010
    Location
    Illinois
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    Install compiz:

    sudo apt-get install compizconfig-settings-manager

    Open Unity-Launcher (the ubuntu icon in top left of screen) and search for compizconfig settings manager.

    Click on General Options, then the Desktop Size tab (last one on the right), and set all of the sliders to 1.

  4. #4
    Join Date
    May 2009
    Location
    Pensacola, Florida
    Beans
    52
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    I want to have the 4 desktops, I just don't want to have the icon on the left....
    ***********************************************
    I run two sites, if you like horror movies: etcomeback.com, and my personal blog at mailorderdudes.com

  5. #5
    Join Date
    Apr 2006
    Beans
    189

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    I too would like to get rid of this button. I'm using the cube and switch desktops via the viewport switcher plugin, so the button on the launcher is just wasted space.

    I haven't found a way to do it yet... still searching...

  6. #6
    Join Date
    Dec 2007
    Beans
    27

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    same problem here, icon just takes up space

  7. #7
    Join Date
    May 2008
    Beans
    13

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    nnard1616's procedure did let me reduce the number of workspaces to one but I still can't get rid of the annoying button.

  8. #8
    Join Date
    Mar 2010
    Location
    Dublin, Ireland
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    I've been trying to figure this out for a few days. I've now resorted to checking out the unity source code to see if it's hard-coded there
    Matt
    blog.mattrudge.net for extra helpings of geeky Ubuntu goodness
    Get the Ubuntu Weekly Newsletter

  9. #9
    Join Date
    Mar 2010
    Location
    Dublin, Ireland
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    ...and indeed it is hard-coded

    There doesn't seem to be a way around this with .desktop files either (I've tried) and trying to force an error by removing the associated icon file doesn't work either.

    From my perusal of the code - it would be fairly trivial to introduce some form of conditional checking, but since I'm not authorised to update the branch, then we'll just have to wait for it to be fixed in an update.
    Matt
    blog.mattrudge.net for extra helpings of geeky Ubuntu goodness
    Get the Ubuntu Weekly Newsletter

  10. #10
    Join Date
    Jun 2010
    Location
    Louisiana
    Beans
    184
    Distro
    Ubuntu Development Release

    Re: 11.04 Unity - Can't get rid of Workspace Switcher

    I have found a way to get the Workspace Switcher icon to no longer appear in the Unity launcher.

    First, open up a terminal and open gnome-panel by typing:
    Code:
    gnome-panel
    This launches the old gnome panel. Your gnome panel should have a Workspace Switcher on it, probably in a 2 X 2 grid pattern. (If you don't have a Workspace Switcher on the gnome-panel, right-click on the panel and add it.) Now right-click on the Workspace Switcher on the gnome-panel and select Preferences. Change the columns to 1 and the rows to 4. Now log out of Unity...then log back in. The switcher on the launcher will be gone.

    Now your desktop wall will be in a 1 X 4 grid, up to down...rather than side to side. But this all I've found to work. Changing to a 4 X 1 grid side to side will not remove the launcher switcher.

    NOTE: To get the Unity launcher switcher back, simply open the gnome-panel in terminal again, and go back to a 2 X 2 grid. Logout and log back in.
    Attached Images Attached Images
    "The Linux philosophy is laugh in the face of danger. Oops. Wrong one. Do it yourself. That's it." --Linus Torvalds

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •