Page 1 of 131 1231151101 ... LastLast
Results 1 to 10 of 1309

Thread: Graphics Resolution- Upgrade /Blank Screen after reboot

  1. #1
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Graphics Resolution- Upgrade /Blank Screen after reboot

    Are you having these problems?
    - Error- "Cannot display this grahics mode"
    - GRUB_GXFMODE-auto results in Blank screen problems on Startup? (this includes purple or black screen, flashing cursor, stuck at splash screen...)
    - No Grub Menu?

    Note: Keep checking back to this post and the next 2, as I edit them with the latest changes and workarounds.

    The Table Of Contents (<-- Link) is on page 2. It has links to many graphics tutorials, workarounds and fixes in this thread.


    Preface
    Linux distributions such as Ubuntu, basically and simplistically run in layers like this--> You have a Linux kernel running. On top of that layer, you have a terminal session- running to interact with other layers. On top of that, you have an GUI, XTerminal session, X-Wndows, XServer or also known as an XSession running to have a visually interactive session running. In each version of Ubuntu (and of distro's) an honest and earnest attempt is made to make each new version easier to use for a new user, in a way that is pleasing to the eye. Each of these changes does mean underlying changes in how things relate to each other layer... on a base that is trying to cover a myriad of hardware combinations, that users will install that distribution onto. Sometimes all of these combinations cannot be "foreseen." (For instance when a certain video card type is made by over a dozen different vendors...) These techniques are similar to the same problems in Unix and XServer (XServer Host & Client)...

    Here is a short quick-reference of Linux short-cuts and hot-keys to help you get around and to help diagnose graphics problems in an Linux XSession. Some are also helpful later in just everyday kind of tasks. Like I said, this is only an abbreviated list, but I included them here because they do come in handy in diagnostics and the correction of boot and video errors:

    <Ctrl><Alt><F1>
    Switch to the first text terminal. Under Linux you can have several (6 in standard setup) terminals opened at the same time. Terminals start as tty0 and go up from there. Most of the time the normal boot text console, that is present "under" the GUI or XSession (in Ubuntu) is tty1, so you would press <Cntrl><Alt><F2> to get to it...

    <Ctrl><Alt><Fn> (n=1..6)
    Switch to the nth text terminal.

    tty<Enter>
    Print the name of the terminal in which you are typing this command.

    <Ctrl><Alt><F7>
    Switch to the first GUI terminal (if X-windows is running on this terminal).

    <Ctrl><Alt><Fn> (n=7..12)
    Switch to the nth GUI terminal (if a GUI terminal is running on screen n-1). On default, nothing is running on terminals
    8 to 12, but you can run another server there.

    <Tab>
    (In a text terminal) Autocomplete the command if there is only one option, or else show all the available options.
    THIS SHORTCUT IS VERY HANDY! This also works at LILO or GRUB prompt!

    <ArrowUp>
    Scroll and edit the previous command history. You can then use that command as is or edit it to change. Press <Enter> to execute.

    <Arrow><Down>
    As above, but go back to the next command in history.

    <Shift><PgUp>
    Scroll terminal output up. Work also at the login prompt in the tty text console, so you can scroll through your bootup messages to find errors and messages. Does not work to see terminal output that has been "cleared."

    <Shift><PgDown>
    As above, but scrolls terminal output down.

    <Ctrl><Alt><+>
    (in X-windows) Change to the next X-server resolution (if you set up the X-server to more than one resolution in /etc/X11/XF86Config). For multiple resolutions on my standard XVGA card/monitor, I have the following line in the file /etc/X11/xorg.conf (the first resolution starts on default, the largest determines the size of the "virtual screen"):
    Modes "1440x900" "1024x768" "800x600" "640x480" "512x384" "480x300" "400x300" "1152x864" Whichever resolution you have as first in this line will be the default.

    <Ctrl><Alt><->
    (in XWindows) Change to the previous XServer resolution.

    <Ctrl><Atl><Backspace>
    Linux Ubuntu version 10.10 and previous- Kill the current X-session.

    <Alt>-<SysReq>-<k>
    Linux Ubuntu version 11.04 and later- Kill the current X-session.

    -- The "Linux shortcut keys" are just that, meaning Linux is already booted. to use them-- although "some" of them do work in the Grub CLI. *such as the <Tab> for autocomplete)

    Basically, between the grub menu and the GUI Desktop Manager (GDM or LightDM), where you are getting a blank screen the only short-cut keys that "may" be available are the <ctrl><alt><F1 the F6> keys and <ctrl><alt><F7> key... which I mentioned, may not work even if you were not having graphical problems.. But if they do, you have some options.


    General
    Yes, with every new release of a distribution of Ubuntu, there seems to be similar and reoccurring problems that arise with "graphics" when trying the run a LiveCD and after the initial install and first boot. These are my notes that have help people through the last 5 releases of Ubuntu, up through Ubuntu Natty Narwhal 11.04.

    Basically, we want to make sure that the Grub menu boots. then verify that the kernel is booting, then that the XServer Session starts and displays.

    Troubleshooting Flow Chart
    This is to break this down into steps:
    Step 1. Do you have a Grub Menu?
    - Yes: Go to step 2...
    - No: While booting, Press shift key (don't hold down) multiple times to see if the Grub menu will come up.
    - - If yes on Menu, go to step 2
    - - If no, comment out /etc/default/grub/ GRUB_HIDDEN_TIMEOUT=00. and rerun "update-grub" chroot'ed from a LiveCD... instructions second half of post #3.
    - - - If yes on Grub Menu go to Step 2
    - - - If No, go to my fix on "Forcing Grub To Show Menu"... Link in Post #2
    - - - - If yes on menu, go to Step 2
    - - - - If No, reinstall grub and Start Step 1 from Beginning... Because it seems that Grub is not booting.

    Step 2
    "Does the Linux Kernel Boot?" At Grub Menu, go into edit mode and boot into a text console (see instructions below)
    - Yes. Go to Step 3
    - No. Messages will be verbose on what is loading, what are warnings and what are error messages. Shortcut keys will start to work as the kernel modules load. If if stops at an error, you will be able to use the shortcut navigation cuts to review the errors. Depending on the error, if it is a kernel error, you may be able to reinstall or renew the kernel image. If it is a device module, at least you have somewhere to go to reload that device module or driver.,,, Goal is to get a "booting kernel."

    Step 3.
    From the Grub Menu, try to boot in Rescue mode/low graphics.
    - If Yes, look for additional drivers and install recommended driver.
    - If No, goto Step 4 to verify that linux kernel will boot.

    Step 4
    . Can you boot a graphical XSesion from a text console session? From the command line type
    Code:
    sudo service gdm start
    - Yes No black screen/No problem... should boot straight from the grub menu.
    - No. Reboot and start testing and changing gfx_modes and kernel boot graphical modes, still booting into the text console before you try to start an XSession. Going this way, you will have more of a possible chance to be able to toggle between a graphical session or text terminal session (sometimes). ...and at a text console, at least you have the ability to install files and make changes to config files. And if you can get back into a command prompt, you could then stop the gdm service that is locked.

    You can stop the gdm service via
    Code:
    sudo service gdm stop
    Note-- Changes/Updates. GDM was used through v11.04. v11.10, v12.04 and newer used LightDM as the Desktop Manager. If so use "lightdm" is place of "gdm."

    Digging and opening up the hood:

    If you can successfully boot grub, you are at least past point one. You can use grub as a jumping off-point- To test and see what graphical modes do work. Modes in Grub and where the linux kernel boots into does have a direct relationship to mode problems/successes when an Xorg Xsession starts.

    Here, I can mention LiveCD'es. See post 3 for notes on using these techniques with a LiveCD. To me, a LiveCD in hand, is a very valuable diagnostics and recovery tool. If you can successfully boot and display a LiveCD on your PC... You are almost there.

    A note about temporarily "editing" the kernel boot line...
    This is an example of the menu entries of a Ubuntu menu item that will display when you press "e" in a Grub menu:
    Code:
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod part_msdos
    insmod ext2
    set root='(/dev/sdb,msdos3)'
    search --no-floppy --fs-uuid --set=root 32939def-1f4a-4134-9b56-bed2319a9216
    linux    /boot/vmlinuz-2.6.38-8-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro   quiet splash vt.handoff=7
    initrd    /boot/initrd.img-2.6.38-8-generic
    The Linux kernel boot line in indicated above in red.

    Note: Something that has changed with Natty and GNU Grub 1.99~rc1... Look at the kernel boot line again, below:
    Code:
    linux    /boot/vmlinuz-2.6.38-8-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro   quiet splash vt.handoff=7
    What we used to do to help display error messages was to remove the options in blue ( quiet splash ) and type in " nosplash --verbose text " at the end of the boot line to boot into a text console (and have all the messages displayed).

    Note on the "text" option. Stopped working as of Kernel 3.x.x. I have a Luancpad and Upstream Linux (kernel.org) bug opened on this. My workaround for this is to substitute the option "single" and either use the "root prompt" or to use "resume" which should then resume to a tty text prompt.

    Notice the new option in green above (" vt_handoff=7 "). Remove this boot option now also. This new option (from the wiki)
    For a smooth boot process, we want to display something other than a black screen as early as possible and leave it on screen until the desktop is ready. vt.handoff=7 is part of this. We have the boot loader display an aubergine background (we wanted to have an Ubuntu logo as well, but there are problems with different aspect ratios between the boot loader and the real system, so this is the next best thing). vt.handoff=7 then causes the kernel to maintain the current contents of video memory on virtual terminal 7, which is a new "transparent" VT type. The first time that the kernel is told to switch away from VT 7, either from Plymouth or manually (Alt-F1, etc.), these contents are lost and VT 7 reverts to text mode.

    The upshot is that, when everything is working correctly, you get an aubergine background on the way out of the boot loader, then at some point Plymouth displays a logo and a progress indicator on top of that, and then the display manager comes up and smoothly replaces that with a login prompt.
    So if we want to see all the error messages, we now also have to remove this from the boot line temporarily while trying to find problems.

    So to boot into a text console to verify that the system is booting into Linux, we edit the above kernel boot line to look like this:
    Code:
     linux    /boot/vmlinuz-2.6.38-8-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro  nosplash --verbose text
    After editing, press <cntrl><x> and it will try to boot the menu entries. If and after the kernel boots in text mode, you will have more options to change things going into an Xsession.

    If the kernel didn't boot, check the displayed error messages. You may have a kernel image problem, where you may have to reinstall the kernel image... or a device driver/module problem.

    If you can boot the linux kernel and you know the package name of the driver you need... Reboot and get into the grub menu, cursor to the main boot menu item. press "e" > go to the kernel boot line and append " text " to the end of the line. Press ctrl-x to boot ther kernel... it will boot into a text console mode. Login as you > install the driver via apt-get or aptitude...


    Going on
    If still no Xsession. I usually check the /home/username/.xsession-errors file for errors. where can see if there is a problem with loading a driver or in acThen I go to grub... Another log to now check is var/log/kernel.log to see if vmap allocation is running out of memory on startup (look at the nvidia tips).

    If you are having problems not seeing the grub menu on boot, hold down the "shift" key.. even if the menu is set to "silent" or not to be shown, grub should be listenning for the shift key to interrupt the boot sequence. On some machines, holding the shift key down continuosly will cause a keyboard over flow-- if it does, pess the shift key multiple times instead. If it still doesn't bring up the Grub menu, commenting out /etc/default/grub/ line
    Code:
      
     # GRUB_HIDDEN_TIMEOUT=00
    sometimes helps with that... But I found a way to hardcode it in and force it to show, even on difficult hardware:
    Forcing Grub to Show Menu

    If that still doesn't bring it up after that, reinstall grub.

    Uncommenting the line in the /etc/default/grub that says gfxmode=680x480 "should" work to see graphics in that mode... sometimes.

    Here is where a lot of the "blank screen" problems arise:
    If no setting is found in /etc/default/grub, Grub2 uses the resolution established in /etc/grub.d/00_header, which is set at default to auto. The else on that is supposed to be that, but if it errors, sets to text mode, which is why some graphics errors just error out to text mode. If it "thinks" it is in a valid mode but actually isn't (or is actually locked up without returning that error code) then it is simply blank.

    In simple terms- In "auto" or if a specific graphics mode is not specified "explicitly", it tries different modes until the first one is found that does not return an error code. If that mode happens to be out of range and locks up before it returns that error code, you get a blank screen... If the mode specified is a known supported resolution mode by heigth and width (ex: 800x600), it is still going to roll through the different color depths and it still may be going out of range by an unsupported color depth setting it is trying...

    One way to test this would be to press <ctrl><alt><F1> or <cntrl><alt><F2>, then <ctrl><alt><F7>, which is supposed to be the "toggle hot-keys" between a graphics session and a text session... but I'll tell you now, that crtl-alt-F2 does not work on some of the boxes I have here that have "no" existing problems with graphics... So that may not be a valid test. Booting as above instructions noted > Into a text console if this didn't work. This will narrow things down to verify that the kernel has booted and that there “is” an Xsession problem.

    To try different kernel boot options, using "e" at the grub menu. Go to the kernel boot line... try these options (one at a time/not together):
    Code:
      
     nomodeset  
     xforcevesa  
     i915.modeset=0 xforcevesa  
     vga=xxx # Note- where xxx is a vesa mode that your card supports, such as 771
    These options, again, would be added near the end of the line, after the kernel name, For other boot options, look here:
    http://ubuntuforums.org/showthread.php?t=1613132

    Another thing you can try is to drop down the the grub CLI (command line interface) via pressing "c" while in the grub menu... While you are in the Grub CLI, you can use it to test the variable setting, set them to other settings and to see what modes your video supports.-- instead changing things (hard edits) and rebooting to see if it worked... Just just "set" and "unset" viables to change your environment variable from the command line. Such as to set the screen resolution, you should set the variable $vbe_mode before loading vbe and/or gfxmterm (default mode is 0x101 i.e. 640x480 8bpp) Test your graphics... What I last said translates to
    Code:
      
     set gfxmode=640x480  
     load_video  
     insmod gfxterm
    From the CLI you could use
    Code:
      
     GRUB> echo $linux_gfx_mode
    to see what the video mode it is currently set to... It will most likely be set at "keep". If you then
    Code:
      
     echo $gfxmode
    it will most likely say "auto' which is the default.
    [/code]
    Then use
    Code:
      
     GRUB> vbeinfo
    to get the video modes as grub sees them on your hardware. Get ready with your "pause" key as may get as many as 3 screens of info will go by faster than you can possibly read. When ready to read more, hit the enter key. "vbetest" will tell you what video mode in hex it is currently set to. You can then use these modes in the kernel boot line and append/adding a vga=xxx, where xxx is the mode. Note that this XXX value must correspond to a resolution that you had set the gfxmode to.

    Note: The 1915 driver and natty currently have know bugs with vbeinfo and the "vga=xxx" kernel switch. Please use hwinfo (below) instead, then see the i915 notes at the end of this post.

    From a Linux text console session, you can use
    Code:
      
    sudo hwinfo --framebuffer
    to find vesa video modes that your installed card supports. you may want to use
    Code:
      
    sudo hwinfo --framebuffer | more
    if the info is more than one page... Or
    Code:
      
    sudo hwinfo --framebuffer > ~/video_results.txt
    To save the result to a file in your Home Directory. If this program in not already installed, you can easily install in via
    Code:
    sudo apt-get install hwinfo
    This utiltity is very small and it well worth the few bytes of space it uses and the few seconds it takes to install.

    If you also use
    [code[
    sudo hwinfo --monitor
    [/code]It will display the modes that the monitor displays.

    Alternate method:
    If you use the application startup-manager, installed via
    Code:
    sudo apt-get install startup-manager
    it will make edits to the grub files for you... For instance, changing the following settings in Startup Manager to:
    display resolution 1024x768
    color depth 16 bit

    and under the advanced tab:
    bootloader 1024x768

    Changes to grub file section 00_header, line that says "set gfxmode=auto" to "set gfxmode-1024x768" and then add/appends vga-758 to the kernel boot line in 10_linux section... Unfortunately for most who are reading this thread, this program will not help them "until" they get a working graphical Xsession. Once they do, they could use this program to tweak their session or to Customise the default "startup" of their Grub Menu.

    After you make changes to any grub file, remember to run update-grub to pick up the changes.

    On the info returned from
    Code:
    sudo hwinfo --framebuffer
    It returns modes that your installed video card supports in a hex number format. For instance it may say 00x0303, which is 771 decimal. You can then use that the converted decimal number in the kernel boot line with a "vga=xxx" switch such as
    Code:
    linux    /boot/vmlinuz-2.6.38-8-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro   nosplash vga=771 text
    You can use the info returned in grub using vbeinfo the same way... If you are not sure what to do with these results, post them here, ensuring that you highlight the results and press the "#" button to wrap the results with code tags

    All this is too find a Mode that your hardware supports so that you can set them manually. Once you find a mode that work, then you can make it permanent.

    Now that I found something that works, how do I make it permanent?
    In a terminal:
    Code:
    cd/etc/default
    sudo gedit grub
    Edit the line "GRUB_CMDLINE_LINUX_DEFAULT". Add your new options, for example:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=771"
    Now in a terminal run
    Code:
    sudo update-grub
    Now each time you update grub and in configures the files, it will pick up these changes.

    Noteworthy Notes

    Notes on for some Laptops:
    Will inform your BIOS to use provisions for Linux:
    Code:
    acpi_osi=Linux
    Will fix some backlighting Problems:
    Quote Originally Posted by glococo View Post
    Hi,
    The best workaround for solving backlight ISSUE was for me:
    Autorun "setpci -s 00:02.0 F4.B=00" each boot.

    Steps:
    1) edit rc.local
    Code:
    gksudo gedit /etc/rc.local
    2) Add the command before EXIT 0
    Code:
    setpci -s 00:02.0 F4.B-0
    3) Restart.
    You should now be able to boot in UNITY where nomodeset was unable.
    Notes about nvidia cards and SLI
    The "nomodeset" kernel bootline switch usually works for most nVidia cards, but now all.

    Especially for nvidia cards, I usually just into a text mode by going to a text console via grub edit ('e") append " text " to the end of the kernel boot line and boot{"ctrl-x') and after a login type
    Code:
    sudo apt-get update
    sudo nvidia-installer --uninstall
    sudo apt-get remove nvidia-*
    sudo apt-get install linux-headers-'uname -r'
    sudo apt-get install nvidia-current  
    sudo nvidia-xconfig
    sudo apt-get update
    (Note- This example assumes that you have a GeoForce 6xxx or better card) then try to start the GUI via
    Code:
    sudo service gdm  start
    For Unix and Linux, some versions of Xorg will not boot when there are multiple physical instances of the same video card installed (which bridged SLI cards are) until the proprietary video driver is installed. If you have SLI and a LiveCD will not boot: Remove one SLI card > Boot the LiveCD and install the system > Install the video drivers... Install the second physical card.

    There is another problem coming up with natty and the Geoforce 9800 where the kernel is misallocating and running out of allocated addressed video memory while trying to boot. This has been resolved by allocating more memory by adding "vmalloc=192MB" to the kernel boot line.

    One other problem on the order modules are loading:
    Code:
    sudo echo RUN+="/sbin/modprobe nvidia" > /etc/udev/rules.d/90-modprobe.rules
    sudo echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf
    sudo update-initramfs -u
    ATI TIPS:
    Note that some ATI cards need flgrlx and some do not... If not then this workaround sometimes works:

    Steps for ATI users:

    1. Get to a terminal session or TTY Console

    2. Edit the sources list to include the the Conical Partner Repo's:
    Code:
    sudo vim /etc/apt/sources.list
    Then
    Code:
    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get update
    sudo apt-get remove --purge fglrx*
    sudo apt-get install fglrx
    sudo apt-get upgrade
    sudo reboot
    The above only works for some but not all, depending on what card you have and whether it actually is supported by additional drivers (proprietary). All at the moment, mostl seem to need "nomodeset radeon mode=X", where x= 0 or 1... Some ATI cards are not working with the current natty kernel, but are working with the older 2.6.37 kernel or the proposed 2.6,38.9 kerne (please see post 2)l


    Intel i915GM
    There is a known bug with this chipset and Natty. Some of the workarounds include using "i915modeset=0" and some "i815modeset=1" in the kernel boot line and going to /etc/default/grub to
    Andy Whitcroft wrote on 2010-12-02 as part of Launchpad Bug https://bugs.launchpad.net/ubuntu/+s...x/+bug/683775:

    As a work-around we can turn this off by adding the line below to /etc/default/grub and running update-grub:
    GRUB_GFXPAYLOAD_LINUX=text
    There is also an upstream Debian Bug with this driver that says if you try to use a "vga=xxx" switch on a Linux 2.6.x kernel and this driver, you will get a black screen. It further says if you use anything besides the i915's driver's internal framebuffers, it will get a black screen. So-- the "i915modeset=0" also has to be set in the kernel boot line to turn off KMS.

    Notes on KMS:

    This thread was inspired by the addition of this Wiki entry and how it's application "changed" how things worked or failed:
    Quoted from the Ubuntu Wiki (editted):
    KernelModeSetting

    Kernel mode-setting (KMS) shifts responsibility for selecting and setting up the graphics mode from X.org to the kernel. When X.org is started, it then detects and uses the mode without any further mode changes.

    Configuring KMS

    KMS is enabled by default for the -intel, -ati, and -nouveau drivers. It is not available for any other drivers at this time.

    If you need to manually adjust mode settings, the video= boot parameter is used. For example,

    video=LVDS-1:d -- Disables the LVDS
    video=VGA-1:e -- Enables VGA-1


    Turning it off


    If you need to turn KMS *off* do the following depending on the hardware in question:

    # ATI Radeon:
    echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

    # Intel:
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

    # Nvidia (this should revert you to using -nv or -vesa):
    echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf


    For some users (particularly users with encrypted volumes) KMS is enabled very early in the boot process and in order to pick up these changes you need to run sudo update-initramfs -u.
    For more "detailed" testing and configuration techniques and options (geared more for the advanced level user), please read this Wiki pages:
    https://wiki.ubuntu.com/X/Config/Resolution
    https://wiki.ubuntu.com/X/Config#hal

    And for a more detailed, consolidated list of Kernel Parameters, please see:
    http://www.kernel.org/doc/Documentat...parameters.txt

    If All Else Fails? See Post 2--
    Last edited by MAFoElffen; January 8th, 2012 at 06:34 PM. Reason: Revision / Updates
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  2. #2
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Last edited by MAFoElffen; January 5th, 2012 at 02:39 AM. Reason: Revision / Update
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  3. #3
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    To do this from a LiveCD... The first screen you will see is a black or purplish screen with an icon centered at the lower part of the screen. This icon will be a keyboard and person.



    Press escape.



    Press escape.

    At that screen, instead of picking a language, press the <esc> key. Actually you can do anyhting here, but escape is faster. It should get you to this screen:



    At this screen, it is a Casper/Isolinux Menu. Look at the lower right of the menu, where it says "F6 Other" Pressing <F6> will bring us this screen (below):



    Here (above) there is some of the most common boot up options, where you want to try "nomodeset"

    If that doesn't work, if you press <F1> for help and while in the "help menu" pressed <F6> or <F7> you would be presented with more common boot options. where you can select them with <enter> or <space> such as ...



    And when you press <esc> those entries are retained and then you can edit them. If you edit them, add your options after the double dashes ("--") That will be the linux boot line.

    What I do in my installs is to use the "try" option. That way I can ensure the hardware is being found, everything works... And If I install from the Live Image and the installer errors out, I can review the syslogs that are in the live image's memory. (I also have a way out / instead of locked up)

    To mount an installed system from a LiveCD:
    (This example is to install drivers, but similarly could be used to mount a system and reinstall grub or kernel image)

    1. Boot a Live-CD,
    2. Find your "Installed" partition, e.g. /dev/sda5 (where you've installed the OS ... the "/" partition)
    Code:
    sudo mount /dev/sda5 /mnt
    3. If you have a dedicated boot partition: sudo mount /dev/sda3 /mnt/boot
    Code:
    sudo mount -o bind /dev /mnt/dev
    sudo mount -o bind /sys /mnt/sys
    sudo mount -t proc /proc /mnt/proc
    4. "changeroot" to /mnt
    Code:
    sudo chroot /mnt /bin/bash
    5. Now you're "on" the installed system, see the chroot man page for details

    Do what you need to do from there, like install drivers, install a kernel, install grub, etc. Once you are through, Press <cntrl><x> or just enter the command "exit". That gets you out of the chroot. Then unmount your mounts... If you don't... oh well.
    Last edited by MAFoElffen; November 18th, 2011 at 06:31 AM. Reason: Revised/Updates
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  4. #4
    Join Date
    May 2008
    Beans
    19

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    hi, i booted up with a blank screen. i've tried pressing the shortcut keys you mention, none of them worked. i think most of those shortcut assume that you could bootup into linux to begin with. but i can't do anything at the bootloader right now aside from ctrl+alt+del.

  5. #5
    Join Date
    Jan 2009
    Beans
    3

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    I had the same problem.
    Solved with uncommenting(delete #) GRUB_GFXMODE=640x480 in /etc/default/grub
    Do not forget to run sudo update-grub in a terminal afterwards.

  6. #6
    Join Date
    Sep 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by KazukiFlame View Post
    hi, i booted up with a blank screen. i've tried pressing the shortcut keys you mention, none of them worked. i think most of those shortcut assume that you could bootup into linux to begin with. but i can't do anything at the bootloader right now aside from ctrl+alt+del.
    Same here, none of the shortcuts (control-alt-f1 to get to text login) or boot options (like nomodeset and so forth) work. I just get a blank screen after the grub stage.

    I didn't get a blank screen when booting up to the live usb of ubuntu 11.04, nor with 10.10, although there were other issues. I only get the blank screen when booting up to an installed 11.04.

  7. #7
    Join Date
    Jun 2007
    Beans
    193

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by dugh View Post
    Same here, none of the shortcuts (control-alt-f1 to get to text login) or boot options (like nomodeset and so forth) work. I just get a blank screen after the grub stage.

    I didn't get a blank screen when booting up to the live usb of ubuntu 11.04, nor with 10.10, although there were other issues. I only get the blank screen when booting up to an installed 11.04.
    Me too. I upgraded from 10.10, now I get grub then a black screen. Recovery mode is the same. If I select an older kernel I can get into recovery mode but that's it. I can't even seem to get a terminal.

    Phil

  8. #8
    Join Date
    Dec 2005
    Beans
    106
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    I'm getting the blank screen as well...
    <ctrl><alt><F1> or <cntrl><alt><F2>, then <ctrl><alt><F7> does not work. Ctrl-alt-del seems to be the only recognized keystrokes.

    I tried commenting out /etc/default/grub/ GRUB_HIDDEN_TIMEOUT=00. I also tried uncommenting the line in the /etc/default/grub that says gfxmode=680x480. Neither of those options worked.

    You lost me though when modifying boot loader settings. I'm able to run sudo hwinfo --framebuffer, but am not sure why to do with this info...

  9. #9
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by KazukiFlame View Post
    hi, i booted up with a blank screen. i've tried pressing the shortcut keys you mention, none of them worked. i think most of those shortcut assume that you could bootup into linux to begin with. but i can't do anything at the bootloader right now aside from ctrl+alt+del.
    Between the grub menu and the GUI GDM, where you are getting a blank screenm the only short-vut keys that "may" be available are the <ctrl><alt><F1 the F6> keys and <ctrl><alt><F7> key... which I mentioned, may not work even if you were not having graphical problems..

    1. Make sure Grub boots and you can get a menu. After booting grub, you are at least past point one. Use grub as a jumping off-point- To test and see what graphical modes do work. Modes in Grub and where the linux kernel boots into // have a direct relationship to mode problems/successes when an Xorg Xsession starts.

    2. Boot into a text console to verify that the system is booting into Linux.

    3. After kernel boots in text mode you will have more options to change things going into an Xsession.

    -- The "Linux shortcut keys" are just that, meaning Linux is already booted. to use them-- although "some" of them do work in the Grub CLI. *such as the <Tab> for autocomplete)

    Quote Originally Posted by emerick7 View Post
    I'm getting the blank screen as well...
    <ctrl><alt><F1> or <cntrl><alt><F2>, then <ctrl><alt><F7> does not work. Ctrl-alt-del seems to be the only recognized keystrokes.

    I tried commenting out /etc/default/grub/ GRUB_HIDDEN_TIMEOUT=00. I also tried uncommenting the line in the /etc/default/grub that says gfxmode=680x480. Neither of those options worked.

    You lost me though when modifying boot loader settings. I'm able to run sudo hwinfo --framebuffer, but am not sure why to do with this info...
    So-- lets break this down into steps/into a troubleshooting flow chart-->

    Step 1. Do you have a Grub Menu?
    - Yes: Go to step 2...
    - No: Whiie booting, Press shift key (don't hold down) multiple times to see if the Grub menu will come up
    - - If yes on Menu, go to step 2
    - - If no, comment out /etc/default/grub/ GRUB_HIDDEN_TIMEOUT=00. and rerun grub-update (from a LiveCD)
    - - - If yes on Grub Menu go to Step 2
    - - - If No, reinstall grub and Start Step 1 from Beginning... Becuase it seems that Grub is not booting.
    Step 2 "Does the Linux Kernel Boot?" At Grub Menu, go into edit mode and boot into a text console (instructions above)
    - Yes. Go to Step 3
    - No. Messages will be verbose on what is loading, what are warnings and what are error messages. Shortcut keys will start to work as the kernel modules load. If if stops at an error, you will be able to use the shortcut navigation cuts to review the errors. Depending on the error, if it is a kernel error, you may be able to reinstall or renew the kernel image. If it is a device module, at least you have somewhere to go to reload that device module or driver.,,, Goal is to get a "booting kernel."
    Step 3. Can you boot a graphical Xseesion from a text console session? From the command line type
    Code:
    sudo service gdm start
    - Yes No black screen/No problem... should boot straight from the grub menu.
    - No. Reboot and start testing and changing gfx_modes and kernel boot graphical modes, still booting into the text console before you try to start an Xsession. Going this way, you will have more of a possible chance to be able to toogle between a graphical session or text terminal session (sometimes). ...and at a text console, at least you have the abilty to install files and make changes to config files.

    See psot #2 for more info.
    Last edited by MAFoElffen; April 30th, 2011 at 09:30 PM.
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  10. #10
    Join Date
    Dec 2005
    Beans
    106
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    First off thanks for the reply.

    I'm at Step 2 right now... it gets stuck on "Stopping GNOME Display Manager." It seems to hang there, until I hit the enter key. At that point, I'm able to use CTRL-ALT-F1/F2 to get into the command line.

    sudo service gdm start gives me gdm start/running then a process ID. CTRL-ALT-F7 brings me to the same screen though.

    Also, I tried appending vga=318 but that did not have any effect.


    In case this helps, after "Stopping GNOME Display Manager," it says:
    speech-dispatch disabled...
    *PulseAudio configured for per-user sessions
    saned disabled; edit /etc/default/saned
    *Enabling additional executable binary formats binfmt-support
    *Starting web server apache2
    /etc/rc2.d/S99acpi-support: line 7: /usr/share/acpi-support/power-funcs: No such file or directory
    cups start/running, process 1084
    {then it has a blinking _}
    Once again, thanks for the troubleshooting!

Page 1 of 131 1231151101 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •