Page 77 of 132 FirstFirst ... 2767757677787987127 ... LastLast
Results 761 to 770 of 1318

Thread: Graphics Resolution- Upgrade /Blank Screen after reboot

  1. #761
    Join Date
    Dec 2006
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by linux4me View Post
    Thanks again for keeping at this!

    You're right, post one is kind of overwhelming it has so much information.

    I did some more googling about this and found one article where the guy's solution was to install Startup Manager, which through the GUI appends a "vga=XXX" to the boot string. I tried it and it solved my problem, sort of. I set it to the monitor's native resolution and 24 bits. I now get the correct resolution, but the display is shifted about 10 px to the left. I can live with that, but I want to try your solution to see if it gives me better results; also using Startup Manager means I get an error for using the decimal value for vga instead of the hex...

    I'm rebooting now after editing /etc/default/grub with the values for my monitor via hwinfo. I'll post back.
    Even using the hex code for "vga=" I get an error message about it being deprecated, but it works. Still have the display shifted to the left a bit at 16-bits, but once into 'buntu it's right on.

    I did some more looking and it seems I should be using "gfxpayload=" instead of "vga=" to avoid the error. I'll try that next.

  2. #762
    Join Date
    Dec 2006
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by linux4me View Post
    Even using the hex code for "vga=" I get an error message about it being deprecated, but it works. Still have the display shifted to the left a bit at 16-bits, but once into 'buntu it's right on.

    I did some more looking and it seems I should be using "gfxpayload=" instead of "vga=" to avoid the error. I'll try that next.
    I must be doing something wrong. I edited /etc/default/grub and tried the following:
    Code:
    GRUB_CMDLINE_LINUX=" gfxpayload=true"
    with the graphics mode line uncommented. That didn't work.

    Then I tried:
    Code:
    GRUB_CMDLINE_LINUX=" gfxpayload=keep"
    with the graphics mode line uncommented. That didn't work.

    Then:
    Code:
    GRUB_CMDLINE_LINUX=" gfxpayload=1280x1024x16"
    with the graphics mode line commented out. That didn't work, either.

    I ran:
    Code:
    sudo update-grub
    each time.

    Now, I'm back with "vga=0x031a," which works, though I get that nasty "deprecated" error.

  3. #763
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by linux4me View Post
    Thanks again for keeping at this!

    You're right, post one is kind of overwhelming it has so much information.

    I did some more googling about this and found one article where the guy's solution was to install Startup Manager, which through the GUI appends a "vga=XXX" to the boot string. I tried it and it solved my problem, sort of. I set it to the monitor's native resolution and 24 bits. I now get the correct resolution, but the display is shifted about 10 px to the left. I can live with that, but I want to try your solution to see if it gives me better results; also using Startup Manager means I get an error for using the decimal value for vga instead of the hex...

    I'm rebooting now after editing /etc/default/grub with the values for my monitor via hwinfo. I'll post back.
    Also unfortunate to Boot Manager is that the edits go away after an update-grub...

    I used to try to explain to people how to convert the hex value to decimal so they could use it, but the vga tag takes both... so that step was not really needed. If there is an error between your hex value and a decimal value, then it was in the conversion of that value.

    I use hwinfo (and xrandr) for a lot of diagnostics and graphics setups(!!!!) I used to the VESA Mode and Linux VESA Mode number charts... But I found that all the modes on that chart don't work on other than generic hardware. When i got out in the real world, I had to get over that fence and see what modes mutually worked between specific monitors and graphics chipsets. Sometimes you can create more modes or tweak the existing modes... but if it's out-of-range, it's just that. (Beyond that now is dealing with non-standard sync and refresh rates for extended modes...)

    Another way to do this is to go in your xorg.conf file, screen section, display subsection and add a line for the Virtual Terminal
    Code:
    
    Section "Screen"     
        Identifier        "Default Screen"
        Monitor          "Configured Monitor"
        Device           "Configured Video Device"     
        DefaultDepth   24
        SubSection "Display"
            Depth         24
            Virtual        1024 768 
            Modes        "1280x1024" "1024x786" "800x600" "640x480" 
    EndSubSection
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  4. #764
    Join Date
    Dec 2006
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by MAFoElffen View Post
    Also unfortunate to Boot Manager is that the edits go away after an update-grub...

    I used to try to explain to people how to convert the hex value to decimal so they could use it, but the vga tag takes both... so that step was not really needed. If there is an error between your hex value and a decimal value, then it was in the conversion of that value.

    I use hwinfo (and xrandr) for a lot of diagnostics and graphics setups(!!!!) I used to the VESA Mode and Linux VESA Mode number charts... But I found that all the modes on that chart don't work on other than generic hardware. When i got out in the real world, I had to get over that fence and see what modes mutually worked between specific monitors and graphics chipsets. Sometimes you can create more modes or tweak the existing modes... but if it's out-of-range, it's just that. (Beyond that now is dealing with non-standard sync and refresh rates for extended modes...)

    Another way to do this is to go in your xorg.conf file, screen section, display subsection and add a line for the Virtual Terminal
    Code:
    
    Section "Screen"     
        Identifier        "Default Screen"
        Monitor          "Configured Monitor"
        Device           "Configured Video Device"     
        DefaultDepth   24
        SubSection "Display"
            Depth         24
            Virtual        1024 768 
            Modes        "1280x1024" "1024x786" "800x600" "640x480" 
    EndSubSection
    It turned out the error I was getting wasn't to do with the hex or decimal for "vga=," it was because Grub2 wants me to us "gfxpayload=," but I could never get it to work.

  5. #765
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    This should answer your last post, #774 also...
    Quote Originally Posted by linux4me View Post
    I must be doing something wrong. I edited /etc/default/grub and tried the following:
    Let me break this down for you to keep it simple. Before I start, GRUB_CMDLINE_LINUX="" is not the place to set gfxpayload, GXFMODE= is... gfxpayload's default is set to "keep". Somewhere in the scripting gfxpayload gets set by GFXMODE. If it errors, it is supposed to get set to "text". If you set gfxpayload directly, you set if by adding an additional/separate line saying gfxmode=text or whatever.
    Code:
    GRUB_CMDLINE_LINUX=" gfxpayload=true"
    with the graphics mode line uncommented. That didn't work.
    That is not a valid value for gfxpayload.
    Then I tried:
    Code:
    GRUB_CMDLINE_LINUX=" gfxpayload=keep"
    with the graphics mode line uncommented. That didn't work.
    Yhay is the default which is not worlking for you
    Then:
    Code:
    GRUB_CMDLINE_LINUX=" gfxpayload=1280x1024x16"
    with the graphics mode line commented out. That didn't work, either.
    You say this works, but agian, the place to set this is to change this section
    Code:
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    To this
    Code:
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=1280x1024x16
    I ran:
    Code:
    sudo update-grub
    each time.

    Now, I'm back with "vga=0x031a," which works, though I get that nasty "deprecated" error
    .
    You could run that script or do it manually:

    1. Install v86d, fbset and ensure usafb is there
    Code:
    sudo apt-get unstall v86 fbset uvesafb
    2. Use hwinfo to find your supported modes (which you already did...)
    Code:
    sudo hwinfo --framebuffer
    3. Open /etc/default/grub
    Code:
    gksudo gedit /etc/default/grub
    and make edits to make your line
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=vga=0x031a"
    And change to
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash options uvesafb mode_option=1280x1024-16 mtrr=3 scroll=ywrap"
    Change line (You have already)
    Code:
    #GFXMODE=640x480
    Save and exit.

    4. Open the /etc/mod
    Code:
    GFXMODE=1280x1024x16
    4. Open /etc/modprobe.d/blacklist-framebuffer.conf
    Code:
    gksudo gedit /etc/modprobe.d/blacklist-framebuffer.conf
    and ensure that the line containing
    Code:
    balcklist uvesafb
    is commented out like this
    Code:
    # blacklist uvesafb
    5. Open file /etc/modules
    Code:
    gksudo /etc/modules
    and add a separate line saying
    Code:
    uvesafb
    6. Update Grub
    Code:
    sudo update-grub
    7. Update the intial boot ram disk.
    Code:
    sudo update-initramfs -u
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  6. #766
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Reset Authoritiies Profile for Logging Into X

    Can you toggle to a text console? <cntrl><alt><F2>

    If not look here to boot to a TTY text console temporarily:
    http://ubuntuforums.org/showpost.php...&postcount=715

    Once in a tty prompt and logged in:
    Code:
    
    sudo rm .Xauthority* 
    touch .Xauthority 
    chmod 600 .Xauthority
    sudo shutdown -r reboot
    That should reset the authorities profile for X.

    <<Linked from Table Of Contents>>
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  7. #767
    Join Date
    Aug 2006
    Location
    Nashville, TN.
    Beans
    95
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Thanks MAFoElffen,

    My /etc/default/grub line is now:
    Code:
    >>>>>>>> snip <<<<<<<<<<<<
    GRUB_CMDLINE_LINUX_DEFAULT="--verbose single nomodeset"
    
    >>>>>>>>>>>>>>>>> snip <<<<<<<<<<<<<<
    When the regular 3.0.0-12-generic kernel boots I get unreadable test on the monitor. I am also unable to ssh into the machine. You are correct, this is the first issue we need to resolve.

    The contents of:
    Code:
    lspci -vnn | grep VGA
    01:00.0 VGA compatible controller [0300]: nVidia Corporation NV44A [GeForce 6200] [10de:0221] (rev a1) (prog-if 00 [VGA controller])
    I have also returned to post 619 where under v11.04 we modified the /etc/X11/xorg.conf file. My current /etc/X11/xorg.conf file contains:
    Code:
    cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 285.05.09  (buildmeister@swio-display-x86-rhel47-02.nvidia.com)  Fri Sep 23 19:18:19 PDT 2011
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # This is the monitor section the Princeton Monitor.
        Identifier     "Monitor0"
        VendorName     "Princeton Graphics Systems"
        ModelName      "Model EO500"
        HorizSync       30.0 - 70.0
        VertRefresh     50.0 - 120.0
        # This is the published modes of the Princeton monitor model EO500.
        Modeline "1280x1024 68.00"  124.00  1280 1368 1496 1712  1024 1027 1034 1067 -hsync +vsync
        Modeline "1024x768 85.00"    94.50  1024 1096 1200 1376   768  771  775  809 -hsync +vsync
        Modeline "1024x768 75.00"    82.00  1024 1088 1192 1360   768  771  775  805 -hsync +vsync
        Modeline "800x600 85.00"     56.75   800  848  928 1056   600  603  607  633 -hsync +vsync
        Modeline "800x600 75.00"     49.00   800  840  920 1040   600  603  607  629 -hsync +vsync
        Modeline "640x480 85.00"     35.00   640  664  728  816   480  483  487  507 -hsync +vsync
        Modeline "640x480 75.00"     30.75   640  664  728  816   480  483  487  504 -hsync +vsync
        Option "PreferredMode"   "1280x1024 66.00"
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BusID          "PCI:1:0:0"
    EndSection
    
    Section "Screen"
         # This is the screen for the Princeton montitor
         Identifier     "Screen0"
         Device         "Device0"
         Monitor        "Monitor0"
         DefaultDepth    24
         SubSection     "Display"
             Viewport    0 0
             Depth       24
             Modes       "1280x1024" "1024x768" "800x600" "640x480"
         EndSubSection
    EndSection
    I could have made an error in judgment but, the red highlighted text was necessary to get a working monitor with readable fonts under v11.04. This being important info you might need.

    The number one problem is still the unreadable fonts during boot.

  8. #768
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Hi! MaFoElffen,
    I posted: (Post 741 p75)
    !Eureka! It worked!! well 99% anyway!
    The 1% is the Panel problem, and this:

    With both Ubuntu 11.04 and 11.10 running on 2.6.8-8, changing the default of the Grub menu within Startup Manager had no effect on the menu displayed, it stayed as the first item.
    Now 11.10 is running on 3.0.0-12, changing the default of the Grub menu within Startup Manager changes the default displayed, but not to the one selected.

    The problem seems to be that both update-grub and Startup Manager recognize and list the previous versions of 11.04 2.6.38-8, -11 and -12,( the last two being corrupted updates partially installed); whereas the grub menu display does not.

    So, to get Vista as the default. I have to pick an entry six places away and hope for the best. By trial and error I got there eventually.
    Is there some way I can get rid of these useless listings, or to recover the 11.04 as a usable alternative if 11.10 goes ****-up?
    Say, for example:
    Code:
     sudo apt-get remove --purge Linux-headers-2.6.38-xx-generic
     or:
    sudo apt-get install --purge Linux-headers-2.6.38-xx-generic
    and:
    sudo apt-get install --reinstall Linux-headers-2.6.38-8-generic
    If something like that worked, would I then have to re-run:
    Code:
     sudo apt-get dpkg-reconfigure nvidia-current
     and:
     sudo nvidia-xconfig
    ??

    If it is:'Yes', would you please confirm the exact correct phrasing ?

    Thanks again for your valuable and appreciated support.
    Chao! bogan. Or, if you prefer it: Ciao!
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  9. #769
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by bobwdn View Post
    Thanks MAFoElffen,

    My /etc/default/grub line is now:
    Code:
    >>>>>>>> snip <<<<<<<<<<<<
    GRUB_CMDLINE_LINUX_DEFAULT="--verbose single nomodeset"
    
    >>>>>>>>>>>>>>>>> snip <<<<<<<<<<<<<<
    When the regular 3.0.0-12-generic kernel boots I get unreadable test on the monitor. I am also unable to ssh into the machine. You are correct, this is the first issue we need to resolve.

    The contents of:
    Code:
    lspci -vnn | grep VGA
    01:00.0 VGA compatible controller [0300]: nVidia Corporation NV44A [GeForce 6200] [10de:0221] (rev a1) (prog-if 00 [VGA controller])
    I have also returned to post 619 where under v11.04 we modified the /etc/X11/xorg.conf file. My current /etc/X11/xorg.conf file contains:
    Code:
    cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 285.05.09  (buildmeister@swio-display-x86-rhel47-02.nvidia.com)  Fri Sep 23 19:18:19 PDT 2011
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # This is the monitor section the Princeton Monitor.
        Identifier     "Monitor0"
        VendorName     "Princeton Graphics Systems"
        ModelName      "Model EO500"
        HorizSync       30.0 - 70.0
        VertRefresh     50.0 - 120.0
        # This is the published modes of the Princeton monitor model EO500.
        Modeline "1280x1024 68.00"  124.00  1280 1368 1496 1712  1024 1027 1034 1067 -hsync +vsync
        Modeline "1024x768 85.00"    94.50  1024 1096 1200 1376   768  771  775  809 -hsync +vsync
        Modeline "1024x768 75.00"    82.00  1024 1088 1192 1360   768  771  775  805 -hsync +vsync
        Modeline "800x600 85.00"     56.75   800  848  928 1056   600  603  607  633 -hsync +vsync
        Modeline "800x600 75.00"     49.00   800  840  920 1040   600  603  607  629 -hsync +vsync
        Modeline "640x480 85.00"     35.00   640  664  728  816   480  483  487  507 -hsync +vsync
        Modeline "640x480 75.00"     30.75   640  664  728  816   480  483  487  504 -hsync +vsync
        Option "PreferredMode"   "1280x1024 66.00"
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BusID          "PCI:1:0:0"
    EndSection
    
    Section "Screen"
         # This is the screen for the Princeton montitor
         Identifier     "Screen0"
         Device         "Device0"
         Monitor        "Monitor0"
         DefaultDepth    24
         SubSection     "Display"
             Viewport    0 0
             Depth       24
             Modes       "1280x1024" "1024x768" "800x600" "640x480"
         EndSubSection
    EndSection
    I could have made an error in judgment but, the red highlighted text was necessary to get a working monitor with readable fonts under v11.04. This being important info you might need.

    The number one problem is still the unreadable fonts during boot.
    Yes, you need to use that xorg.conf...
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

  10. #770
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics Resolution- Upgrade /Blank Screen after reboot

    Quote Originally Posted by bogan View Post
    Hi! MaFoElffen,
    I posted: (Post 741 p75)The 1% is the Panel problem, and this:

    With both Ubuntu 11.04 and 11.10 running on 2.6.8-8, changing the default of the Grub menu within Startup Manager had no effect on the menu displayed, it stayed as the first item.
    Now 11.10 is running on 3.0.0-12, changing the default of the Grub menu within Startup Manager changes the default displayed, but not to the one selected.

    The problem seems to be that both update-grub and Startup Manager recognize and list the previous versions of 11.04 2.6.38-8, -11 and -12,( the last two being corrupted updates partially installed); whereas the grub menu display does not.

    So, to get Vista as the default. I have to pick an entry six places away and hope for the best. By trial and error I got there eventually.
    Is there some way I can get rid of these useless listings, or to recover the 11.04 as a usable alternative if 11.10 goes ****-up?
    Say, for example:
    Code:
     sudo apt-get remove --purge Linux-headers-2.6.38-xx-generic
     or:
    sudo apt-get install --purge Linux-headers-2.6.38-xx-generic
    and:
    sudo apt-get install --reinstall Linux-headers-2.6.38-8-generic
    If something like that worked, would I then have to re-run:
    Code:
     sudo apt-get dpkg-reconfigure nvidia-current
     and:
     sudo nvidia-xconfig 
    ??

    If it is:'Yes', would you please confirm the exact correct phrasing ?

    Thanks again for your valuable and appreciated support.
    Chao! bogan. Or, if you prefer it: Ciao!
    See Above In Red >> Don't Do That! No need to reinstall drivers when they already work.

    You upgraded from version 11.04 to version 11.10. Version 11.04 doesn't exist on your PC anymore. There may be some older kernels still present, which get seen by Grub2 and the OS_Prober.

    Sounds like your goal is the cleanup and restructure your grub menu, right? You have 2 kernels that you say are corrupted? You don't want them in the menu or want them to be reinstalled? You want to know how to do this manually? Tell me how you want the menu to end up as...

    Please post your /boot/grub/grub.cfg file...
    Last edited by MAFoElffen; October 29th, 2011 at 05:16 PM.
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

Page 77 of 132 FirstFirst ... 2767757677787987127 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •