Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Speedtest.net doesn't start the test

  1. #1
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Speedtest.net doesn't start the test

    Hello. I am new to Ubuntu and there is probably something I missed.
    When trying to test my internet speed on www.speedtest.net I can not run the test. The map with the test servers shows up as normal, you point the cursor to some location and it shows the city. So far so good.
    You click on the city and nothing happens.

    As far as I know, I have installed flashplugin-nonfree and java plugin (don't remember the exact package name). My Ubuntu is 64bit but I have also installed the 32bit java plugin and I thought it actually helped. I remember once I was able to run the test.
    Then without any changes to firefox, it doesn't want to start same as before installing java plugin.
    Are there more packages to install?
    In System -> Preferences I can see control panel for both Java and Java 32bit, opened both and under Java tab in View it shows the plugin as enabled. Also firefox preferences show JavaScript and Java enabled, haven't touched those.

    Thanks in advance.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  2. #2
    Join Date
    Nov 2008
    Location
    Salem, Oregon
    Beans
    15
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Speedtest.net doesn't start the test

    Darkod. I had the exact same problem although I'm using 32 bit Xubuntu 9.10. In my case the problem was a conflict with kdocker. Starting firefox without kdocker solved the problem.
    Ralph

  3. #3
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Speedtest.net doesn't start the test

    Thanks for the reply. I will look into it but it seems it's not the same problem. Judging by the name kdocker is used in KDE or Kubunu, while I am running Ubuntu with gnome.
    But you made a valid point, I am also starting firefox from the shortcut on the top bar, I will try from the App menu to see what happens.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  4. #4
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Speedtest.net doesn't start the test

    I have tried anything I could think of with my limited Ubuntu experience. I think the problem is the java applet not executing but don't know how to check.

    I have removed all java packages with --purge option, inclusing sun-java6-bin, sun-java6-plugin and sun-java6-fonts. After that I installed them again. I also installed ia32-sun-java6-plugin which should be the 32bit plugin.

    I have tried with the 64bit plugin disabled and enabled, no change.

    I looked in firefox in aboutlugins and all java plugins seem to be working and are enabled.

    My system is Desktop 64bit, can that be the problem? What am I missing?
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  5. #5
    Join Date
    Nov 2008
    Location
    Salem, Oregon
    Beans
    15
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Speedtest.net doesn't start the test

    Have you tried the 64 bit Adobe Flash Plugin?
    Ralph

  6. #6
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Speedtest.net doesn't start the test

    I don't think the problem is flash, but I removed it anyway and made sure I install the 64bit version. Didn't help.
    If flash is the problem then the sppedtest.net would not open at all, not the part with the server locations. After that I think java takes over for the actual speed test and that's the hiccup. Even though all java plugins seem installed and enabled, it doesn't work.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  7. #7
    Join Date
    Nov 2008
    Location
    Salem, Oregon
    Beans
    15
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Speedtest.net doesn't start the test

    Sorry I couldn't have been more help. As I said in my first post my problem was a conflict with Kdocker, a dock to tray program similar to Alltray or the Firetray Firefox extension. As far as I know these programs have nothing to do with Java or Flash. You might try checking for conflicts with other running programs or Firefox extensions.

    Ralph

  8. #8
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Speedtest.net doesn't start the test

    Got it sorted. It was a problem with the flash plugin. It seems that test does not even use java. For 64bit Ubuntu you have to make sure you get the 64bit flash plugin, it turned out just downloading a library and copying it to plugins folder does the trick.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  9. #9
    Join Date
    Jul 2008
    Beans
    6

    Re: Speedtest.net doesn't start the test

    hmmm...i wish that's all there was to it. i put the 64 bit libflashplayer.so into ~/.mozilla/plugins, and still no dice for me...

  10. #10
    Join Date
    Oct 2008
    Location
    Down Under
    Beans
    1,566
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Speedtest.net doesn't start the test

    Quote Originally Posted by timothydonohue View Post
    hmmm...i wish that's all there was to it. i put the 64 bit libflashplayer.so into ~/.mozilla/plugins, and still no dice for me...
    I put mine in
    Code:
    /usr/lib/mozilla/plugins

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •