Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Disable window maximize when titlebar dragged to top of screen?

  1. #1
    Join Date
    Jul 2007
    Beans
    14

    Disable window maximize when titlebar dragged to top of screen?

    I just updated to 11.04. I tried to keep an open mind while using Unity, but I just couldn't deal with the totally unorganized application menu, so I switched back to the regular Gnome desktop.

    There's something that bugs me, though: when I drag the titlebar of a window up to the top of the screen, it maximizes the window, or more accurately, it "grows" the window depending on how far up I drag it, up to the maximum size of the screen. I don't have any desire to use this method to make my windows larger, and it also prevents me from dragging windows to the virtual desktop above the current one (I have edge-flipping turned on).

    Does anyone know how to disable this? I installed the compiz config manager installed but can't seem to find the right option.

  2. #2
    Join Date
    Jan 2011
    Location
    Kansas City, KS
    Beans
    1,274
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Disable window maximize when titlebar dragged to top of screen?

    The plugin you need to disable is called the "Grid." = )
    ~ I know I shouldn't use tildes for decoration, but they always make me feel at home. ~

  3. #3
    Join Date
    Jul 2007
    Beans
    14

    Re: Disable window maximize when titlebar dragged to top of screen?

    Quote Originally Posted by Copper Bezel View Post
    The plugin you need to disable is called the "Grid." = )
    Worked like a charm. Thank you!
    Last edited by wch; April 30th, 2011 at 12:18 AM.

  4. #4
    Join Date
    Jan 2011
    Location
    Kansas City, KS
    Beans
    1,274
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Disable window maximize when titlebar dragged to top of screen?

    Cool. = ) Just please mark the thread as "Solved." (Thread Tools, upper right.)
    ~ I know I shouldn't use tildes for decoration, but they always make me feel at home. ~

  5. #5
    Join Date
    Nov 2009
    Beans
    13

    Re: Disable window maximize when titlebar dragged to top of screen?

    Quote Originally Posted by Copper Bezel View Post
    The plugin you need to disable is called the "Grid." = )
    Thanks. This helped me too. I find every time I go to a new version of Ubuntu hoping to enjoy new features, I end up spending all my time figuring out how to get rid of the new "features".

  6. #6
    Join Date
    May 2011
    Beans
    1

    Re: Disable window maximize when titlebar dragged to top of screen?

    Personally I think The Grid plugin has some neat features in it like letting you resize windows using Ctrl+Alt+Number Pad.

    If you want to keep that functionality but remove the Maximize when you drag a window to the top do the following:

    - Open CompizConfig Settings Manager
    - Click on the "Grid" in the "Window Management" category
    - Click on the "Edges" tab
    - Open the "Resize Actions" drop down
    - Change the "Top Edge" drop down to "None"
    - Close CompizConfig and you're all done.

  7. #7
    Join Date
    Jan 2010
    Beans
    1

    Re: Disable window maximize when titlebar dragged to top of screen?

    Note that if you don't have the CompizConfig Setting Manager installed, you can use gconf-editor (start it from terminal) and go to :

    - apps -> compiz-1 -> pluging -> grid -> screen0 -> options -> top_edge_action

    set this value to 0

    relief!

  8. #8
    Join Date
    May 2007
    Location
    albuquerque
    Beans
    561
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Disable window maximize when titlebar dragged to top of screen?

    Quote Originally Posted by stevecomrie View Post
    If you want to keep that functionality but remove the Maximize when you drag a window to the top do the following:

    - Open CompizConfig Settings Manager
    - Click on the "Grid" in the "Window Management" category
    - Click on the "Edges" tab
    - Open the "Resize Actions" drop down
    - Change the "Top Edge" drop down to "None"
    - Close CompizConfig and you're all done.
    Quote Originally Posted by Marji View Post
    Note that if you don't have the CompizConfig Setting Manager installed, you can use gconf-editor (start it from terminal) and go to :

    - apps -> compiz-1 -> plugins -> grid -> screen0 -> options -> top_edge_action

    set this value to 0
    Very nice tips -- thanks!

  9. #9
    Join Date
    Sep 2009
    Beans
    5

    Re: Disable window maximize when titlebar dragged to top of screen?

    Good, that's been annoying me for months. I wish Ubuntu wouldn't introduce new functionality that upsets the status quo without warning, but that seems their policy now, and why I'm moving to Mint.

  10. #10
    Join Date
    Jan 2009
    Beans
    1

    Re: Disable window maximize when titlebar dragged to top of screen?

    Just moved to Mint a few days ago. Since it's based on Ubuntu, it also had this "feature". I found this thread very helpful in disabling. Thanks stevecomrie!

    Too bad though, I've been with Ubuntu since 8.04. Unity is a big step backwards. It may be ok for novice uses that like to run apps full screen. Otherwise the global menu is awful.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •